Recent Topics
Debating repowering my tower.
by Colt45ws. 09/20/18 01:10 AM
Oil filter for GM 8.1l V8?
by KenO. 09/19/18 11:10 PM
Help! No high beam
by wolf_06. 09/19/18 11:02 PM
Heading for divorce
by barkingspider. 09/19/18 11:02 PM
Oil recommendation: 1991 Nissan D21 truck
by RDY4WAR. 09/19/18 10:04 PM
Cold starting and CCS etc.
by CT8. 09/19/18 10:03 PM
Whine->Dead car(electrical)
by madRiver. 09/19/18 09:59 PM
Differential Allen Drain Bolt Buggered
by Gebo. 09/19/18 09:41 PM
Pick my oil. 25k miles a year
by Serge. 09/19/18 09:41 PM
Ok to use in Kubota? Pennsoil 0w-40
by racinjason. 09/19/18 09:35 PM
Road Hugger GTP A/S Tires
by Bud_One. 09/19/18 09:16 PM
Gravity Bleeding Clutch?hel
by Spetz. 09/19/18 09:10 PM
Drunken Watch?
by StevieC. 09/19/18 09:01 PM
New Forum Member New Truck Owner
by FarmerDude. 09/19/18 08:35 PM
Valvoline DOT 3/4?
by DJ. 09/19/18 08:22 PM
Best grease for AWD actuator disconnect?
by Bman90. 09/19/18 08:14 PM
Reconditioning a 2-Stroke Snow Blower
by Finz. 09/19/18 07:55 PM
Liquimoly Anti Friction - $6.83 Shipped/ Can
by ad244. 09/19/18 06:57 PM
ACEA spec for old Toyota??
by alexmarjanovic98. 09/19/18 06:54 PM
3.5EB Gen II: Oil & Interval
by Gene K. 09/19/18 06:09 PM
Newest Members
FarmerDude, Bman90, Alday714, Joephoto, tlelectric
66021 Registered Users
Who's Online Now
17 registered members (Bailes1992, BlakeB, asand1, deoxy4, 5 invisible), 712 guests, and 47 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,698
Posts4,848,458
Members66,021
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Old Volvo - oil light at startup idle...then goes #4615821
12/27/17 02:59 PM
12/27/17 02:59 PM
Joined: Jun 2006
Posts: 1,486
Peterborough
ryan2022 Offline OP
ryan2022  Offline OP
Joined: Jun 2006
Posts: 1,486
Peterborough
Hi guys,

I picked up the old Volvo 940 non turbo and the oil light stays on at idle.

If I give it a quick shot of gas it goes out and stays out.....until I shut the car off and start it again.

Hot or cold....the light stays on at idle....and will eventually go out on its own, but usually only after I've hit the gas.

***I changed the oil and filter from a Fram and 5w30 high mileage, to a Mann and 10w30 Dino and it didn't do it for two days.....now after some driving it's doing it again.

What are your thoughts? Oil pressure sender? Oil pump crud? Bearings?

Either way, this car has so many issues I'm thinking about buying something newer.

It's too bloody cold to work on it right now.

Thoughts?


2011 Subaru Impreza Hatchback 5w30 kendall synthetic blend

2007 Hyundai Entourage 5w20

1995 Nishiki Navajo mountain bike....some kind of chain oil.
Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4615832
12/27/17 03:07 PM
12/27/17 03:07 PM
Joined: Mar 2017
Posts: 568
West Ma.
rollinpete Offline
rollinpete  Offline
Joined: Mar 2017
Posts: 568
West Ma.
I'd start with the oil pressure sender...


Pete.
97 Ford Expl.Sport 4.0 ohv 4wd 5spddrive184k miles
Last Change;
Penn. Plat. HM. 5w30
Fram xg8a, Fram CA8141

I like my oil (slippery).

Re: Old Volvo - oil light at startup idle...then goes [Re: rollinpete] #4615848
12/27/17 03:20 PM
12/27/17 03:20 PM
Joined: Jun 2006
Posts: 1,486
Peterborough
ryan2022 Offline OP
ryan2022  Offline OP
Joined: Jun 2006
Posts: 1,486
Peterborough
Thanks. I have one on order and it's easy to get to. Fingers crossed!

To me...it wouldn't make sense that it was the bearings, as it didn't do it for a while after the oil was changed and is intermittent.

I figured if it's the engine, it should do it at idle regardless, and not go out and be fine one minutes and not the next.


2011 Subaru Impreza Hatchback 5w30 kendall synthetic blend

2007 Hyundai Entourage 5w20

1995 Nishiki Navajo mountain bike....some kind of chain oil.
Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4615858
12/27/17 03:31 PM
12/27/17 03:31 PM
Joined: May 2013
Posts: 2,093
Saskatchewan, Canada
Johnny2Bad Offline
Johnny2Bad  Offline
Joined: May 2013
Posts: 2,093
Saskatchewan, Canada
Oil pressure sender, Oil pump gear wear, or main bearing wear. An oil passage obstruction would increase oil pressure, so it's not that.

All normal for a high mileage engine. Some people would drop the pan and replace the pump and bearings, but as long as your oil light is going out after initially lighting, you can probably just run the thing and it will last probably as long as it was going to last in the first place. Loose main bearing clearance makes for easier winter starts, as you are in southern Ontario that might matter to you.


'57 FL Straight 50 wt
'90 Miata 1.8L w/Rotrex Supercharger [Mobil1 0W-40]
'96 Ram 1500 [3.7L Mobil1 0W-20 / 1L 15W-50]
'01 PT Cruiser [Mobil1 0W-40]
Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4615891
12/27/17 03:57 PM
12/27/17 03:57 PM
Joined: May 2012
Posts: 452
Connecticut
Sam_Julier Offline
Sam_Julier  Offline
Joined: May 2012
Posts: 452
Connecticut
Oil pressure sender.

Sam


2005 Highlander 3.3L PC Duron 0W30, 47k
1993 Volvo 245 Delo 10W30, 140k
1993 Volvo 244 Delo 10W30, 152k

Re: Old Volvo - oil light at startup idle...then goes [Re: Johnny2Bad] #4615903
12/27/17 04:02 PM
12/27/17 04:02 PM
Joined: Dec 2016
Posts: 6,226
Waco, TX
Linctex Offline
Linctex  Offline
Joined: Dec 2016
Posts: 6,226
Waco, TX
I think the sender is working fine.

They usually fail "hard" (either 100% or 0%, nothing in between)

Originally Posted By: Johnny2Bad
Oil pump wear, or main bearing wear.


It wouldn't be the first bad oil pump I have ever changed.


"The evidence demands a verdict".
(Re:VOA)"it's nearly impossible to actually know the particular additives that are in there at what concentrations."
Re: Old Volvo - oil light at startup idle...then goes [Re: Sam_Julier] #4615906
12/27/17 04:03 PM
12/27/17 04:03 PM
Joined: Jun 2006
Posts: 1,486
Peterborough
ryan2022 Offline OP
ryan2022  Offline OP
Joined: Jun 2006
Posts: 1,486
Peterborough
Thanks a ton guys. Fingers crossed.

The motor has roughly 120k miles so not terribly high for these.

I'm feeling more optimistic though!


2011 Subaru Impreza Hatchback 5w30 kendall synthetic blend

2007 Hyundai Entourage 5w20

1995 Nishiki Navajo mountain bike....some kind of chain oil.
Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4615962
12/27/17 05:04 PM
12/27/17 05:04 PM
Joined: Jan 2003
Posts: 3,203
Southeastern, PA
Rick in PA Offline
Rick in PA  Offline
Joined: Jan 2003
Posts: 3,203
Southeastern, PA
Oil pressure switches have hysteresis, i.e. they switch off at a slightly higher pressure than they switch on. My car switches off at ~7psi, and switches on at between 2 and 4 psi.

I had a discussion about oil pressures recently with my brother, a long time mechanic. He said it's not unusual for oil pressure to drop very low at idle, and it's generally not a problem. In fact one car manufacturer was having a problem with the oil light coming on, the factory fix was to install a pressure switch with a lower setting.

I'd say your car is operating in the dead band during idle. Once you get over the "switch off" pressure, the light stays out because it doesn't drop below the "switch on" pressure.


A wise man told me:
"Heat is your friend." and "Any oil is better than no oil."
Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4616018
12/27/17 05:51 PM
12/27/17 05:51 PM
Joined: Dec 2014
Posts: 1,671
'murica
Ethan1 Offline
Ethan1  Offline
Joined: Dec 2014
Posts: 1,671
'murica
This is all just WAGs until you get a pressure gauge on it shrug

Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4616029
12/27/17 06:03 PM
12/27/17 06:03 PM
Joined: Jul 2008
Posts: 1,090
British Columbia, Canada
ecotourist Offline
ecotourist  Offline
Joined: Jul 2008
Posts: 1,090
British Columbia, Canada
Originally Posted By: ryan2022
The motor has roughly 120k miles so not terribly high for these.

120,000 miles is not high at all.

I assume it's not making any funny noises? Unless the new oil pressure sending unit "fixes" the problem, I'd get a pressure gauge on it.


2000 BMW 528i 5MT
2007 Honda Accord EX-L 4Door V6 6MT
Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4616044
12/27/17 06:19 PM
12/27/17 06:19 PM
Joined: Sep 2010
Posts: 7,485
S California
OneEyeJack Offline
OneEyeJack  Offline
Joined: Sep 2010
Posts: 7,485
S California
Try a mechanical gauge?

Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4616292
12/28/17 01:32 AM
12/28/17 01:32 AM
Joined: Jul 2012
Posts: 663
Perth, Western Australia
Brad_C Offline
Brad_C  Offline
Joined: Jul 2012
Posts: 663
Perth, Western Australia
Similar symptoms to popping an o-ring out of the oil delivery tube that runs from the pump to the block. 120k is only just run in for a b230, so it's most likely to be the o-rings, a duff oil pump (very rare on a b230) or a duff oil pressure switch. A gauge will make quick work of the diagnostics.

Because of the baffle in the sump, unfortunately you need to drop the sump to check the delivery tube as you can't get a bore scope up there.

Re: Old Volvo - oil light at startup idle...then goes [Re: ryan2022] #4628741
01/08/18 10:21 PM
01/08/18 10:21 PM
Joined: Jun 2006
Posts: 1,486
Peterborough
ryan2022 Offline OP
ryan2022  Offline OP
Joined: Jun 2006
Posts: 1,486
Peterborough
thanks guys for all that responded. Just to follow up, it was the oil pressure switch.

i finally got it installed tonight after 2 weeks of -20 and below!!

now on to the e brake cable....brake pads.. tie rod... stereo.....locking system....ahh..I think thats it lol

Happy New year!

Ryan


2011 Subaru Impreza Hatchback 5w30 kendall synthetic blend

2007 Hyundai Entourage 5w20

1995 Nishiki Navajo mountain bike....some kind of chain oil.

BOB IS THE OIL GUY® Powered by UBB.threads™