Recent Topics
Oil thickness on the dipstick
by Idlewild294. 09/21/18 05:40 PM
Chinese WIX Trans filter bad, let me down..
by jetmech1. 09/21/18 04:47 PM
Gen 8 Accord rear brakes-What tool?
by fdcg27. 09/21/18 04:30 PM
Ammeters?
by buck91. 09/21/18 03:55 PM
Need Help with Double D Knockers
by user52165. 09/21/18 03:41 PM
Opinion needed....
by Duffyjr. 09/21/18 02:56 PM
2017 nissan sentra
by jahwarrior1423. 09/21/18 02:47 PM
I Need A Safe Space- lol
by Zee09. 09/21/18 02:29 PM
Liqui Moly
by dawgn86. 09/21/18 02:10 PM
Valve issues
by kawie_guy. 09/21/18 01:54 PM
2018 Elantra SE
by wolf_06. 09/21/18 01:36 PM
Nasty looking oil filter
by atikovi. 09/21/18 12:43 PM
Laughing hard.
by StevieC. 09/21/18 12:26 PM
Apologies
by Drew99GT. 09/21/18 12:15 PM
Would Like the Manual Transmission to Make a Comeback?
by Speak2Mountain. 09/21/18 11:39 AM
Leaf Mulcher
by kwijibo. 09/21/18 11:32 AM
Pizza dough too crusty
by zorobabel. 09/21/18 11:26 AM
Newest Members
JRMFt11, Navyretired, aikwae, ScottRousell, Direct_Rejection
66036 Registered Users
Who's Online Now
101 registered members (Ablebody, A310, ABomb369, 928, Astro14, 9 invisible), 1,695 guests, and 42 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,785
Posts4,850,255
Members66,036
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
2006 Chrysler 300 Limited #4609489
12/20/17 06:06 PM
12/20/17 06:06 PM
Joined: Feb 2009
Posts: 59
ny
jeep58 Offline OP
jeep58  Offline OP
Joined: Feb 2009
Posts: 59
ny
I have this car with dual climate control, Today turn on the heat heat and one side is ice cold other side is hot both temp control knobs are on high. Look on the internet some say its the heat blend door actuator but the sir comes out where ever you point the knob too ie: floor defrost etc. any ideas ?

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609506
12/20/17 06:30 PM
12/20/17 06:30 PM
Joined: Aug 2017
Posts: 209
Cincinnati, USA
Dave9 Offline
Dave9  Offline
Joined: Aug 2017
Posts: 209
Cincinnati, USA
Don't know about a Chrysler 300 specifically, but on many vehicles the blend door is an electric motor while the vent selection is vac based. This means where the air comes out doesn't necessarily mean anything. Again none of my info is Chrysler 300 specific.

I'd tear the dash down to the blend door for the side that isn't working right, pull the electrical plug and confirm it's getting power when it should change state with the dash controls. Could be wiring, more likely motor, or the door shaft could have broken off. Doorman makes replacement doors for some vehicles and depending on how it needs to be pulled out, might have a repair kit that's usually just including some foil tape to hold it together if it has to be cut to pull the blend door out.

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609574
12/20/17 07:47 PM
12/20/17 07:47 PM
Joined: Sep 2015
Posts: 1,525
USA
mk378 Online content
mk378  Online Content
Joined: Sep 2015
Posts: 1,525
USA
First confirm that the cooling system is full before tearing anything down.

The control panel and motor system should have a self test mode.

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609605
12/20/17 08:12 PM
12/20/17 08:12 PM
Joined: Feb 2013
Posts: 10,689
Phoenix, AZ
Nick1994 Offline
Nick1994  Offline
Joined: Feb 2013
Posts: 10,689
Phoenix, AZ
There's likely multiple electric motors, and the temperature one for the cold side is bad.

My grandparent's Trailblazer basically does the same thing. But when we need heat I just turn off the drivers side vents manually and point the passenger ones over toward the drivers side. Works good enough.


2015 Hyundai Sonata 2.4L 84k Mobil 1 AFE 0w30 & OEM
2000 Toyota Camry 2.2L 230k Valvoline 5w30 & Fram Ultra
1996 Jeep Cherokee 4.0L 147k Mobil 1 HM 10w40 & Fram Ultra
Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609669
12/20/17 09:10 PM
12/20/17 09:10 PM
Joined: Feb 2009
Posts: 59
ny
jeep58 Offline OP
jeep58  Offline OP
Joined: Feb 2009
Posts: 59
ny
Thanks thinking yes it may be a bad motor,and yes it is full of antifreeze.

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4610671
12/21/17 10:19 PM
12/21/17 10:19 PM
Joined: Feb 2009
Posts: 59
ny
jeep58 Offline OP
jeep58  Offline OP
Joined: Feb 2009
Posts: 59
ny
Problem solved Had to re calibrate the climate control unit, took it out and unplugged the unit wait 30 seconds and plug back in worked, dealer will do it for you with a star scan tool, reading on internet found a way around it one win for consumer!


BOB IS THE OIL GUY® Powered by UBB.threads™