Recent Topics
Internet Network Issues
by ZeeOSix. 12/13/18 04:13 AM
Looking for Fram Ultra XG30 and XG5 cut open
by rubberchicken. 12/12/18 10:27 PM
92 f150 332 code
by ram_man. 12/12/18 10:05 PM
Mixing brands of brake fluid / gear lube
by SureshR. 12/12/18 09:26 PM
45,000 miles in the Caprice.
by ls1mike. 12/12/18 09:21 PM
Quality oils?
by Horsehaulin. 12/12/18 09:16 PM
Exhaust fumes in cabin
by Skater4life27. 12/12/18 08:40 PM
Squeaky sunroof
by dishdude. 12/12/18 08:09 PM
Liqui Moly Top Tec 1800
by Chuckh. 12/12/18 07:56 PM
2006 Pathfinder Transmission Shudder
by Bluestream. 12/12/18 07:10 PM
Maybe E-10 is better? - PentaStar (Flex Fuel)
by StevieC. 12/12/18 06:52 PM
Shipping cost
by Fitter30. 12/12/18 06:45 PM
Purolator P1 14476 CUT OPEN
by 53' Stude. 12/12/18 06:00 PM
Which car to buy?
by jrcowboys. 12/12/18 04:55 PM
New Tire Cracking
by robd. 12/12/18 04:43 PM
SAR B6P - Thoughts?
by 28oz. 12/12/18 03:59 PM
Time to sell the 1-ton Dually
by 02SE. 12/12/18 03:55 PM
Shell Rotella Grease
by WMW0505. 12/12/18 02:27 PM
Newest Members
Horsehaulin, JLew, bmrk1100, Rrrracer, jefe_de_estado
66664 Registered Users
Who's Online Now
32 registered members (bmod305, Black_Thunder, 53' Stude, bfleeman, Black, Bailes1992, 1 invisible), 885 guests, and 39 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics295,008
Posts4,925,910
Members66,664
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
2006 Chrysler 300 Limited #4609489
12/20/17 05:06 PM
12/20/17 05:06 PM
Joined: Feb 2009
Posts: 67
ny
jeep58 Offline OP
jeep58  Offline OP
Joined: Feb 2009
Posts: 67
ny
I have this car with dual climate control, Today turn on the heat heat and one side is ice cold other side is hot both temp control knobs are on high. Look on the internet some say its the heat blend door actuator but the sir comes out where ever you point the knob too ie: floor defrost etc. any ideas ?

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609506
12/20/17 05:30 PM
12/20/17 05:30 PM
Joined: Aug 2017
Posts: 225
Cincinnati, USA
Dave9 Offline
Dave9  Offline
Joined: Aug 2017
Posts: 225
Cincinnati, USA
Don't know about a Chrysler 300 specifically, but on many vehicles the blend door is an electric motor while the vent selection is vac based. This means where the air comes out doesn't necessarily mean anything. Again none of my info is Chrysler 300 specific.

I'd tear the dash down to the blend door for the side that isn't working right, pull the electrical plug and confirm it's getting power when it should change state with the dash controls. Could be wiring, more likely motor, or the door shaft could have broken off. Doorman makes replacement doors for some vehicles and depending on how it needs to be pulled out, might have a repair kit that's usually just including some foil tape to hold it together if it has to be cut to pull the blend door out.

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609574
12/20/17 06:47 PM
12/20/17 06:47 PM
Joined: Sep 2015
Posts: 1,592
USA
mk378 Offline
mk378  Offline
Joined: Sep 2015
Posts: 1,592
USA
First confirm that the cooling system is full before tearing anything down.

The control panel and motor system should have a self test mode.

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609605
12/20/17 07:12 PM
12/20/17 07:12 PM
Joined: Feb 2013
Posts: 11,088
Phoenix, AZ
Nick1994 Offline
Nick1994  Offline
Joined: Feb 2013
Posts: 11,088
Phoenix, AZ
There's likely multiple electric motors, and the temperature one for the cold side is bad.

My grandparent's Trailblazer basically does the same thing. But when we need heat I just turn off the drivers side vents manually and point the passenger ones over toward the drivers side. Works good enough.


2015 Hyundai Sonata 2.4L 88k Motorcraft Synthetic Blend 5w30 & OEM
2000 Toyota Camry 2.2L 231k Valvoline 5w30 & Fram Ultra
1996 Jeep Cherokee 4.0L 147k Mobil 1 HM 10w40 & Fram Ultra
Re: 2006 Chrysler 300 Limited [Re: jeep58] #4609669
12/20/17 08:10 PM
12/20/17 08:10 PM
Joined: Feb 2009
Posts: 67
ny
jeep58 Offline OP
jeep58  Offline OP
Joined: Feb 2009
Posts: 67
ny
Thanks thinking yes it may be a bad motor,and yes it is full of antifreeze.

Re: 2006 Chrysler 300 Limited [Re: jeep58] #4610671
12/21/17 09:19 PM
12/21/17 09:19 PM
Joined: Feb 2009
Posts: 67
ny
jeep58 Offline OP
jeep58  Offline OP
Joined: Feb 2009
Posts: 67
ny
Problem solved Had to re calibrate the climate control unit, took it out and unplugged the unit wait 30 seconds and plug back in worked, dealer will do it for you with a star scan tool, reading on internet found a way around it one win for consumer!


BOB IS THE OIL GUY® Powered by UBB.threads™