Recent Topics
"synthetic" gear oil and LS additive?
by nthach
45 minutes 9 seconds ago
Supertech wix ST8 5514 miles
by jakewells
Today at 01:38 PM
Review - Sonax Spray and Seal.
by PimTac
Today at 01:36 PM
Lets Get a True Group 4 Sticky going!
by KMJ1992
Today at 12:17 PM
Rotella 10W40
by jakewells
Today at 10:43 AM
Extend WiFi Range at the Laptop?
by clarkflower
Today at 10:40 AM
Silicone containing waxes
by mjoekingz28
Today at 09:44 AM
Matrix totaled
by circuitsmith
Today at 08:32 AM
Door rust problems
by Dave Sherman
Today at 07:51 AM
2016 Honda Civic problems
by dbias
Today at 07:39 AM
Royal purple 75-140 in a subaru rear
by 91camarosRS
Today at 07:32 AM
OCI. With short trips. Nissan 4 liter
by Gawardawg
Today at 06:52 AM
Approach Watching on the Beach @ St Maarten ...
by LoneRanger
Today at 06:41 AM
Honda Accord Needs Shocks; Front, Back, or Both?
by tc1446
Today at 05:50 AM
How much oil does your oil filter hold?
by Snagglefoot
Today at 05:44 AM
better day
by mx5miata
Today at 05:26 AM
BRAVO to Officer Wheeles......
by Sayjac
Today at 05:17 AM
People Watching ....Airport style.
by ZZman
Today at 04:24 AM
Subaru's at play...
by OneEyeJack
Today at 03:50 AM
Treating a 2003 Jetta
by llmercll
Today at 01:41 AM
Newest Members
JustaDude, 3horseman, Firedog45, WtsTacoma01, Orion62
65265 Registered Users
Who's Online
96 registered (1JZ_E46, 28oz, 97f150, 2strokeNorthstar, 69Torino, 4WD, 8 invisible), 1712 Guests and 37 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65265 Members
67 Forums
285598 Topics
4766208 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4609122 - 12/20/17 08:47 AM 2006 Tacoma CEL P0460
SteveP Offline


Registered: 01/07/12
Posts: 29
Loc: Virginia
First maintenance issue in 11 years of ownership!!!

So starting last spring I started hearing a couple of noises. The first sounded like a rattle - but not metal, more like the sound you'd hear if something was dragging against fan. It only lasted a brief amount of time, and was gone. The second noise was more like a diesel engine sound, at lower rpm ranges typically. Very intermittent. I always run 89 octane fuel, BTW.

I let it go as the first wasn't really an issue unless the truck sat out in the cold overnight. I had my trusted local shop check things out and their best guess was something in the exhaust causing either/both. They had recommended Marvel Mystery Oil as a cleaner and I added 8 oz to the crankcase. About a week later the truck threw code P0460, related to the cat (or cats). I don't believe in coincidences so I am wondering if adding the Marvel could have caused something problematic downstream?

This morning I am changing the PCV valve, air filter, and cleaning the MAF as first steps towards resolving the light - any other thoughts/input welcome.

Top
#4609139 - 12/20/17 09:07 AM Re: 2006 Tacoma CEL P0460 [Re: SteveP]
CT8 Offline


Registered: 10/09/14
Posts: 10934
Loc: Idaho
How many miles on the Truck and which engine? Google your code.
_________________________
"Don't let your preconceived notions get in the way of facts."
Geoff Metcalf

Top
#4609146 - 12/20/17 09:12 AM Re: 2006 Tacoma CEL P0460 [Re: SteveP]
LeakySeals Offline


Registered: 02/18/11
Posts: 6561
Loc: Hudson, NH
I had that code recently on a Nissan. Turned out not to be the fuel level sensor, it was problems with the cluster.
_________________________
06 Escalade 6.0L AWD 160k. M1 5w30 Fram TG
03 Maxima 3.5L 149k ST HM 10w30

Top
#4609316 - 12/20/17 01:11 PM Re: 2006 Tacoma CEL P0460 [Re: SteveP]
Kamele0N Offline


Registered: 02/09/15
Posts: 2038
Loc: Slovenia
Most probably your catalyst converter went south (its mesh inside basically)...thats why it is rattling...inside its housing...

Did your fuel consumption go up recently? (engine went in "safe mode")


Edited by Kamele0N (12/20/17 01:13 PM)
_________________________
2011 Hyundai i30 1.4 CVVT Shell Helix Ultra 5w40
1997 Toyota Landcruiser KZJ95 3.0 TD various 10w40

Top