Recent Topics
"SG(+)" 15w40 or better oil 1987 BBC 454
by F239141. 12/14/18 03:52 PM
All Mazda 3’s have bad OCV’s?
by buster. 12/14/18 03:44 PM
Bad cylinder 3 misfire.
by Hemispheres. 12/14/18 02:49 PM
Small leak at toilet base - bad wax ring?
by Oro_O. 12/14/18 02:38 PM
Ok I take it back about Keurig
by StevieC. 12/14/18 02:29 PM
Edge 5W-30 7.9k miles '13 F150 5.0
by dustyroads. 12/14/18 02:11 PM
Stick with WSS-M2C946-A?
by BlueFog. 12/14/18 01:42 PM
How engine capacity affects fuel consumption?
by NICAT. 12/14/18 01:12 PM
Pep Boys
by Zee09. 12/14/18 12:41 PM
How early in engines life can I start to extend OCI
by Doublehaul. 12/14/18 12:33 PM
EFB and AGM batteries charge faster?
by slybunda. 12/14/18 11:20 AM
97.5 Regal GS climate control illumination
by 71Chevyguy. 12/14/18 11:04 AM
Cool train site for Canadians
by Papa Bear. 12/14/18 10:09 AM
Putting together a groups 3/4/5 synthetic list
by MrWideTires. 12/14/18 10:02 AM
VW Atlas V6 Oil
by motech. 12/14/18 09:32 AM
Great shakes, it's Yahtzee... or a Taurus
by redhat. 12/14/18 09:03 AM
MWI Micro Wave Ignition
by Danno. 12/14/18 08:52 AM
8k Miles on M1 EP 2017 Subaru 3.6
by BISCUT. 12/14/18 08:47 AM
Wrong ATF Fluid in my 07 Chevy Impala
by CM613. 12/14/18 08:39 AM
Newest Members
wsalopek, jcr1293, maxwellk, BlueFog, Frank_G35
66682 Registered Users
Who's Online Now
94 registered members (A310, andyd, 77GrandPrix, 94astro, Atesz792, 03s, 11 invisible), 1,959 guests, and 46 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics295,070
Posts4,927,240
Members66,682
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
FRAM ULTRA 3614, 6,500 miles CUT OPEN #4603723
12/14/17 05:45 PM
12/14/17 05:45 PM
Joined: Mar 2015
Posts: 11,878
In the shop
53' Stude Offline OP
53' Stude  Offline OP
Joined: Mar 2015
Posts: 11,878
In the shop
Good evening gentlemen.

Posting this FRAM ultra for member Curtis Newton. Came off of a 2004 Lexus RX330 AWD with v-6 engine. Said he started vehicle one day and knocking for few seconds and shut vehicle off. Then re started and knocking went away.

Filter looks ok to be. Filter had 6,500 miles and the PP had around 3,000 miles

Enjoy the pics smile













The dent was from Curtis removing filter and smooshed media is from me prying on media and can to remove element

Last edited by car51; 12/14/17 05:47 PM.

09' Camry LE, 141,020 miles

PP 5w30 and TG 4967
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4603731
12/14/17 05:56 PM
12/14/17 05:56 PM
Joined: Mar 2015
Posts: 5,422
Virginia
bbhero Online content
bbhero  Online Content
Joined: Mar 2015
Posts: 5,422
Virginia
Looks very stout there Captain. Good job here man. I am running the orange can on my car for 9600 miles.


Nissan Altima 3.5 Coupe
Mobil Super 5w30 Wix 57356
"Treat your family like your friends and treat your friends like your family."
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4603735
12/14/17 06:00 PM
12/14/17 06:00 PM
Joined: Jan 2003
Posts: 893
Colorado
newtoncd8 Offline
newtoncd8  Offline
Joined: Jan 2003
Posts: 893
Colorado
Thanks car51 for cutting open and posting the filter. Was hoping the anti-drain back valve was damaged. Seeing it cut open, sure wish I knew what that knocking noise was on our RX330. Changed over to WIX XP for this current run.


12 Jeep GC, 04 Lexus RX330, 77 MG-B
11 Audi A4, 01 Audi A4
99 Lexus ES300, 98 Isuzu Trooper
94 & 91 Acura Integra, 88 Toyota Camry,
84 Honda Accord, 70 Pontiac LeMans,
62 Ford Galaxy 500
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4603736
12/14/17 06:00 PM
12/14/17 06:00 PM
Joined: Mar 2015
Posts: 11,878
In the shop
53' Stude Offline OP
53' Stude  Offline OP
Joined: Mar 2015
Posts: 11,878
In the shop
Thanks Captain. Bit chilly here past few days and 4 snow overnight here so I was busy today smile


09' Camry LE, 141,020 miles

PP 5w30 and TG 4967
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: newtoncd8] #4603737
12/14/17 06:01 PM
12/14/17 06:01 PM
Joined: Mar 2015
Posts: 11,878
In the shop
53' Stude Offline OP
53' Stude  Offline OP
Joined: Mar 2015
Posts: 11,878
In the shop
Originally Posted By: newtoncd8
Thanks car51 for cutting open and posting the filter. Sure wish I knew what that knocking noise was on our RX330. Changed over to WIX XP for this current run.


You are welcome sir smile


09' Camry LE, 141,020 miles

PP 5w30 and TG 4967
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: newtoncd8] #4603759
12/14/17 06:29 PM
12/14/17 06:29 PM
Joined: Mar 2015
Posts: 5,422
Virginia
bbhero Online content
bbhero  Online Content
Joined: Mar 2015
Posts: 5,422
Virginia
I had a Fram Ultra with 0 oil in it on my lady's Camry. It is angled downward but I have had Carquest red filter which was totally full in the same circumstance. Regular Wix did good as well.

Car51 I wish we would've gotten 4 inches of snow here today. We just missed out on that amount of snow last Friday into Saturday... By 25 miles north and west saw 4-5 inches.


Nissan Altima 3.5 Coupe
Mobil Super 5w30 Wix 57356
"Treat your family like your friends and treat your friends like your family."
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: bbhero] #4603791
12/14/17 06:55 PM
12/14/17 06:55 PM
Joined: Jan 2003
Posts: 893
Colorado
newtoncd8 Offline
newtoncd8  Offline
Joined: Jan 2003
Posts: 893
Colorado
Originally Posted By: bbhero
I had a Fram Ultra with 0 oil in it on my lady's Camry. It is angled downward but I have had Carquest red filter which was totally full in the same circumstance. Regular Wix did good as well.


I have no proof, but based upon the noise, I have to believe the Fram Ultra filter that I pulled off and sent to car51 was similar to your experience. On our RX330, the filter is also angled down. The noise was pretty concerning and I have used (mostly) OEM, Fram Ultra and Wix; that was the first time I have ever heard the knocking noise. It may filter 20 microns @ 99%, but that noise isn't something I can deal with.


12 Jeep GC, 04 Lexus RX330, 77 MG-B
11 Audi A4, 01 Audi A4
99 Lexus ES300, 98 Isuzu Trooper
94 & 91 Acura Integra, 88 Toyota Camry,
84 Honda Accord, 70 Pontiac LeMans,
62 Ford Galaxy 500
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: newtoncd8] #4603803
12/14/17 07:09 PM
12/14/17 07:09 PM
Joined: Mar 2015
Posts: 5,422
Virginia
bbhero Online content
bbhero  Online Content
Joined: Mar 2015
Posts: 5,422
Virginia
Yeah I agree with you on that man. I couldn't deal with that kind of circumstance as well. I have a STP XL on there now made by Daewa. It has been just fine this whole time.


Nissan Altima 3.5 Coupe
Mobil Super 5w30 Wix 57356
"Treat your family like your friends and treat your friends like your family."
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4603822
12/14/17 07:39 PM
12/14/17 07:39 PM
Joined: Oct 2017
Posts: 743
Georgia
MParr Offline
MParr  Offline
Joined: Oct 2017
Posts: 743
Georgia
Knocking sounds like the clue to ditch the FRAM. There are many other choices. Motorcraft FL-910s or FL-400s. Bosch, WIX 51348 NAPA Gold 1348. The STP XL looks like a well constructed filter.


2013 KIA Optima EX 2.4L. Now: QSUD 5W30 & STP S2808ML
2017 Ford Escape SE 2.0T Now: Mobil 1 5W30 & NAPA Gold 1348
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4603888
12/14/17 08:41 PM
12/14/17 08:41 PM
Joined: Dec 2006
Posts: 19,124
Dallas,Tx USA
aquariuscsm Offline
aquariuscsm  Offline
Joined: Dec 2006
Posts: 19,124
Dallas,Tx USA
What would cause filter knock? Too restrictive?


1996 Nissan 300ZX 5-speed,Arctic Pearl(#175 of 300)
Quaker State Ultimate Durability 10W30
2012 Honda Accord Coupe EX-L 2.4,auto,San Marino Red
Pennzoil Platinum 5W20

Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: aquariuscsm] #4603902
12/14/17 08:54 PM
12/14/17 08:54 PM
Joined: Dec 2016
Posts: 7,159
Waco, TX
Linctex Offline
Linctex  Offline
Joined: Dec 2016
Posts: 7,159
Waco, TX
Originally Posted By: aquariuscsm
What would cause filter knock? Too restrictive?


Possibly the oil drained out overnight.


"The evidence demands a verdict".
(Re:VOA)"it's nearly impossible to actually know the particular additives that are in there at what concentrations."
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: Linctex] #4603942
12/14/17 09:49 PM
12/14/17 09:49 PM
Joined: Jul 2010
Posts: 19,283
PNW
ZeeOSix Offline
ZeeOSix  Offline
Joined: Jul 2010
Posts: 19,283
PNW
Originally Posted By: Linctex
Originally Posted By: aquariuscsm
What would cause filter knock? Too restrictive?


Possibly the oil drained out overnight.


Yep, most likely leaky ADBV.

Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: newtoncd8] #4603947
12/14/17 09:52 PM
12/14/17 09:52 PM
Joined: Jul 2010
Posts: 19,283
PNW
ZeeOSix Offline
ZeeOSix  Offline
Joined: Jul 2010
Posts: 19,283
PNW
Originally Posted By: newtoncd8
Originally Posted By: bbhero
I had a Fram Ultra with 0 oil in it on my lady's Camry. It is angled downward but I have had Carquest red filter which was totally full in the same circumstance. Regular Wix did good as well.


I have no proof, but based upon the noise, I have to believe the Fram Ultra filter that I pulled off and sent to car51 was similar to your experience. On our RX330, the filter is also angled down. The noise was pretty concerning and I have used (mostly) OEM, Fram Ultra and Wix; that was the first time I have ever heard the knocking noise. It may filter 20 microns @ 99%, but that noise isn't something I can deal with.


Question: Do you change your own oil? If so, do you ever hear any engine noises on first start-up with a new dry oil filter installed? That scenario mimics a filter that has leaked down due to a bad ADBV. Some vehicles are sensitive to the filter and galleries draining out, some aren't. None of my vehicles ever make any engine noises on first start-up after an oil change with a new dry filter installed.

Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4603972
12/14/17 10:20 PM
12/14/17 10:20 PM
Joined: Mar 2016
Posts: 1,117
MT
jongies3 Offline
jongies3  Offline
Joined: Mar 2016
Posts: 1,117
MT
I have slight startup noise on cold mornings regardless of what filter I use, I'm not worried about it.


2004 Toyota Tacoma 3.4 V6: Mobil 1 AFE 0W-30, FRAM TG-3600 filter
1969 Mustang Mach 1 5.8 V8: PYB 10W-30 Napa Gold 1515 filter
1997 Ford F-250 HD 7.3 Powerstroke V8: T6 5W-40 FRAM PH-3786 filter
Re: FRAM ULTRA 3614, 6,500 miles CUT OPEN [Re: 53' Stude] #4604008
12/14/17 11:30 PM
12/14/17 11:30 PM
Joined: Nov 2016
Posts: 1,283
WI
HoosierJeeper Offline
HoosierJeeper  Offline
Joined: Nov 2016
Posts: 1,283
WI
I ran a Fram Ultra once after being extremely happy with a TG on my Liberty and it knocked a bit too. No idea why but I took it off after a 100 miles and put a Wix on and it was fine. Now running another TG and it's perfect. Not sure why it reacted badly to the Ultra, but I'm a once filter/one OCI guy so a TG is 110% adequate for a 5k interval.


15 Jeep KL Limited V6: Formula Shell 5W20
07 LR3 SE V8: Maxlife 5W30
05 Jeep KJ Limited: PHM 5W30
96 Jeep XJ Country: STP HM 5W30 (winter)
Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™