Recent Topics
2015 VW GTI autobahn oil questions
by Skyalbo
Yesterday at 11:28 PM
Corrosion in the garage - salt or humidity?
by Kurtatron
Yesterday at 11:13 PM
Darn dogs
by AZjeff
Yesterday at 10:21 PM
New GC?
by Bullwinkle007
Yesterday at 10:04 PM
The guy with the plexiglass head on you tube
by andyd
Yesterday at 09:21 PM
'07 Pacifica Timing Belt Replacement success
by 92saturnsl2
Yesterday at 09:10 PM
SAE 90 v 85/140
by Knuckle078
Yesterday at 09:10 PM
Mobil 1 5W30-HM 5,011 mi, 1999 Ford Escort
by WA1DH
Yesterday at 08:45 PM
what happened to merk
by ernied
Yesterday at 08:34 PM
Schaeffer's oil reviews on Amazon
by zfasts03
Yesterday at 07:41 PM
Decent MP3 player
by Ed_T
Yesterday at 07:08 PM
Letgo
by Donald
Yesterday at 06:52 PM
Tire buying advice
by supton
Yesterday at 06:23 PM
Two versions of M1 5w30 ESP now?
by Patman
Yesterday at 06:21 PM
No older cars in New York State?
by Oldtom
Yesterday at 06:19 PM
2009 Taurus strut mount noise
by terry274
Yesterday at 04:38 PM
A3/B3 vs A3/B4, big difference or irrelevant?
by FordCapriDriver
Yesterday at 03:36 PM
2003 Honda power steering problem
by hogpops
Yesterday at 03:29 PM
Public Service Announcement: Flush Your HW Heater
by gathermewool
Yesterday at 03:25 PM
Fellow 2AZ-FE toyota owners: what oil are you usin
by car51
Yesterday at 03:21 PM
Newest Members
lozpxs, danthemanx07, FunktasticLucky, Knuckle078, penncove
65317 Registered Users
Who's Online
33 registered (dishdude, Aero540T, cb_13, CharlieBauer, andyd, 2 invisible), 901 Guests and 38 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65317 Members
67 Forums
285952 Topics
4771868 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4583411 - 11/24/17 07:38 AM AC not working 2015 Charger compressor not working
Blue_Goose Offline


Registered: 07/13/05
Posts: 2064
Loc: New Hampsha
Picked up my Charger last Monday and even though it was 27 degrees last night I decided to see how cold the AC was in this car. Turned on the AC and everything lights up (button dash and also on the 8.4 Uconnect screen) but........no compressor kick in. It just blows whatever temp the cabin temp is. This is with the recirc on. If I open to fresh air, yeah it gets cold quick with 27 degree air lol

I asked over in the Charger Forums and so far the reply I got was that the compressor won't turn on if the ambient temp outside is less than 60 degrees?? Does this make sense? I don't think I've ever had a car where I couldn't turn on the AC regardless of the temperature


Can anyone who has a Charger or 300 or I imagine a RAM verify this?


Again everything lights up like it should come on but missing that familiar sound and rpm drop when the compressor turns on.

Thanks
_________________________
2015 Dodge Charger R/T Road & Track 5.7L
2003 Honda Accord EX-L 2.4L 5MT

Top
#4583416 - 11/24/17 07:53 AM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
motor_oil_madman Offline


Registered: 11/29/09
Posts: 4860
Loc: Houston, Texas
Put it on defrost and see if it kicks on then.
_________________________
2007.5 dodge cummins 6.7 liter. Chevron Delo400 15w40. 7000 mile or 250-300hr intervals.


Top
#4583417 - 11/24/17 07:53 AM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
DuckRyder Offline


Registered: 10/20/05
Posts: 4215
Loc: Atlanta
Does the compressor run in defrost mode?
_________________________
Robert
  • 2007 Toyota Prius Touring
  • 2005 Honda Civic Sedan
  • 1972 Ford F100

Top
#4583418 - 11/24/17 07:53 AM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
motor_oil_madman Offline


Registered: 11/29/09
Posts: 4860
Loc: Houston, Texas
I don't see why the compressor would be commanded on at 27 degrees. Lol
_________________________
2007.5 dodge cummins 6.7 liter. Chevron Delo400 15w40. 7000 mile or 250-300hr intervals.


Top
#4583424 - 11/24/17 08:01 AM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
JTK Offline


Registered: 08/14/03
Posts: 10592
Loc: Buffalo, NY
An automotive A/C compressor typically won't run at temps below ~55F or so. Not enough heat load for the refrigerant. The evap core would freeze up, etc.

Like said, why would you want it to, or need it to when the ambient air is that cold?
_________________________
2017 Ram 1500 4x4, 3.6L. 2016 Nissan Quest SV (Babe magnet IV)

Top
#4583447 - 11/24/17 08:42 AM Re: AC not working 2015 Charger compressor not working [Re: JTK]
Danno Offline


Registered: 10/07/12
Posts: 1993
Loc: Northern Ontario, Canada
Originally Posted By: JTK
Like said, why would you want it to, or need it to when the ambient air is that cold?

He's just testing the controls in his new ride. No harm no foul, I guess, in him asking the question.
_________________________
2016 Sorento SX V6 AWD
2015 KIA RIO SX
2010 Mazda 3 2.0L
2009 Venza V6 AWD
2013 Sonata 2.4L RIP in write-off crash

Top
#4583510 - 11/24/17 09:46 AM Re: AC not working 2015 Charger compressor not working [Re: Danno]
Blue_Goose Offline


Registered: 07/13/05
Posts: 2064
Loc: New Hampsha
Originally Posted By: Danno
Originally Posted By: JTK
Like said, why would you want it to, or need it to when the ambient air is that cold?

He's just testing the controls in his new ride. No harm no foul, I guess, in him asking the question.


Yep, exactly right lol. I saw a thread somewhere on the cost of ac parts and thought maybe I should test it before I turn over 36k.

I tested this morning and at 36 degrees the compressor did turn on when I turned on the ac and cold air did come out. I guess Iím just not used to the way the Charger climate system works

The compressor kicking on is very subtle compared to my 4 bangers lol

Hey thanks guys, I just wanted to make sure I wasnít looking at a $$$$ repair even before it was registered
_________________________
2015 Dodge Charger R/T Road & Track 5.7L
2003 Honda Accord EX-L 2.4L 5MT

Top
#4583515 - 11/24/17 09:51 AM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
mk378 Offline


Registered: 09/27/15
Posts: 1421
Loc: USA
On any car, the compressor will not run if the evaporator temperature is below freezing.

Top
#4583747 - 11/24/17 02:44 PM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
Trav Offline


Registered: 11/20/06
Posts: 18909
Loc: MA, Mittelfranken.de
Normal operation on most cars, the temp may vary a bit from manufacturer to manufacturer but not by much eg VW has a 40F setting.
Others allow/command it run if the coolant temp is above circa 120f on defrost to insure the evaporator core wont ice.
_________________________
ASE L1, Master. Deutsch Meisterbrief.

Top
#4583831 - 11/24/17 05:01 PM Re: AC not working 2015 Charger compressor not working [Re: Blue_Goose]
JTK Offline


Registered: 08/14/03
Posts: 10592
Loc: Buffalo, NY
Originally Posted By: Blue_Goose
Originally Posted By: Danno
Originally Posted By: JTK
Like said, why would you want it to, or need it to when the ambient air is that cold?

He's just testing the controls in his new ride. No harm no foul, I guess, in him asking the question.


Yep, exactly right lol. I saw a thread somewhere on the cost of ac parts and thought maybe I should test it before I turn over 36k.


Sorry Goose! Didn't mean to come off snarky there.. I missed the "test" part.

You're right about the almost non-detectable compressor cycling thing on Dodges. You'd maybe notice a click was about it with our 2013 Grand Caravan with the Pentastar.


Edited by JTK (11/24/17 05:03 PM)
_________________________
2017 Ram 1500 4x4, 3.6L. 2016 Nissan Quest SV (Babe magnet IV)

Top
#4583942 - 11/24/17 07:13 PM Re: AC not working 2015 Charger compressor not working [Re: JTK]
Blue_Goose Offline


Registered: 07/13/05
Posts: 2064
Loc: New Hampsha
Originally Posted By: JTK
Originally Posted By: Blue_Goose
Originally Posted By: Danno
Originally Posted By: JTK
Like said, why would you want it to, or need it to when the ambient air is that cold?

He's just testing the controls in his new ride. No harm no foul, I guess, in him asking the question.


Yep, exactly right lol. I saw a thread somewhere on the cost of ac parts and thought maybe I should test it before I turn over 36k.


Sorry Goose! Didn't mean to come off snarky there.. I missed the "test" part.

You're right about the almost non-detectable compressor cycling thing on Dodges. You'd maybe notice a click was about it with our 2013 Grand Caravan with the Pentastar.



No worries my friend! No offense taken smile

I actually learned quite a bit about ac systems today grin
_________________________
2015 Dodge Charger R/T Road & Track 5.7L
2003 Honda Accord EX-L 2.4L 5MT

Top
#4583985 - 11/24/17 08:03 PM Re: AC not working 2015 Charger compressor not working [Re: JTK]
dishdude Online   content


Registered: 11/14/08
Posts: 8765
Loc: Phoenix
Originally Posted By: JTK

You're right about the almost non-detectable compressor cycling thing on Dodges. You'd maybe notice a click was about it with our 2013 Grand Caravan with the Pentastar.


Aren't most manufacturers using a variable displacement compressor that doesn't click on and off like the old days? I know I can't tell when the compressor cycles in my Jeep.
_________________________
2018 Challenger SRT

Top
#4584486 - 11/25/17 12:55 PM Re: AC not working 2015 Charger compressor not working [Re: dishdude]
Trav Offline


Registered: 11/20/06
Posts: 18909
Loc: MA, Mittelfranken.de
Both are common on new cars, this car apparently uses a common 7SB series with magnetic clutch, most of the electronic control valve models don't need a magnetic clutch as they can reduce down to 1% so you wouldn't hear/feel it engage.

EV cars will almost certainly use and electronically controlled unit
_________________________
ASE L1, Master. Deutsch Meisterbrief.

Top