Recent Topics
Needing New Dipstick
by Geauxtiger
06/19/18 05:11 PM
'98 Mercedes E300TD Rotella T5 10W-30 5k miles
by KenO
06/19/18 04:35 PM
Premium guard oil filters
by Jaha24k
06/19/18 04:09 PM
76 super motor oil- synthetic blend 5w-30
by Jaha24k
06/19/18 04:07 PM
Who makes the Mopar 5038041AA filter?
by Quattro Pete
06/19/18 03:55 PM
Ruger Mini-14, yay or nay?
by 28oz
06/19/18 03:51 PM
USPS long long delivery to BlackStone Labs
by Pajero
06/19/18 02:58 PM
House A.c. vent leaking water
by motor_oil_madman
06/19/18 02:55 PM
"synthetic" gear oil and LS additive?
by nthach
06/19/18 01:54 PM
Supertech wix ST8 5514 miles
by jakewells
06/19/18 01:38 PM
Review - Sonax Spray and Seal.
by PimTac
06/19/18 01:36 PM
Lets Get a True Group 4 Sticky going!
by KMJ1992
06/19/18 12:17 PM
Rotella 10W40
by jakewells
06/19/18 10:43 AM
Extend WiFi Range at the Laptop?
by clarkflower
06/19/18 10:40 AM
Silicone containing waxes
by mjoekingz28
06/19/18 09:44 AM
Matrix totaled
by circuitsmith
06/19/18 08:32 AM
Door rust problems
by Dave Sherman
06/19/18 07:51 AM
2016 Honda Civic problems
by dbias
06/19/18 07:39 AM
Royal purple 75-140 in a subaru rear
by 91camarosRS
06/19/18 07:32 AM
OCI. With short trips. Nissan 4 liter
by Gawardawg
06/19/18 06:52 AM
Newest Members
JustaDude, 3horseman, Firedog45, WtsTacoma01, Orion62
65265 Registered Users
Who's Online
94 registered (bds1984, 2009Edge, bmod305, bdcardinal, Audios, 14 invisible), 1587 Guests and 39 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65265 Members
67 Forums
285606 Topics
4766424 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Page 1 of 5 1 2 3 4 5 >
Topic Options
#4570233 - 11/10/17 06:57 PM 2017 Pentastar - tick on startup
webfors Offline


Registered: 06/06/06
Posts: 4941
Loc: Great White North.. eh
I've noticed a tick on startup with our new van, especially now that it's getting colder.

It lasts about 2 seconds, which indicates the oil reaches the ticking area and it stops.

Is this normal for the 3.6 Pentastar? Is it filer related?
_________________________
17 Cadillac ATS 2.0T, Edge D1G2 5w30, XG10575
17 Dodge GC, VWB 5w30, Fram DL11665
15 DL650, Valvoline 20w50, KN-138
Small engines; RT5 10w30

Top
#4570250 - 11/10/17 07:14 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
Merkava_4 Offline


Registered: 01/30/07
Posts: 17501
Loc: Clovis, CA
Sounds like an oil flow restriction. I'd be changing filters.

Top
#4570295 - 11/10/17 08:06 PM Re: 2017 Pentastar - tick on startup [Re: Merkava_4]
webfors Offline


Registered: 06/06/06
Posts: 4941
Loc: Great White North.. eh
Originally Posted By: Merkava_4
Sounds like an oil flow restriction. I'd be changing filters.


Or poor ADBV design on the filter or housing? Trying another filter is probably the easiest/first thing to try I agree.
_________________________
17 Cadillac ATS 2.0T, Edge D1G2 5w30, XG10575
17 Dodge GC, VWB 5w30, Fram DL11665
15 DL650, Valvoline 20w50, KN-138
Small engines; RT5 10w30

Top
#4570326 - 11/10/17 09:06 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
OVERKILL Online   content


Registered: 04/28/08
Posts: 36430
Loc: Ontario, Canada
Assuming you are using the OEM Mopar cartridge filters, I imagine you are just hearing a tensioner, I wouldn't be worried about it.

My wife's quiet FWIW, but we are running markedly different oils if your sig is current.
_________________________
2016 Durango Limited
2016 Grand Cherokee SRT

Top
#4570332 - 11/10/17 09:10 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
Kuato Offline


Registered: 10/23/05
Posts: 7094
Loc: Colorado
Thinking ADBV also....2 secs is about right to fill the filter...
_________________________
Thick vs Thin test: 15k / 43k miles complete

Top
#4570354 - 11/10/17 09:50 PM Re: 2017 Pentastar - tick on startup [Re: OVERKILL]
webfors Offline


Registered: 06/06/06
Posts: 4941
Loc: Great White North.. eh
Originally Posted By: OVERKILL
Assuming you are using the OEM Mopar cartridge filters, I imagine you are just hearing a tensioner, I wouldn't be worried about it.

My wife's quiet FWIW, but we are running markedly different oils if your sig is current.


Not using the OEM filter. I'm thinking replacing the oil filter is the next best step.
_________________________
17 Cadillac ATS 2.0T, Edge D1G2 5w30, XG10575
17 Dodge GC, VWB 5w30, Fram DL11665
15 DL650, Valvoline 20w50, KN-138
Small engines; RT5 10w30

Top
#4570381 - 11/10/17 10:18 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
HoosierJeeper Offline


Registered: 11/23/16
Posts: 1276
Loc: WI
My 3.2 Cherokee does it, running Mopar filters.
_________________________
15 Jeep KL Limited V6: Formula Shell 5W20
07 LR3 SE V8: Maxlife 5W30
05 Jeep KJ Limited: PHM 5W30
96 Jeep XJ Country: STP HM 5W30 (winter)

Top
#4570385 - 11/10/17 10:20 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
StevieC Offline


Registered: 08/21/08
Posts: 17116
Loc: Ontario, Canada
How old is the PentaStar as they revised the filter in the newer ones to help stop with the drain back and with lifter ticking.

Make sure you have the right filter in use. The first version does fit both engine revisions but won't function properly in newer Pentastars.

First Version (WIX 57526)


Revised Version (WIX WL10010)


Also make sure who ever is doing the oil change that they clip the filter into the housing lid before screwing it back into the housing. I've seen places that just drop them in the housing and tighten the lid over top and it damages the filter in the process.

My dads is a 2012 and takes the older one and my Father inlaw takes the newer one. I use Wix in both because I can get them at a good price and I have had 0 issues with them if you want to try them as a reference to see if it remedies the problem.



Edited by StevieC (11/10/17 10:31 PM)
_________________________
'15 Dodge Journey - 90,000 KM's - SSO 5w20
'06 Hyundai Santa Fe - 535,000km - SSO 0w30 (R.I.P)

Top
#4570387 - 11/10/17 10:33 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
HoosierJeeper Offline


Registered: 11/23/16
Posts: 1276
Loc: WI
I want to say 2013 and up have the new design.
_________________________
15 Jeep KL Limited V6: Formula Shell 5W20
07 LR3 SE V8: Maxlife 5W30
05 Jeep KJ Limited: PHM 5W30
96 Jeep XJ Country: STP HM 5W30 (winter)

Top
#4570391 - 11/10/17 10:37 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
StevieC Offline


Registered: 08/21/08
Posts: 17116
Loc: Ontario, Canada
Yeah but if you have some turkey at a shop somewhere that just looks up by engine size and doesn't realize there is a second filter that also fits the housing but is wrong it could be a newer engine with the older filter design and as a result it's allowing the oil to drain back and possibly not even filter it because of the differences.
_________________________
'15 Dodge Journey - 90,000 KM's - SSO 5w20
'06 Hyundai Santa Fe - 535,000km - SSO 0w30 (R.I.P)

Top
#4570392 - 11/10/17 10:39 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
StevieC Offline


Registered: 08/21/08
Posts: 17116
Loc: Ontario, Canada
Some of the Pentastars had bad roller rockers as well so if a lifter is draining back slightly it could cause ticking there until it refills with oil. Good news is these are relatively easy to change depending which one it is and there is lots of YouTube videos about it.


Edited by StevieC (11/10/17 10:39 PM)
_________________________
'15 Dodge Journey - 90,000 KM's - SSO 5w20
'06 Hyundai Santa Fe - 535,000km - SSO 0w30 (R.I.P)

Top
#4570405 - 11/10/17 10:57 PM Re: 2017 Pentastar - tick on startup [Re: StevieC]
webfors Offline


Registered: 06/06/06
Posts: 4941
Loc: Great White North.. eh
Originally Posted By: StevieC
Some of the Pentastars had bad roller rockers as well so if a lifter is draining back slightly it could cause ticking there until it refills with oil. Good news is these are relatively easy to change depending which one it is and there is lots of YouTube videos about it.


I think this might be it. I have an appointment Wednesday at the dealer. Same dealer that replaced the engine in my 2013. They have a good service department.

RE: filter types, thank you. I do all my oil changes and I'm using the correct filter. The dealer was nice enough to swap out my old filter stash for the new when I traded the van in for the new 2017.

Hopefully it's an easy fix. The van only has 20k KMs on it.
_________________________
17 Cadillac ATS 2.0T, Edge D1G2 5w30, XG10575
17 Dodge GC, VWB 5w30, Fram DL11665
15 DL650, Valvoline 20w50, KN-138
Small engines; RT5 10w30

Top
#4570407 - 11/10/17 11:00 PM Re: 2017 Pentastar - tick on startup [Re: StevieC]
4WD Offline


Registered: 09/21/10
Posts: 6366
Loc: Texas
Our 2007 is a 10w30 motor and it does not do this
maybe workers were thinner and dressed better on the shop floor back then

Top
#4570412 - 11/10/17 11:18 PM Re: 2017 Pentastar - tick on startup [Re: StevieC]
OVERKILL Online   content


Registered: 04/28/08
Posts: 36430
Loc: Ontario, Canada
Originally Posted By: StevieC
How old is the PentaStar


Well, the title of the thread says it is a 2017 wink
_________________________
2016 Durango Limited
2016 Grand Cherokee SRT

Top
#4570413 - 11/10/17 11:20 PM Re: 2017 Pentastar - tick on startup [Re: webfors]
StevieC Offline


Registered: 08/21/08
Posts: 17116
Loc: Ontario, Canada
Duh, missed that... I've been up since 4am. That's my excuse... Coffee2 <--- Clearly I need some.



Edited by StevieC (11/10/17 11:21 PM)
_________________________
'15 Dodge Journey - 90,000 KM's - SSO 5w20
'06 Hyundai Santa Fe - 535,000km - SSO 0w30 (R.I.P)

Top
Page 1 of 5 1 2 3 4 5 >