Recent Topics
Barrs leak oil additive
by Micahmcmeen - 04/05/20 08:10 AM
Lawn mower oil question
by icemanrrc - 04/05/20 08:10 AM
Wait until you see who's driving...
by Shannow - 04/05/20 06:57 AM
Getting My Harley Back On The Road
by Silverado12 - 04/05/20 06:45 AM
Oil brand you've never used
by OilUzer - 04/05/20 02:27 AM
New dishwasher on order...
by gregk24 - 04/05/20 12:19 AM
Blueing steel
by koffy - 04/04/20 11:53 PM
Home electrical question.
by 73guna - 04/04/20 10:20 PM
Castrol edge vs Valvoline synthetic?
by BTLew81 - 04/04/20 10:16 PM
My 1997 Ford Aspire 1.3 beater has me stumped
by IMSA_Racing_Fan - 04/04/20 09:50 PM
Baldwin B5134 Coolant Filter Cut Open
by FordFETruck - 04/04/20 09:32 PM
Pros vs Cons of upgrading to better filter
by PantherFan88 - 04/04/20 09:23 PM
Touch up paint
by WhyMe - 04/04/20 08:31 PM
Hemi plug change - plug covered in oil
by BigD7 - 04/04/20 07:16 PM
2020 M340i - CQuartz UK 3.0 & Gliss
by gofast182 - 04/04/20 07:14 PM
What VPN do you Recommend?
by Gebo - 04/04/20 06:39 PM
Email Service
by Gebo - 04/04/20 06:38 PM
Newest Members
London, Dave66, Kurt_Kent_09, northestPM, dgvu89
71102 Registered Users
Who's Online Now
101 registered members (AndyB, AdditiveOCD, 2004tdigls, 2015_PSD, 53' Stude, 4WD, 11 invisible), 2,125 guests, and 16 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics303,620
Posts5,238,465
Members71,102
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
Page 2 of 2 1 2
Re: Valvoline vo-76 [Re: Lignums] #4569399 11/10/17 01:19 AM
Joined: May 2015
Posts: 1,113
P
Popsy Offline
Offline
P
Joined: May 2015
Posts: 1,113
Originally Posted By: slacktide_bitog


For that Ecotec, ONLY use these filters:

Purflux L264A


Be careful, some of these are now made in India, and the gluing appeared a bit sloppy to me (I've only seen one).


96 Barchetta, 300V 5W40 | Forfour 95, M1 0W40
Mazda 6 2.3, Castrol 0W30 | Colt Ralliart, 300V 5W40
Re: Valvoline vo-76 [Re: ZeeOSix] #4569700 11/10/17 10:55 AM
Joined: Oct 2005
Posts: 7,094
K
Kuato Offline
Offline
K
Joined: Oct 2005
Posts: 7,094
Originally Posted By: ZeeOSix
Originally Posted By: Kuato
Originally Posted By: Charlie2015
Pretty normal for an oil filter in an ecotec engine - the media bends at the half-way point. I see it even on ACDelco filters.


Dang...too bad that "normal" is close to "failed". Makes me wonder what is happening to the filter, and how far it is compressed during normal operation - does it get compressed far enough to effectively be in bypass?

How does the filter compressing like that cause it to go into bypass?


If it deforms far enough, it will no longer be sealed at the end - and therefore no longer filtering. Unless I'm looking at it wrong and the end caps cannot move closer together.


Thick vs Thin test: 15k / 43k miles complete
Re: Valvoline vo-76 [Re: Lignums] #4570522 11/11/17 07:00 AM
Joined: Oct 2008
Posts: 14,490
S
Sayjac Offline
Offline
S
Joined: Oct 2008
Posts: 14,490
After observing many of these post use ecotec cartridges from many brands, this not an outlier. A Google image search of 'ecotec cartidge' will confirm that statement. Even the XG 9018 you mention showed a similar result HERE.

While appearance not great, I wouldn't call it a functional fail.


Re: Valvoline vo-76 [Re: Sayjac] #4570631 11/11/17 09:47 AM
Joined: Sep 2010
Posts: 8,317
2015_PSD Online Content
Online Content
Joined: Sep 2010
Posts: 8,317
Originally Posted By: Sayjac
After observing many of these post use ecotec cartridges from many brands, this not an outlier. A Google image search of 'ecotec cartidge' will confirm that statement. Even the XG 9018 you mention showed a similar result HERE. While appearance not great, I wouldn't call it a functional fail.
I agree with you that it is not a fail, but when a wire supported media filter bends (and this does not appear to be an overly long filter), I want to question the overall design. Perhaps, in the long term, the bend means nothing, it just seems "wrong".


2019 o)|||||(o Rubicon Wrangler Unlimited 3.6L V6 [Castrol Edge + Hastings]
2018 Mercedes Benz C300 2.0L Turbo [Pennzoil Platinum + Mann filter]
Re: Valvoline vo-76 [Re: Lignums] #4570654 11/11/17 10:16 AM
Joined: Dec 2010
Posts: 3,120
G
goodtimes Offline
Offline
G
Joined: Dec 2010
Posts: 3,120
I would suspect installer heavy handedness, like too much twisting or hard pushing, or getting it not all the way in and the cap thread has to push it further, maybe while crooked, before the two filters shown are being blamed defective themselves. Seems it would be pretty easy to install a new filter correctly, look at it to check again if all is well, then run it. If it is bad after, like these, then blame the filter.

Re: Valvoline vo-76 [Re: 2015_PSD] #4570977 11/11/17 04:16 PM
Joined: Oct 2015
Posts: 1,796
W
WellOiled Offline
Offline
W
Joined: Oct 2015
Posts: 1,796
Originally Posted By: 2015_PSD
Originally Posted By: Sayjac
After observing many of these post use ecotec cartridges from many brands, this not an outlier. A Google image search of 'ecotec cartidge' will confirm that statement. Even the XG 9018 you mention showed a similar result HERE. While appearance not great, I wouldn't call it a functional fail.
I agree with you that it is not a fail, but when a wire supported media filter bends (and this does not appear to be an overly long filter), I want to question the overall design. Perhaps, in the long term, the bend means nothing, it just seems "wrong".

I agree. It seems wrong. The filter designs and the housing they fit in are not very well thought out.


Mazda 6
Factory fill
Page 2 of 2 1 2
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™