Recent Topics
New car wax score
by Marco620. 01/16/19 02:42 PM
Bought a used Cherokee Trailhawk
by Sunnyinhollister. 01/16/19 02:34 PM
Air Fryer....whose got'em?
by Schmoe. 01/16/19 01:59 PM
ebates - anyone a member?
by Papa Bear. 01/16/19 01:29 PM
Ordered a 2019 X5 for the Wife
by gofast182. 01/16/19 12:48 PM
Today, I ride
by SirTanon. 01/16/19 12:02 PM
2019 Nissan Rogue SL
by JTK. 01/16/19 11:19 AM
Does GM oil life monitor % go down without driving?
by Corollaman. 01/16/19 10:37 AM
Ford tire wear issues?
by Redright9. 01/16/19 10:23 AM
New Battery
by CarlGR. 01/16/19 10:21 AM
It's January and I Need My Motorcycling "Therapy" !!
by LoneRanger. 01/16/19 10:13 AM
Are New Vehicles Too Expensive?
by SubLGT. 01/16/19 10:02 AM
Manual transmission fluid in Europe for Mazda
by zsero. 01/16/19 07:31 AM
Affected by the gov't shutdown?
by xBa380. 01/16/19 07:04 AM
Opinion Needed / 1998 Olds 88
by Mark72. 01/16/19 06:24 AM
Chevron Supreme color change
by OilUzer. 01/16/19 05:14 AM
Dual exhaust benefits
by OilUzer. 01/16/19 03:02 AM
M1 0w40
by Pinoak. 01/16/19 01:55 AM
M1 0w40
by Pinoak. 01/16/19 01:51 AM
Newest Members
VV03, Witchipoo, Durco1977, ConnorM, dkar26
66950 Registered Users
Who's Online Now
113 registered members (aircooled, 28oz, 4WD, advocate, 2002 Maxima SE, 9 invisible), 2,200 guests, and 33 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics296,645
Posts4,956,535
Members66,950
Most Online2,577
Jan 14th, 2019
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Traverse heat/defrost issues #4559940
10/31/17 07:30 AM
10/31/17 07:30 AM
Joined: Oct 2010
Posts: 1,614
stl
MarkM66 Offline OP
MarkM66  Offline OP
Joined: Oct 2010
Posts: 1,614
stl
'09 Traverse; have been having this problem intermittently. If I have the temp toward hot, it doesn't want to go back to cold, and vise versa. I have been getting it to change just by messing around with controls. Put blower on full blast, back and forth to hot/cold, etc. But this really should be fixed. From what I gather, it's a blend door actuator.

Now I'm having another issue: I can get heat out of the bottom vents, but not out the defrost vents. I believe this function is controlled by a different actuator.

Anyone else have this type of experience with one of these vehicles. Any tips on where to find these actuators? Going to try to look at it tonight.

Thanks

Re: Traverse heat/defrost issues [Re: MarkM66] #4559959
10/31/17 07:46 AM
10/31/17 07:46 AM
Joined: Jan 2017
Posts: 287
Iowa
Iowegian Offline
Iowegian  Offline
Joined: Jan 2017
Posts: 287
Iowa
Might want to ask someone on the traverse forum?
I have great help on the Equinox forum.

http://www.traverseforum.com


2011 Equinox, 2.4l
2009 Sienna, 3.5l
Re: Traverse heat/defrost issues [Re: MarkM66] #4559978
10/31/17 08:10 AM
10/31/17 08:10 AM
Joined: Dec 2013
Posts: 2,099
socal
barkingspider Offline
barkingspider  Offline
Joined: Dec 2013
Posts: 2,099
socal
You may need a new climate control panel and the definitely a new blend door actuator


06 Cadillac Escalade Ext
17 Cadillac ATS (wife)
05 Toyota Camry (daughter)
11 GMC Canyon off-road (daily)
Re: Traverse heat/defrost issues [Re: MarkM66] #4561029
11/01/17 08:19 AM
11/01/17 08:19 AM
Joined: Oct 2010
Posts: 1,614
stl
MarkM66 Offline OP
MarkM66  Offline OP
Joined: Oct 2010
Posts: 1,614
stl
I did the HVAC resent and as of now everything is working properly. I pulled glove box, and saw both temp, and vent function actuators moving when they should be moving.

So hopefully they stay working...

GM reset:

https://sparkys-answers.com/2011/08/hvac-actuator-recalibration-procedure.html


BOB IS THE OIL GUY® Powered by UBB.threads™