Recent Topics
Oil filter for GM 8.1l V8?
by KenO. 09/19/18 11:10 PM
Help! No high beam
by wolf_06. 09/19/18 11:02 PM
Heading for divorce
by barkingspider. 09/19/18 11:02 PM
Oil recommendation: 1991 Nissan D21 truck
by RDY4WAR. 09/19/18 10:04 PM
Cold starting and CCS etc.
by CT8. 09/19/18 10:03 PM
Whine->Dead car(electrical)
by madRiver. 09/19/18 09:59 PM
Differential Allen Drain Bolt Buggered
by Gebo. 09/19/18 09:41 PM
Pick my oil. 25k miles a year
by Serge. 09/19/18 09:41 PM
Ok to use in Kubota? Pennsoil 0w-40
by racinjason. 09/19/18 09:35 PM
Road Hugger GTP A/S Tires
by Bud_One. 09/19/18 09:16 PM
Gravity Bleeding Clutch?hel
by Spetz. 09/19/18 09:10 PM
Drunken Watch?
by StevieC. 09/19/18 09:01 PM
New Forum Member New Truck Owner
by FarmerDude. 09/19/18 08:35 PM
Valvoline DOT 3/4?
by DJ. 09/19/18 08:22 PM
Best grease for AWD actuator disconnect?
by Bman90. 09/19/18 08:14 PM
Reconditioning a 2-Stroke Snow Blower
by Finz. 09/19/18 07:55 PM
Liquimoly Anti Friction - $6.83 Shipped/ Can
by ad244. 09/19/18 06:57 PM
ACEA spec for old Toyota??
by alexmarjanovic98. 09/19/18 06:54 PM
3.5EB Gen II: Oil & Interval
by Gene K. 09/19/18 06:09 PM
Are there any cable techs here?
by Reddy45. 09/19/18 06:02 PM
Newest Members
FarmerDude, Bman90, Alday714, Joephoto, tlelectric
66021 Registered Users
Who's Online Now
61 registered members (alphadog, ArrestMeRedZ, AlaskaMike, advocate, Ag76, ABomb369, 4 invisible), 1,170 guests, and 38 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,696
Posts4,848,412
Members66,021
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
Briggs 190cc engine starting problems. #4545891
10/17/17 07:42 AM
10/17/17 07:42 AM
Joined: Aug 2014
Posts: 326
Florida
lawnguy Offline OP
lawnguy  Offline OP
Joined: Aug 2014
Posts: 326
Florida
I have a snapper 21" self propelled mower. It has the Briggs 190cc engine. After of about 1 year of using it,for the past couple of months it is having a hard time starting. It used to start on the first pull every time,whether if the engine was hot or cold. It now takes approx 3 -7 pulls before it will start. It's usually around 4-5 hard pulls to typically start.

I have done all the required maint.,so If anyone can share some wisdom regarding this issue please advise.

Thanks!

Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4545895
10/17/17 07:48 AM
10/17/17 07:48 AM
Joined: Apr 2010
Posts: 4,398
Storrs, Connecticut
jeepman3071 Offline
jeepman3071  Offline
Joined: Apr 2010
Posts: 4,398
Storrs, Connecticut
The carburetor is likely gummed up and needs a cleaning. If you do a youtube search for Briggs 5hp Carburetor cleaning there has to be a how-to video somewhere showing how to take it apart and clean it.

Or, you could look up the engine numbers and search on ebay for a new carb.

I assume once it finally starts it runs okay?


2000 Jeep Cherokee 4.0L (180k) - Pennzoil 10w30, Napa Gold 1516, Magnefine trans filter
2009 BMW 328i (33k) - Castrol Edge Euro 0w40, MANN HU816X
Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4545904
10/17/17 07:58 AM
10/17/17 07:58 AM
Joined: Aug 2014
Posts: 326
Florida
lawnguy Offline OP
lawnguy  Offline OP
Joined: Aug 2014
Posts: 326
Florida
Yes, Once it starts it runs strong.

Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4545926
10/17/17 08:23 AM
10/17/17 08:23 AM
Joined: Apr 2009
Posts: 2,933
Canada
boraticus Offline
boraticus  Offline
Joined: Apr 2009
Posts: 2,933
Canada
Agreed. Carb problem. Likely the jet needs cleaning.

Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4545945
10/17/17 08:35 AM
10/17/17 08:35 AM
Joined: Jan 2011
Posts: 1,033
Columbus Nebraska
old1 Offline
old1  Offline
Joined: Jan 2011
Posts: 1,033
Columbus Nebraska
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


2017 Nissan Frontier 4.0 5w30
1965 Mustang 200 c/4 10w30 QS defy
1964 Ford Ranchero 302 c/4 15/40 Delo
1929 ford model A No filters, and 15/40 oil
Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4545948
10/17/17 08:37 AM
10/17/17 08:37 AM
Joined: Jun 2005
Posts: 5,244
North Texas
ARB1977 Offline
ARB1977  Offline
Joined: Jun 2005
Posts: 5,244
North Texas
On my Briggs power washer it was a dog tring to get it started. Come to find out it had a little too much oil.

Starts on the third pull. Before I had to use starting fluid.


2015 Tacoma 4.0L 60K (as of 02/23/18)
AMSOIL SS 0W30 / Toyota filter

2018 CRV 1.5L (as of 05/11/18)
Factory fill / Honda filter
Re: Briggs 190cc engine starting problems. [Re: old1] #4545971
10/17/17 08:52 AM
10/17/17 08:52 AM
Joined: Aug 2014
Posts: 326
Florida
lawnguy Offline OP
lawnguy  Offline OP
Joined: Aug 2014
Posts: 326
Florida
Originally Posted By: old1
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


It's auto choke. I was thinking about running seafoam through it a few times. Thoughts?

Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4545992
10/17/17 09:13 AM
10/17/17 09:13 AM
Joined: Jul 2012
Posts: 376
Michigan
khittner Offline
khittner  Offline
Joined: Jul 2012
Posts: 376
Michigan
Save yourself some grief. Buy a Honda-powered mower and forget the Snapper. Briggs engine = starting problems

Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4546005
10/17/17 09:20 AM
10/17/17 09:20 AM
Joined: Jan 2017
Posts: 278
Iowa
Iowegian Offline
Iowegian  Offline
Joined: Jan 2017
Posts: 278
Iowa
Here are some how to videos.

https://www.google.com/search?q=briggs+and+stratton+190cc+carburetor+cleaning&oq=briggs+190cc+carborator+cl&aqs=chrome.1.69i57j0.18464j0j7&client=ms-android-uscellular-us&sourceid=chrome-mobile&ie=UTF-8#scso=uid_WeYNNwACrwYKg-vDTwdqGQ_2:1


2011 Equinox, 2.4l
2009 Sienna, 3.5l
Re: Briggs 190cc engine starting problems. [Re: old1] #4546106
10/17/17 10:52 AM
10/17/17 10:52 AM
Joined: Apr 2009
Posts: 2,933
Canada
boraticus Offline
boraticus  Offline
Joined: Apr 2009
Posts: 2,933
Canada
Originally Posted By: old1
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


Good point. It's probably something to do with the enrichening circuit. Auto choke might be malfunctioning.

I've got an 8 h.p. B&S engine on my log splitter that's difficult to start if left for long term storage. I pretty much have to pull the plug & give it a few drops of gas into the cylinder to get it to fire. Once running, I can shut it of and refire it with one pull. I should probably check the choke linkage.

Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4546119
10/17/17 11:04 AM
10/17/17 11:04 AM
Joined: Sep 2011
Posts: 49
Jacksonville, FL
R_W_M Offline
R_W_M  Offline
Joined: Sep 2011
Posts: 49
Jacksonville, FL
I had the same problem on my 190cc B&S. It turned out that a spring on the auto choke mechanism had disconnected. Reconnected it (and gave the linkage a good cleaning!) Problem solved.


2005 Ford Five Hundred 87 K Mi.
2005 Ford Ranger 128 K mi.
Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4546147
10/17/17 11:30 AM
10/17/17 11:30 AM
Joined: Oct 2009
Posts: 3,209
Wet side WA
JohnnyJohnson Offline
JohnnyJohnson  Offline
Joined: Oct 2009
Posts: 3,209
Wet side WA
Originally Posted By: lawnguy
Originally Posted By: old1
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


It's auto choke. I was thinking about running seafoam through it a few times. Thoughts?


I have ran the Seafoam through mine and it seems to work. But how old is your gas and do you use a preservative in your gas. Oh I found my Briggs runs a whole lot better on premium gas. This winter drain your fuel tank and save yourself a lot of problems and start with fresh gas next spring.


2004 Corolla 124705
Out: VML 5w-30 TG4967 OCI 5007 Miles
In: EDGE EP 5W-30 Bosch 3311 122537 7-18-18
2006 Duramax 74277
Out: T6 5W-40 M1-303
In: T6 5W-40 XG9100 74705 4-22-18
Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4546186
10/17/17 12:02 PM
10/17/17 12:02 PM
Joined: Jan 2007
Posts: 17,501
Clovis, CA
Merkava_4 Offline
Merkava_4  Offline
Joined: Jan 2007
Posts: 17,501
Clovis, CA
Post up the engine numbers if you can.

Re: Briggs 190cc engine starting problems. [Re: khittner] #4546280
10/17/17 02:00 PM
10/17/17 02:00 PM
Joined: Apr 2010
Posts: 4,398
Storrs, Connecticut
jeepman3071 Offline
jeepman3071  Offline
Joined: Apr 2010
Posts: 4,398
Storrs, Connecticut
Originally Posted By: khittner
Save yourself some grief. Buy a Honda-powered mower and forget the Snapper. Briggs engine = starting problems


I fix non-starting Hondas with carb problems all the time.


2000 Jeep Cherokee 4.0L (180k) - Pennzoil 10w30, Napa Gold 1516, Magnefine trans filter
2009 BMW 328i (33k) - Castrol Edge Euro 0w40, MANN HU816X
Re: Briggs 190cc engine starting problems. [Re: lawnguy] #4546995
10/18/17 09:34 AM
10/18/17 09:34 AM
Joined: Aug 2003
Posts: 10,774
Buffalo, NY
JTK Offline
JTK  Offline
Joined: Aug 2003
Posts: 10,774
Buffalo, NY
I've got a Commercial snapper 21" with (I presume) the same 190cc "Professional series" Briggs. Like said, they have an auto choke that relies on exhaust heat to release itself. That's where I would look first.

FWIW, mine has started with 1-2 pulls since 2011. My only dislike of this engine is the tiny fuel tank.


2017 Ram 1500 4x4, 3.6L. 2016 Nissan Quest SV (Babe magnet IV)
Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™