Recent Topics
Matrix totaled
by circuitsmith
06/19/18 08:32 AM
Door rust problems
by Dave Sherman
06/19/18 07:51 AM
2016 Honda Civic problems
by dbias
06/19/18 07:39 AM
Royal purple 75-140 in a subaru rear
by 91camarosRS
06/19/18 07:32 AM
OCI. With short trips. Nissan 4 liter
by Gawardawg
06/19/18 06:52 AM
Approach Watching on the Beach @ St Maarten ...
by LoneRanger
06/19/18 06:41 AM
Honda Accord Needs Shocks; Front, Back, or Both?
by tc1446
06/19/18 05:50 AM
How much oil does your oil filter hold?
by Snagglefoot
06/19/18 05:44 AM
better day
by mx5miata
06/19/18 05:26 AM
BRAVO to Officer Wheeles......
by Sayjac
06/19/18 05:17 AM
People Watching ....Airport style.
by ZZman
06/19/18 04:24 AM
Subaru's at play...
by OneEyeJack
06/19/18 03:50 AM
Treating a 2003 Jetta
by llmercll
06/19/18 01:41 AM
Brakes not working - brake pedal sinks
by tookien
06/19/18 12:42 AM
Dave thinks I can make it 12--15k
by Marco620
06/19/18 12:26 AM
'05 Impala front wheel "squeal". Cost !
by Lee4212
06/19/18 12:16 AM
One Dollar Per Gallon?
by Y_K
06/18/18 11:53 PM
Walmart Tightening up Returns
by John_K
06/18/18 10:21 PM
flare nut wrench set
by spasm3
06/18/18 09:46 PM
Auto trans temperature scanner - help!
by JeffKeryk
06/18/18 09:45 PM
Newest Members
JustaDude, 3horseman, Firedog45, WtsTacoma01, Orion62
65265 Registered Users
Who's Online
84 registered (andyd, BAJA_05, AndyB, 2009Edge, 2004tdigls, ARCOgraphite, 7 invisible), 1499 Guests and 32 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65265 Members
67 Forums
285586 Topics
4765910 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Page 1 of 2 1 2 >
Topic Options
#4545891 - 10/17/17 07:42 AM Briggs 190cc engine starting problems.
lawnguy Offline


Registered: 08/17/14
Posts: 326
Loc: Florida
I have a snapper 21" self propelled mower. It has the Briggs 190cc engine. After of about 1 year of using it,for the past couple of months it is having a hard time starting. It used to start on the first pull every time,whether if the engine was hot or cold. It now takes approx 3 -7 pulls before it will start. It's usually around 4-5 hard pulls to typically start.

I have done all the required maint.,so If anyone can share some wisdom regarding this issue please advise.

Thanks!

Top
#4545895 - 10/17/17 07:48 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
jeepman3071 Online   content


Registered: 04/15/10
Posts: 4209
Loc: Storrs, Connecticut
The carburetor is likely gummed up and needs a cleaning. If you do a youtube search for Briggs 5hp Carburetor cleaning there has to be a how-to video somewhere showing how to take it apart and clean it.

Or, you could look up the engine numbers and search on ebay for a new carb.

I assume once it finally starts it runs okay?
_________________________
2000 Jeep Cherokee 4.0L (179k) - Pennzoil 10w30, Napa Gold 1516, Magnefine trans filter
2009 BMW 328i (32k) - Castrol Edge Euro 0w40, MANN HU816X

Top
#4545904 - 10/17/17 07:58 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
lawnguy Offline


Registered: 08/17/14
Posts: 326
Loc: Florida
Yes, Once it starts it runs strong.

Top
#4545926 - 10/17/17 08:23 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
boraticus Offline


Registered: 04/19/09
Posts: 2905
Loc: Canada
Agreed. Carb problem. Likely the jet needs cleaning.

Top
#4545945 - 10/17/17 08:35 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
old1 Online   content


Registered: 01/04/11
Posts: 999
Loc: Columbus Nebraska
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?
_________________________
2017 Nissan Frontier 4.0 5w30
1965 Mustang 200 c/4 10w30 QS defy
1964 Ford Ranchero 302 c/4 15/40 Delo
1929 ford model A No filters, and 15/40 oil

Top
#4545948 - 10/17/17 08:37 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
ARB1977 Offline


Registered: 06/12/05
Posts: 5167
Loc: North Texas
On my Briggs power washer it was a dog tring to get it started. Come to find out it had a little too much oil.

Starts on the third pull. Before I had to use starting fluid.
_________________________
2015 Tacoma 4.0L 60K (as of 02/23/18)
Amsoil SS 0W30 / Toyota filter

2018 CRV 1.5L (as of 05/11/18)
Factory fill / Factory filter

Top
#4545971 - 10/17/17 08:52 AM Re: Briggs 190cc engine starting problems. [Re: old1]
lawnguy Offline


Registered: 08/17/14
Posts: 326
Loc: Florida
Originally Posted By: old1
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


It's auto choke. I was thinking about running seafoam through it a few times. Thoughts?

Top
#4545992 - 10/17/17 09:13 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
khittner Offline


Registered: 07/13/12
Posts: 306
Loc: Michigan
Save yourself some grief. Buy a Honda-powered mower and forget the Snapper. Briggs engine = starting problems

Top
#4546005 - 10/17/17 09:20 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
Iowegian Offline


Registered: 01/05/17
Posts: 273
Loc: Iowa
Here are some how to videos.

https://www.google.com/search?q=briggs+and+stratton+190cc+carburetor+cleaning&oq=briggs+190cc+carborator+cl&aqs=chrome.1.69i57j0.18464j0j7&client=ms-android-uscellular-us&sourceid=chrome-mobile&ie=UTF-8#scso=uid_WeYNNwACrwYKg-vDTwdqGQ_2:1
_________________________
2011 Equinox, 2.4l
2009 Sienna, 3.5l

Top
#4546106 - 10/17/17 10:52 AM Re: Briggs 190cc engine starting problems. [Re: old1]
boraticus Offline


Registered: 04/19/09
Posts: 2905
Loc: Canada
Originally Posted By: old1
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


Good point. It's probably something to do with the enrichening circuit. Auto choke might be malfunctioning.

I've got an 8 h.p. B&S engine on my log splitter that's difficult to start if left for long term storage. I pretty much have to pull the plug & give it a few drops of gas into the cylinder to get it to fire. Once running, I can shut it of and refire it with one pull. I should probably check the choke linkage.

Top
#4546119 - 10/17/17 11:04 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
R_W_M Offline


Registered: 09/22/11
Posts: 49
Loc: Jacksonville, FL
I had the same problem on my 190cc B&S. It turned out that a spring on the auto choke mechanism had disconnected. Reconnected it (and gave the linkage a good cleaning!) Problem solved.
_________________________
2005 Ford Five Hundred 87 K Mi.
2005 Ford Ranger 128 K mi.
1997 Honda CR-V 285 K mi. (Now my son's.)

Top
#4546147 - 10/17/17 11:30 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
JohnnyJohnson Online   content


Registered: 10/22/09
Posts: 2734
Loc: Wet side WA
Originally Posted By: lawnguy
Originally Posted By: old1
I agree it may be a carb problem, BUT, if it runs fine after starting, I don't think it is the jets. I would think it is the cold start enrichment system. does it have an automatic choke, or a primer bulb?


It's auto choke. I was thinking about running seafoam through it a few times. Thoughts?


I have ran the Seafoam through mine and it seems to work. But how old is your gas and do you use a preservative in your gas. Oh I found my Briggs runs a whole lot better on premium gas. This winter drain your fuel tank and save yourself a lot of problems and start with fresh gas next spring.
_________________________
2004 Toyota Corolla 121598
Out: QSUD 5W-30 Purolator One 5030
In: Valvoline ML 5w-30 TG4967 117530 2-8-18
2006 Duramax 74016
Out: T6 5W-40 M1-303
In: T6 5W-40 XG9100 73752 4-22-18

Top
#4546186 - 10/17/17 12:02 PM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
Merkava_4 Offline


Registered: 01/30/07
Posts: 17501
Loc: Clovis, CA
Post up the engine numbers if you can.

Top
#4546280 - 10/17/17 02:00 PM Re: Briggs 190cc engine starting problems. [Re: khittner]
jeepman3071 Online   content


Registered: 04/15/10
Posts: 4209
Loc: Storrs, Connecticut
Originally Posted By: khittner
Save yourself some grief. Buy a Honda-powered mower and forget the Snapper. Briggs engine = starting problems


I fix non-starting Hondas with carb problems all the time.
_________________________
2000 Jeep Cherokee 4.0L (179k) - Pennzoil 10w30, Napa Gold 1516, Magnefine trans filter
2009 BMW 328i (32k) - Castrol Edge Euro 0w40, MANN HU816X

Top
#4546995 - 10/18/17 09:34 AM Re: Briggs 190cc engine starting problems. [Re: lawnguy]
JTK Offline


Registered: 08/14/03
Posts: 10559
Loc: Buffalo, NY
I've got a Commercial snapper 21" with (I presume) the same 190cc "Professional series" Briggs. Like said, they have an auto choke that relies on exhaust heat to release itself. That's where I would look first.

FWIW, mine has started with 1-2 pulls since 2011. My only dislike of this engine is the tiny fuel tank.
_________________________
2017 Ram 1500 4x4, 3.6L. 2016 Nissan Quest SV (Babe magnet IV)

Top
Page 1 of 2 1 2 >