Recent Topics
Tundra vibration
by pda1122
04/22/18 08:39 PM
Who says Corvettes are gas guzzlers?
by Patman
04/22/18 08:26 PM
Mobile rebate question
by Snowball
04/22/18 08:25 PM
Oil shear and 0w,5w,10w?
by Camprunner
04/22/18 05:42 PM
Looks like the Jeep needs axle bearings
by Nick1994
04/22/18 05:13 PM
Toyota OEM Cartridge Filter, Cut Open 12,669 Miles
by Nick1994
04/22/18 04:53 PM
S/C Range Rover, 5000kms 33 different oils UOA
by Vladiator
04/22/18 04:24 PM
Buying oil on price - Pricing Rant
by JHZR2
04/22/18 04:22 PM
Mix of 33 oils VOA
by Vladiator
04/22/18 04:19 PM
Sugar Binge Hangover ... :~/
by LoneRanger
04/22/18 04:18 PM
MagnaFlow 49253 Exhaust Header
by Ambition5253
04/22/18 04:14 PM
Difference between NGK BR6ES and BPR6ES ?!?
by webfors
04/22/18 04:08 PM
Griot's Garage Glass Polish leaving dried flakes
by mclasser
04/22/18 03:56 PM
Pennzoil Platinum 10W30
by turnbowm
04/22/18 03:55 PM
Adhesive for clay pot repair?
by callbay
04/22/18 03:40 PM
G35 rough start
by bowlofturtle
04/22/18 03:37 PM
Parts Master 67045 5K OCI Cut Open
by Ifixjetz1
04/22/18 03:03 PM
Best Subcompact Cars in the US & Global
by NewEnglander
04/22/18 02:41 PM
Super Tech Clearance purchase
by mctmatt
04/22/18 01:58 PM
Website Loading Issue
by sleddriver
04/22/18 01:51 PM
Newest Members
daylateetc, Kjammer, sonnyk, PWMDMD, usernameunknown
64820 Registered Users
Who's Online
108 registered (2007BMW335i, 2015_PSD, amcguru, 123Saab, andyd, 14 invisible), 1732 Guests and 47 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
64820 Members
68 Forums
282151 Topics
4710644 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4541232 - 10/12/17 01:58 PM 1998 k3500 7.4l wont start
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
I am having trouble starting my 1998 k3500 7.4l dually. One day it just shut down. Wound up being the coil. I replaced it and drover her for about 2 weeks. She shut off again. Thought maybe it was fuel pump. I replaced the fuel pump nothing. Replaced the coil again. Nothing. I replaced the camshaft postion sensor. I also replaced the crankshaft position sensor. I replaced the rotor and distribitor cap. I also replaced the ignition control module. Also the fuel filter. I am getting beautiful spark and plenty of fuel pressure. I am at my wits end with this truck and i cant think of anything else. Also i replaced all 8 spark plugs. I checked the timing by putting her at tdc. I also checked the maf sensor and map sensor. Please if anybody has any info please help...

Top
#4541238 - 10/12/17 02:02 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Nick1994 Offline


Registered: 02/19/13
Posts: 9823
Loc: Phoenix, AZ
Spark to all cylinders?

Injectors pulsing?

Squirt some fuel down the throttle body and see if it tries to start.
_________________________
2015 Hyundai Sonata 2.4L 76k PU 5w30 & OEM
2000 Toyota Camry 2.2L 227k M1 AFE 0w30 & Wix
1996 Jeep Cherokee 4.0L 145k M1 HM 10w40 & Fram Ultra

Top
#4541254 - 10/12/17 02:19 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
Spark to all cylinders yes. And i tried carb cleaner and it doesnt start. How do i tell if they are pulsing

Top
#4541260 - 10/12/17 02:29 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Nick1994 Offline


Registered: 02/19/13
Posts: 9823
Loc: Phoenix, AZ
I know on TBI engines there’s a bulb you can plug in to see if the injectors are getting power, not sure on the Vortec engines. Someone on here will probably know, might be able to just use a test light while cranking.
_________________________
2015 Hyundai Sonata 2.4L 76k PU 5w30 & OEM
2000 Toyota Camry 2.2L 227k M1 AFE 0w30 & Wix
1996 Jeep Cherokee 4.0L 145k M1 HM 10w40 & Fram Ultra

Top
#4541265 - 10/12/17 02:40 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
I forgot to mention the only code showing in the systmem is p1351 which is high voltage to icm but its a brand new oem icm i put on and nothing but the code keeps popping up everytime i clear it

Top
#4541284 - 10/12/17 03:20 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Rand Offline


Registered: 08/20/03
Posts: 12485
Loc: NE,Ohio
sounds like a possible wiring issue.

What fuel pressure do you have? does it hold fuel pressure for at least a few mins?

Sounds like maybe its time for it to go to someone with better tools and troubleshooting guide.
_________________________
2017 Jeep Cherokee Trailhawk V6

Top
#4541291 - 10/12/17 03:25 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
I took it to a mechanic shop and they are the ones who told me to replace the icm and spark plugs.

Top
#4541298 - 10/12/17 03:33 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Rand Offline


Registered: 08/20/03
Posts: 12485
Loc: NE,Ohio
Originally Posted By: jubinjr
I took it to a mechanic shop and they are the ones who told me to replace the icm and spark plugs.


Well I hope you get your money back then because it didnt fix it.
_________________________
2017 Jeep Cherokee Trailhawk V6

Top
#4541307 - 10/12/17 03:43 PM Re: 1998 k3500 7.4l wont start [Re: Rand]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
Well i did the work myself. All they did was kind of diagnos it. Im just trying what else could be causing this issue. She sounds like she wants to fire but wont

Top
#4541354 - 10/12/17 04:30 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
mk378 Offline


Registered: 09/27/15
Posts: 1328
Loc: USA
My friend has the same engine. The problem he had turned out to be a hole in the main spark wire from the coil to the distributor leaking sparks out. A test plug would fire outside the engine, but it was not enough spark to start it. If you can't get it to fire at all on starting fluid you should take a close look at the ignition parts, which as you know are very hard to see where they are way at the back of the engine.

Throwing codes related to the interface between the PCM and ICM could be a problem with the low voltage wiring, or even a bad PCM.


Edited by mk378 (10/12/17 04:32 PM)

Top
#4541422 - 10/12/17 06:04 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
kc8adu Offline


Registered: 08/02/05
Posts: 885
Loc: dayton oh
a bad coil wire can cause an insulation failure in the coil.
gets a gap burned in it that has to be jumped which causes overshoot.
you can get a spark with the plug out that is too weak under compression.
spark too weak or worse jumped timing.
have also seen rotor button arc through.

Top
#4541886 - 10/13/17 07:20 AM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
How will i know if it isnt sparking inside the cylinder? And i have checked timing. Timing is correct

Top