Recent Topics
Remote Start by Android Auto App ?
by LoneRanger. 04/19/19 04:53 PM
Continental PureContact LS
by The Critic. 04/19/19 03:31 PM
Dark/Black Rear Differential Oil - UOA?
by The Critic. 04/19/19 03:25 PM
Best oil for Honda Rancher?
by jayjr1105. 04/19/19 03:20 PM
Store bought kimchi?
by Quattro Pete. 04/19/19 03:15 PM
2020 KIA Soul Turbo
by Malo83. 04/19/19 03:03 PM
erratic Speedometer
by tookien. 04/19/19 02:59 PM
Another airbag recall
by mclasser. 04/19/19 02:44 PM
Which barb fitting is less likely to leak?
by zorobabel. 04/19/19 02:36 PM
Can these bucket style tappets be reused?
by atikovi. 04/19/19 01:34 PM
Scratched My New Car. Help Me Fix
by GeorgeKaplan. 04/19/19 01:23 PM
Talk about manual labor...
by AZjeff. 04/19/19 12:42 PM
Car didn't burn an ounce of oil... 7K OCI
by jayjr1105. 04/19/19 12:13 PM
Top 6 OEM Passenger Tire Sizes in 2018
by SubLGT. 04/19/19 11:12 AM
CRC intake valve cleaner, safe to use?
by Backstache. 04/19/19 10:06 AM
'94 Grand Am Steering Column Pivot Pins
by benjamming. 04/19/19 10:02 AM
Why the need to replace suspension springs?
by WyrTwister. 04/19/19 09:47 AM
incorrect mileage on reciept
by 1978elcamino. 04/19/19 09:17 AM
Oregon PowerSharp for chainsaw
by Fitter30. 04/19/19 09:16 AM
new tire 4 years old
by 1978elcamino. 04/19/19 08:51 AM
Newest Members
carve200, Harteeco, fatafox, CurtC, LockCracker
67850 Registered Users
Who's Online Now
92 registered members (ArrestMeRedZ, 2009Edge, ammolab, 2015_PSD, bbhero, 12 invisible), 2,125 guests, and 32 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics287,749
Posts4,933,812
Members67,850
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
Page 1 of 3 1 2 3
Purolator P1 #22500 12,600 miles CUT OPEN #4524778
09/24/17 11:57 AM
09/24/17 11:57 AM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
Good Sunday afternoon BITOG faithful. Hi Jim smile

This filter was off my new boss's 2016 Ford Expedition with Eco Boost 3.5 v-6 engine. Had 2 oci's of M1 0w20 AFE. Filter looks ok minus the 2 cuts in ADBV. SUV has 69,000 miles on it already as he bought it used. Put another load of M1 0w20 AFE and a FU 10575 oil filter in and on.

Enjoy the pictures and he does 98% highway driving



















Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524780
09/24/17 11:59 AM
09/24/17 11:59 AM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
Better pic of date code smile




Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524835
09/24/17 12:56 PM
09/24/17 12:56 PM
Joined: Sep 2010
Posts: 7,712
Houston, TX
2015_PSD Online content
2015_PSD  Online Content

Joined: Sep 2010
Posts: 7,712
Houston, TX
What are all of the particles on the element? Is this from cutting it open or is it just an optical illusion? As for the choice of filters, just why? Cut ADBVs are the norm these days with Purolator...


2018 Mercedes Benz AMG GLC43 3.0L Bi-Turbo [Castrol Edge 0W-40 & Purflux filter]
2018 Mercedes Benz C300 2.0L Turbo [Pennzoil Platinum Euro 0W-40 & Mann filter]
Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524860
09/24/17 01:15 PM
09/24/17 01:15 PM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
Maybe illusion. Think he got filter and m1 0w20 AFE as oil change deal



Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524917
09/24/17 02:38 PM
09/24/17 02:38 PM
Joined: Feb 2003
Posts: 6,139
Cajun Country, La.
BlueOvalFitter Online content
BlueOvalFitter  Online Content

Joined: Feb 2003
Posts: 6,139
Cajun Country, La.
I am TRULY amazed that this Purolator filter didn't have torn media. Ah, but it didn't escape some kind of scrutiny, as the ADBV had cuts in it. shrug
Thanx for the C&P car51.
smile


2007 F150, 4.2 V6
Havoline HM 5W20, NAPA GOLD FIL-1516 MC FL-400S
Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: BlueOvalFitter] #4524934
09/24/17 02:54 PM
09/24/17 02:54 PM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
Originally Posted By: BlueOvalFitter
I am TRULY amazed that this Purolator filter didn't have torn media. Ah, but it didn't escape some kind of scrutiny, as the ADBV had cuts in it. shrug
Thanx for the C&P car51.
smile


Always good to hear from you BlueOvalFilter smile

I too was surprised there were no tears



Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524953
09/24/17 03:14 PM
09/24/17 03:14 PM
Joined: Oct 2004
Posts: 8,858
Cincinnati, OH, USA
bullwinkle Online confused
bullwinkle  Online Confused

Joined: Oct 2004
Posts: 8,858
Cincinnati, OH, USA
car51/Adam-off topic, what kind of highway mileage is he getting with his EB Expedition? The MSRP on them is pretty high, but I'm thinking about trimming down the fleet somewhat.


06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)
Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524957
09/24/17 03:25 PM
09/24/17 03:25 PM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
I believe he said 24.5 was best so far as he drives pretty fast. I dunno what "window sticker" says they get.



Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4524996
09/24/17 04:20 PM
09/24/17 04:20 PM
Joined: Apr 2012
Posts: 10,627
Kendall, FL
wemay Offline
wemay  Offline

Joined: Apr 2012
Posts: 10,627
Kendall, FL
Looks good to me. Thanks Car51


18 KIA Sportage 2.4 AWD
QSUD 5W-20, PH9688

13 Hyundai Santa Fe Sport 2.0T
PP EuroL 5W-30, OE
Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4525024
09/24/17 04:56 PM
09/24/17 04:56 PM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
You're welcome Wemay smile



Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4525031
09/24/17 05:04 PM
09/24/17 05:04 PM
Joined: Apr 2015
Posts: 206
Houston, TX
czbrian Offline
czbrian  Offline

Joined: Apr 2015
Posts: 206
Houston, TX
He is using 0w20 in an ecoboost 3.5? Is that what Ford calls for on the expedition? I thought it was 5w30?

Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: czbrian] #4525041
09/24/17 05:16 PM
09/24/17 05:16 PM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
Originally Posted By: czbrian
He is using 0w20 in an ecoboost 3.5? Is that what Ford calls for on the expedition? I thought it was 5w30?


I honestly didn't ask or look at the oil cap. We put in m1 0w30 AFE, not 0w20; that's my misprint/fault



Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4525062
09/24/17 05:37 PM
09/24/17 05:37 PM
Joined: Feb 2011
Posts: 7,156
Hudson, NH
LeakySeals Offline
LeakySeals  Offline

Joined: Feb 2011
Posts: 7,156
Hudson, NH
I've seen those particles after switching to synthetic oil for the first time. Old dried-up carbon particles removed by the synthetic oil. You said he went 12,000 miles on the oil change. Maybe he was going along with conventional and built up some deposits


06 Escalade 6.0L LQ9 AWD 167k M1 0w40
03 Maxima 3.5L POS 170k ST HM 10w30
05 Malibu Classic 109k Unk
Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: LeakySeals] #4525082
09/24/17 06:04 PM
09/24/17 06:04 PM
Joined: Mar 2015
Posts: 12,544
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,544
In the shop
Originally Posted By: LeakySeals
I've seen those particles after switching to synthetic oil for the first time. Old dried-up carbon particles removed by the synthetic oil. You said he went 12,000 miles on the oil change. Maybe he was going along with conventional and built up some deposits


No, he did 2 oci's; each OCI was with M1 0w20 AFE



Re: Purolator P1 #22500 12,600 miles CUT OPEN [Re: 53' Stude] #4525084
09/24/17 06:06 PM
09/24/17 06:06 PM
Joined: Aug 2013
Posts: 516
Alberta
tcp71 Offline
tcp71  Offline

Joined: Aug 2013
Posts: 516
Alberta
The ecoboost is spec'd for 5w30. I suspect that unless you are towing, the 20weight wouldn't cause problems. Why not an fl500s


2016 F150 Eco: Edge 0w40
2005 Sienna 3.3: mobil 0w40 (varies)
Page 1 of 3 1 2 3
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™