Recent Topics
IPhone SE or flip phone?
by 53' Stude. 12/18/18 05:49 PM
1993 K1500 hard cold start
by BrianF. 12/18/18 05:43 PM
Put my wife's dog down yesterday
by Stelth. 12/18/18 05:04 PM
ATF Filter oem vs aftermarket any differences?
by 97prizm. 12/18/18 03:50 PM
Depth-Fiberglass Filter Media.
by Al. 12/18/18 03:43 PM
O2 sensor B1S1 no voltage??
by David1. 12/18/18 03:43 PM
Brilliant payback for package thieves
by SirTanon. 12/18/18 01:22 PM
Calling all Ford Owners
by dogememe. 12/18/18 01:01 PM
2003 Ford CVPI, 86kmi, 6kmi on Edge HM Ti 5W30
by Colt45ws. 12/18/18 12:35 PM
2017 Kia Sportage recall notice
by SlavaB. 12/18/18 12:26 PM
My VW Service Experience
by Delta. 12/18/18 11:36 AM
Nissan high idle, P0507
by LeakySeals. 12/18/18 11:23 AM
Should i go for even thinner fluid ?
by NICAT. 12/18/18 11:06 AM
Viscosity question
by dbierman. 12/18/18 10:50 AM
48 hours and a used car
by Imp4. 12/18/18 09:32 AM
Test driving PHEV w no battery charge
by RichardS. 12/18/18 09:02 AM
2005 Ford PSD with hard shifts when cold?
by racin4ds. 12/18/18 08:08 AM
18% off Ravenol + EVERYTHING @ Blauparts.com
by CleverUserName. 12/18/18 07:48 AM
Newest Members
MuhThugga, wxo, dbierman, keyblade, leeal
66716 Registered Users
Who's Online Now
119 registered members (53' Stude, 2K2AcuraTL, -SyN-, ABomb369, 01rangerxl, 77GrandPrix, 11 invisible), 2,002 guests, and 45 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics295,230
Posts4,930,586
Members66,716
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Dex VI in 2006 Lucerne Power Steering? #4518702
09/17/17 02:34 PM
09/17/17 02:34 PM
Joined: Feb 2007
Posts: 3,704
Southeast
meep Offline OP
meep  Offline OP
Joined: Feb 2007
Posts: 3,704
Southeast
Hey there,

My brother came by with his 06 Lucerne and the PS was very low. It was also black -- looked like it was once maybe red. Car has almost 100k on it.

I had Dex VI in the garage and drained the reservoir and refilled with Dex VI. No noise and it drives great.

Is this OK? Now I'm reading on the internet that it should use a GM specific PS fluid.

Should I drain and refill?

-meep


2018 F150
2015 crv (wifey!)
Re: Dex VI in 2006 Lucerne Power Steering? [Re: meep] #4518703
09/17/17 02:38 PM
09/17/17 02:38 PM
Joined: Sep 2005
Posts: 5,920
MIchigan
Warstud Offline
Warstud  Offline
Joined: Sep 2005
Posts: 5,920
MIchigan
I would fix the leak first. PS fluid should never get low.

Re: Dex VI in 2006 Lucerne Power Steering? [Re: meep] #4518804
09/17/17 04:54 PM
09/17/17 04:54 PM
Joined: Jan 2017
Posts: 639
Melbourne, Florida
RichardS Online content
RichardS  Online Content
Joined: Jan 2017
Posts: 639
Melbourne, Florida
Definitely look for the leak, but I've used Dex VI, Dex III, and P.S. fluid in my work truck ('06 chevy 2500HD),and not noticed any difference in steering sound or feel.

But I also lose about a 1/2 quart a month, and only started using the DEX mixes since April to use up old DEXIII that's been in the shed for the better part of 15 years in a truck nearing the end of it's useful life for us, so FYI.


2008 Dodge Caliber SE 2.0 117k
4qt Imeditsu 0w-20, 1/2qt Mobil SS 5w-20 Fram HM

2003 Buick Century 107k
4.5q Havoline 5w-30 HM Fram XG
Re: Dex VI in 2006 Lucerne Power Steering? [Re: meep] #4518953
09/17/17 07:36 PM
09/17/17 07:36 PM
Joined: Feb 2007
Posts: 3,704
Southeast
meep Offline OP
meep  Offline OP
Joined: Feb 2007
Posts: 3,704
Southeast
thanks guys. not too worried about the leak. I'm pretty sure it's the oem fluid with next to no maintenance. Going low over 11 years.. meh...

I went ahead and err'd on the side of caution and hit the store for a 3rd time for the right stuff. Vacuumed out the Dex and used real PSF. I was more worried about seal compatability, and GM made some changes twice from what I can read about in the 2000's -- first away from ATF around 02 and then back to ATF around '12. Some forums mention rack pinion seals in certain buicks being sensitive in that timeframe.

-m


2018 F150
2015 crv (wifey!)
Re: Dex VI in 2006 Lucerne Power Steering? [Re: meep] #4519118
09/18/17 03:38 AM
09/18/17 03:38 AM
Joined: Sep 2013
Posts: 10,692
Indiana
dlundblad Offline
dlundblad  Offline
Joined: Sep 2013
Posts: 10,692
Indiana
When I brought my truck home, the PSF level was on the very bottom of the dipstick. I topped it off and drove it a few months keeping an eye on the (non changing) level.

Flushed the system with clean PSF. I could have used ATF, but I already stock the stuff for my Jeep. No change in level. I've put over 10k on it already. I prefer the level to be ~25% between the hot and cold mark when cold.


03 Jeep WJ 4.0 202k Castrol Edge 10w40 HM Fram XG16
02 Volvo S60 2.4T 186k M1 0w40 Mahle OX149D
97 Chevy Blazer 4.3 153k Synpower 5w30 Supertech ST3980 (Ecore)

Re: Dex VI in 2006 Lucerne Power Steering? [Re: meep] #4519149
09/18/17 05:30 AM
09/18/17 05:30 AM
Joined: Sep 2016
Posts: 168
MN
Tman220 Offline
Tman220  Offline
Joined: Sep 2016
Posts: 168
MN
Use Dex VI with confidence. I had a 09 Malibu that had a squeak while turning, which from what I read at that time was attributed to a seal on the rack and didnít like the PSF that GM was using. The dealer wanted to replace the rack under warrantee, (only had 16,000 miles on the car) my work schedule didnít allow for that at the time. Long story short I decided to switch over to Dex VI, the squeak I was hearing quickly faded and then left for good. God rid of the car at 130,000 miles, no squeak, no leaks.


2012 Regal GS Turbo PP 5w30
1994 Camaro Z28 LT1 355 CI, 430 RWHP PP 5W30

BOB IS THE OIL GUY® Powered by UBB.threads™