Recent Topics
silly wiper problem
by bowlofturtle. 09/20/18 10:33 PM
Canadian Tire Shell Rotella T-6 in Pails
by Snagglefoot. 09/20/18 10:04 PM
Best diesel fuel for cold weather?
by Dickm. 09/20/18 10:03 PM
Type 1 Diabetics - New Research
by StevieC. 09/20/18 10:00 PM
Tire Sizing and Options
by NewEnglander. 09/20/18 09:59 PM
2013 Scion FR-S | Transmission Fluid Questions
by nicknak. 09/20/18 09:47 PM
Meguiar's Liquid Cleaner Wax $5 WalMart, Amazon
by The_Cams. 09/20/18 08:42 PM
Winter oil recommendation
by Neptune. 09/20/18 08:27 PM
M1 0W-40
by CT8. 09/20/18 07:37 PM
What controls timing on my 08 Honda?
by Roland. 09/20/18 07:23 PM
The real culprit about 18k
by Ablebody. 09/20/18 06:04 PM
How not to drain a pool.
by StevieC. 09/20/18 05:50 PM
Tranny fluid in Old Ferguson Tractor ?
by Rudy1999 250. 09/20/18 03:39 PM
New (old) car inbound
by BeerCan. 09/20/18 02:42 PM
Ford AWD PTU fluid always black
by Raven. 09/20/18 02:34 PM
PC not charging
by sleepery. 09/20/18 01:53 PM
Can alternators make noise?
by Benzadmiral. 09/20/18 01:21 PM
Newest Members
Direct_Rejection, donatom, Sylent_Snyper, Ajizzle, nicknak
66033 Registered Users
Who's Online Now
77 registered members (Ablebody, A310, 69Torino, AMC, alphadog, ABCarr, 12 invisible), 1,362 guests, and 38 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,738
Posts4,849,384
Members66,033
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
AC fixed but still not blowing cold air #4505920
09/03/17 12:03 AM
09/03/17 12:03 AM
Joined: Sep 2015
Posts: 921
Little Havana, Miami
gallydif Offline OP
gallydif  Offline OP
Joined: Sep 2015
Posts: 921
Little Havana, Miami
Things that have been done recently to the roadmaster-
New: ac drier, hose assembly, condenser, orifice tube.

System was vacuumed out and charged. Oil in. It is leak free

Compressor only has 66k miles on. Doesnt make any wierd noises. Still engages.


After all of this my ac comes out lukecool at best. This cars ac used to be freezing! Any input appreciated.


96 fleetwood 63k dd- MaxLife 5w30, AC Delco pf52
95 Caprice 67k LT1 dd- Mag1 dino 5w30, same ^
84 Caprice Landau 14k- MS5K 5w30, AC D pf454
96 Buick Roadmaster 65k- RIP 17
00 Town Car- RIP 16
Re: AC fixed but still not blowing cold air [Re: gallydif] #4505925
09/03/17 12:43 AM
09/03/17 12:43 AM
Joined: Feb 2013
Posts: 10,685
Phoenix, AZ
Nick1994 Online content
Nick1994  Online Content
Joined: Feb 2013
Posts: 10,685
Phoenix, AZ
Fan clutch?

My grandparent's Trailblazer had lousy a/c for years, even after recharging the system it wasn't very good. Replaced the fan clutch and crzy it blows ice cold!


2015 Hyundai Sonata 2.4L 84k Mobil 1 AFE 0w30 & OEM
2000 Toyota Camry 2.2L 230k Valvoline 5w30 & Fram Ultra
1996 Jeep Cherokee 4.0L 147k Mobil 1 HM 10w40 & Fram Ultra
Re: AC fixed but still not blowing cold air [Re: gallydif] #4505930
09/03/17 01:17 AM
09/03/17 01:17 AM
Joined: Dec 2009
Posts: 25,355
Regina, Saskatchewan, Canada
Garak Offline
Garak  Offline
Joined: Dec 2009
Posts: 25,355
Regina, Saskatchewan, Canada
Is the temperature adjustment working, or is something there stuck?


Plain, simple Garak.

2008 Infiniti G37 - Shell ROTELLA T6 Multi-Vehicle 5w-30, NAPA Gold 7356
1984 F-150 4.9L - Quaker State GB 10w-30, Wix 51515
Re: AC fixed but still not blowing cold air [Re: gallydif] #4505955
09/03/17 04:45 AM
09/03/17 04:45 AM
Joined: Jan 2007
Posts: 17,501
Clovis, CA
Merkava_4 Offline
Merkava_4  Offline
Joined: Jan 2007
Posts: 17,501
Clovis, CA
You can tell a lot by hooking up a set of manifold gauges; most importantly, if the shop cheated you on refrigerant.

Re: AC fixed but still not blowing cold air [Re: gallydif] #4505956
09/03/17 04:46 AM
09/03/17 04:46 AM
Joined: Jan 2013
Posts: 1,842
Texas
WyrTwister Offline
WyrTwister  Offline
Joined: Jan 2013
Posts: 1,842
Texas
Is the vapor / low pressure line going to the accumulator getting cold ?


Wyr
God bless
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506009
09/03/17 08:00 AM
09/03/17 08:00 AM
Joined: May 2010
Posts: 9,047
North Carolina
spasm3 Offline
spasm3  Offline
Joined: May 2010
Posts: 9,047
North Carolina
Yes you need gauges on it. Could be a gummed up orifice tube, if someone used stop leak in it.


13 elantra 70k 5w30 QSUD
03 chevy avalanche79k synpwr 10w30
01 saturnsc1 185k synpwr rebuilt
17 mazda cx-5 5600 miles m1 0w30
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506061
09/03/17 09:11 AM
09/03/17 09:11 AM
Joined: Jun 2003
Posts: 17,347
Deplorable in apple valley, ca
Chris142 Online content
Chris142  Online Content
Joined: Jun 2003
Posts: 17,347
Deplorable in apple valley, ca
Is the suction line cold? Whats the pressures?


02 Wrangler durablend 10w40
87 F250 traveler 15w40
04 Tahoe super-s 10w30
Z400 castrol T 10w40
Can am maveric edge 5w40
57 case tractor 15w40
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506127
09/03/17 10:16 AM
09/03/17 10:16 AM
Joined: Feb 2013
Posts: 76
Herrin, Illinois
CharlieW618 Offline
CharlieW618  Offline
Joined: Feb 2013
Posts: 76
Herrin, Illinois
Evidently it ain't fixed.


Formally Charlie1935
Du Quoin, Il.
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506181
09/03/17 11:25 AM
09/03/17 11:25 AM
Joined: Dec 2003
Posts: 9,800
Florida, Cape Coral
Eddie Offline
Eddie  Offline
Joined: Dec 2003
Posts: 9,800
Florida, Cape Coral
The air blend door sticking will cause this problem.


CX5 Touring 2.5L :-)
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506192
09/03/17 11:39 AM
09/03/17 11:39 AM
Joined: Sep 2015
Posts: 921
Little Havana, Miami
gallydif Offline OP
gallydif  Offline OP
Joined: Sep 2015
Posts: 921
Little Havana, Miami
Garak- the temp adj is working

Wyr- the low pressure line to the drier is getting cold

Chris142- with the gauges on, thr guy at the shop told me the pressure needs to be between 40-50. Was at 40 and he put some more refridgerant in there to be at 45.

The car was on for about an hour today and driven at the ac's highest fan mode and lowet temp. For about 2 minutes i got the tease of it blowing almost as cold as it used to. Then went right back to lukecool. Blend door problem?


96 fleetwood 63k dd- MaxLife 5w30, AC Delco pf52
95 Caprice 67k LT1 dd- Mag1 dino 5w30, same ^
84 Caprice Landau 14k- MS5K 5w30, AC D pf454
96 Buick Roadmaster 65k- RIP 17
00 Town Car- RIP 16
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506212
09/03/17 11:50 AM
09/03/17 11:50 AM
Joined: Jan 2013
Posts: 1,842
Texas
WyrTwister Offline
WyrTwister  Offline
Joined: Jan 2013
Posts: 1,842
Texas
The basics of refrigeration is temperatures and pressures .

I try to run the evaporator coil at around 35F to avoid freezing the coil .

That , under perfect conditions , with R-134a , to 30.5 psi . So , for me , he has too much refrigerant in your system .

But , if the suction / low pressure line is cool , you should be at least be getting some cool air . If not cold .

So , I am still thinking a problem with a blend door or the control problem .

Last edited by WyrTwister; 09/03/17 12:02 PM.

Wyr
God bless
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506238
09/03/17 12:08 PM
09/03/17 12:08 PM
Joined: Sep 2015
Posts: 1,523
USA
mk378 Online content
mk378  Online Content
Joined: Sep 2015
Posts: 1,523
USA
If the suction line is much colder than the air from the vents, there is a blend door problem.

Charging by pressure, and watching only one gauge at that, is the wrong way to do it. There's a good chance he didn't bother to use a vacuum pump either, which means the refrigerant is contaminated with air and will need to be replaced to get full performance.

Re: AC fixed but still not blowing cold air [Re: gallydif] #4506288
09/03/17 01:22 PM
09/03/17 01:22 PM
Joined: Sep 2015
Posts: 1,523
USA
mk378 Online content
mk378  Online Content
Joined: Sep 2015
Posts: 1,523
USA
Also if you're saying it was cold for 2 minutes when you first started the car, then warmed up, that really suggests the heater core is fighting the A/C.

Re: AC fixed but still not blowing cold air [Re: Merkava_4] #4506298
09/03/17 01:33 PM
09/03/17 01:33 PM
Joined: Jun 2009
Posts: 429
New England
555 Offline
555  Offline
Joined: Jun 2009
Posts: 429
New England
Originally Posted By: Merkava_4
You can tell a lot by hooking up a set of manifold gauges; most importantly, if the shop cheated you on refrigerant.
Yup! That's a possibility, been there, chased that problem.


84 XJ6 M1
92 Mustang 5.0 Redline
99 Tahoe 2 door Castrol Edge
99 MX5 Miata Anniversary Edition M1
04 Subaru STi Motul
Re: AC fixed but still not blowing cold air [Re: gallydif] #4506449
09/03/17 05:21 PM
09/03/17 05:21 PM
Joined: Jan 2013
Posts: 1,842
Texas
WyrTwister Offline
WyrTwister  Offline
Joined: Jan 2013
Posts: 1,842
Texas
Good point about the A/C fighting the heater . Put a water valve in the heater hose & shut it off . Does it have a mechanical , vacuum or electronic gizmo to modulate coolant flow to the heater core ?

Last edited by WyrTwister; 09/03/17 05:29 PM.

Wyr
God bless
Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™