Pennzoil - SN Plus and 0W-16 Q&A

Click here to participate in the Pennzoil Q&A

Recent Topics
BMW Coolant Leak Inside Bell Housing
by kschachn
03/18/18 07:59 PM
Health Care Nightmare
by Bluestream
03/18/18 07:58 PM
2.4 Ecotec DI
by mobilaltima
03/18/18 07:57 PM
Prestone may have discontinued Honda PS fluid
by slacktide_bitog
03/18/18 07:45 PM
2002 Lincoln Continental
by Kira
03/18/18 06:31 PM
Driver training!
by Chris142
03/18/18 05:52 PM
Wasabi Paste
by cjcride
03/18/18 05:50 PM
2006 Buick Lacrosse 160k mile review
by TmanP
03/18/18 05:49 PM
Emergency Parking Brake
by mbacfp
03/18/18 05:28 PM
Another "Should I Change it?" - S2000
by climhazzard
03/18/18 04:36 PM
How to get gasket back in the oil cap?
by Jooksing
03/18/18 04:36 PM
Why don't females tell you when something is wrong
by Chris142
03/18/18 04:16 PM
Venison roast
03/18/18 04:00 PM
Consequences of a filter with a lower bypass psi?
by Patman
03/18/18 03:04 PM
Best mini van for hauling work, $5k or less?
by dareo
03/18/18 03:02 PM
Coolant pressure building up with engine OFF?
by Walmill
03/18/18 02:52 PM
yearly insurance renewal-progressive vs auto owner
by volk06
03/18/18 02:33 PM
Mobil rebate for Canadians?
by BigJakeChevy
03/18/18 02:32 PM
Trailer break away stays on charging
by motor_oil_madman
03/18/18 02:16 PM
Fontana - Auto Club Speedway
by Warstud
03/18/18 02:02 PM
Newest Members
rolla2004, Beerstream, JohnnyLi, Caerbannog, Psokeo
64497 Registered Users
Who's Online
120 registered (2004tdigls, aklifter, 2015_PSD, 69Torino, Alex_V, 13 invisible), 1767 Guests and 93 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
64497 Members
68 Forums
280029 Topics
4674120 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4498370 - 08/26/17 06:33 AM Site login
grampi Offline

Registered: 10/08/06
Posts: 7478
Loc: OH
This site is doing that stupid thing again where it won't keep me logged in. I've tried checking the box, and not checking the box, but still, I have to login every time I visit the site. What's going on?

#4498384 - 08/26/17 07:00 AM Re: Site login [Re: grampi]
LoneRanger Offline

Registered: 07/02/07
Posts: 3888
Loc: Midwest USA
I couldn't upload inline photos last night.

'09 Subaru Forester ...................(QSED DEXOS1 5W30)
'16 Moto Guzzi Stelvio 1200 .....(ENI i-Ride PG 10W60)

#4498428 - 08/26/17 08:00 AM Re: Site login [Re: grampi]
Char Baby Offline

Registered: 05/25/05
Posts: 9607
Yeah, it won't keep me logged in either. However, all I do is click on a topic to the left and I am logged in by doing so. If clicking on a topic at in the left column doesn't work, only then will I have to actually login.
'80 Firebird FORMULA V8/4bbl-purchased "NEW"
'06 Mazda 3i 2.0L
'15 Nissan Altima 2.5 SV

#4498683 - 08/26/17 12:59 PM Re: Site login [Re: grampi]
ZeeOSix Offline

Registered: 07/22/10
Posts: 16780
Loc: PNW
Try deleting all the cookies for this site and then log back in with the "keep me logged in" box checked.
We Don't Need No Stinkin' Efficiency!