Recent Topics
Toyota 2TR-FE 2.7 questions
by Doublehaul. 12/12/18 12:32 AM
Anybody used Eurolub?
by FordCapriDriver. 12/12/18 12:18 AM
Micro-Green Cut Open
by David1. 12/11/18 11:45 PM
Witch way does this valve work?
by Dylan1303. 12/11/18 11:42 PM
Santa came early..
by leoblack9. 12/11/18 11:22 PM
dropped a zip tie in my prius trans
by eljefino. 12/11/18 09:54 PM
2 Cello's - Some talented fellows right here.
by StevieC. 12/11/18 09:49 PM
Something different for sure - Punjabi Celtic
by StevieC. 12/11/18 09:40 PM
Honda eu200i hiccuping @ low idle - fixed
by Jmoney7269. 12/11/18 09:34 PM
Your dealer is here - Humor
by StevieC. 12/11/18 08:46 PM
1994 Honda Civic LX Main Relay-solder
by Gito. 12/11/18 08:43 PM
Winter/Summer Fuel Economy
by RayCJ. 12/11/18 08:33 PM
0w20 oils - NOACK
by superangrypenguin. 12/11/18 08:19 PM
Liqui Moly Special Tec AA 5w20 API SN
by Johnny248. 12/11/18 08:15 PM
Buy a brand new 1966-1977 Ford Bronco
by StevieC. 12/11/18 07:50 PM
2012 Accord,QSUD 5W20,WIX 57356 filter,3K miles
by aquariuscsm. 12/11/18 07:05 PM
Check out this awsome work!
by Chris142. 12/11/18 06:47 PM
200,000 miles
by Marco620. 12/11/18 06:29 PM
Newest Members
tcoffin014, Schm1d, EagleC, Dinka, MechanicGuy
66654 Registered Users
Who's Online Now
44 registered members (bullwinkle, 69Torino, alarmguy, 97K15004WD, carviewsonic, 8 invisible), 888 guests, and 36 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics294,964
Posts4,924,977
Members66,654
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
MC FL 820S Issues? #4491543
08/18/17 12:48 AM
08/18/17 12:48 AM
Joined: Dec 2015
Posts: 166
Texas
PumpPusher Offline OP
PumpPusher  Offline OP
Joined: Dec 2015
Posts: 166
Texas
My Crown Vic has a bit of a start up rattle. Not nearly as bad as the first start after an oil change, but very noticeable. When I first got the car, it had a Valvoline filter. After the first change, I went with the 820 and the sound went away. Then it started with the 820 once I passed 8k on my OCI. I change my oil every 10k and each time the noise comes back earlier and earlier. Now it started at 2k. Could it be a filter? I haven't tried an Fram Ultra since I had a stash of 820s.

Re: MC FL 820S Issues? [Re: PumpPusher] #4491557
08/18/17 01:51 AM
08/18/17 01:51 AM
Joined: May 2005
Posts: 10,550
ROCHESTER, NY
Char Baby Online content
Char Baby  Online Content
Joined: May 2005
Posts: 10,550
ROCHESTER, NY
Yeah, try another filter!


"Retired"
-----------------------------------

'80 Firebird FORMULA V8/4bbl-purchased "NEW"
'15 Nissan Altima 2.5 SV
'15 Honda Civic LX
Re: MC FL 820S Issues? [Re: PumpPusher] #4491559
08/18/17 02:10 AM
08/18/17 02:10 AM
Joined: Oct 2014
Posts: 2,538
San Antonio, TX
Nyogtha Offline
Nyogtha  Offline
Joined: Oct 2014
Posts: 2,538
San Antonio, TX
^^^ +1

It doesn't have to be a Fram Ultra, but if you have one handy, why not?

If you want you stay with base end bypass you could try a Mopar MO-899 but note it has a nitrile ADBV.


Last edited by Nyogtha; 08/18/17 02:12 AM.

"No matter how paranoid you are you're not paranoid enough. Tell the truth. Reach as many people as you can with it. That's your weapon." - Susanne Modeski, aka "Holly" to The Lone Gunmen
Re: MC FL 820S Issues? [Re: PumpPusher] #4491575
08/18/17 03:32 AM
08/18/17 03:32 AM
Joined: Dec 2015
Posts: 166
Texas
PumpPusher Offline OP
PumpPusher  Offline OP
Joined: Dec 2015
Posts: 166
Texas
I will, but what are the chances of getting 4 "bad" filters in a row? Could it be something else?

Re: MC FL 820S Issues? [Re: PumpPusher] #4491578
08/18/17 03:48 AM
08/18/17 03:48 AM
Joined: Oct 2014
Posts: 2,538
San Antonio, TX
Nyogtha Offline
Nyogtha  Offline
Joined: Oct 2014
Posts: 2,538
San Antonio, TX
Sure, anything's possible, but trying a different manufacturer's oil filter is an inexpensive way to rule out that component, right?

You indicate it goes away for at least 2K miles after an oil filter change, so what else other than oil is connected to your oil filter changes?

FWIW you can change the oil filter while the noise is present without changing the oil, you can just top off with the same oil to keep that variable constant with trying a new oil filter.

Some oil filters manufactured by Purolator have been exhibiting sharkbit silicone ADBV's here on BITOG.

Last edited by Nyogtha; 08/18/17 03:55 AM.

"No matter how paranoid you are you're not paranoid enough. Tell the truth. Reach as many people as you can with it. That's your weapon." - Susanne Modeski, aka "Holly" to The Lone Gunmen
Re: MC FL 820S Issues? [Re: PumpPusher] #4491592
08/18/17 05:11 AM
08/18/17 05:11 AM
Joined: Oct 2004
Posts: 8,308
Cincinnati, OH, USA
bullwinkle Online confused
bullwinkle  Online Confused
Joined: Oct 2004
Posts: 8,308
Cincinnati, OH, USA
The XG2 fixed my MGM 4.6, after it rattled with a Hastings, and even an Affinia/Wix made CQ Blue. 5W20 Magnatec helped too.


06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)
Re: MC FL 820S Issues? [Re: PumpPusher] #4491594
08/18/17 05:16 AM
08/18/17 05:16 AM
Joined: Oct 2004
Posts: 8,308
Cincinnati, OH, USA
bullwinkle Online confused
bullwinkle  Online Confused
Joined: Oct 2004
Posts: 8,308
Cincinnati, OH, USA
.

Last edited by bullwinkle; 08/18/17 05:17 AM. Reason: double post
Re: MC FL 820S Issues? [Re: PumpPusher] #4491629
08/18/17 06:18 AM
08/18/17 06:18 AM
Joined: Jun 2017
Posts: 220
NY
DdDd Offline
DdDd  Offline
Joined: Jun 2017
Posts: 220
NY
It sounds like by your 8k oci the oil is done in that motor.

Not every oil can last that long and its certainly past the recommended limit for older crown vics. Try another oil or test a sample. Shorter intervals.

Re: MC FL 820S Issues? [Re: PumpPusher] #4491657
08/18/17 06:46 AM
08/18/17 06:46 AM
Joined: Mar 2016
Posts: 1,013
PA,US
HemiHawk Offline
HemiHawk  Offline
Joined: Mar 2016
Posts: 1,013
PA,US
Never had an issue like that with my Mustang (4.6 3v) using nothing but 820s filters. However, my OCIs were usually closer to 3k miles. That has been mostly from my "spirited" driving habits and length of time it takes to get me to those miles.

I will say... I just switched to a Fram Ultra XG2 after all the praises they receive on this site. Did my usual Mobil 1 5w20, and this filter. The thing I noticed is that on a "cold" start (over 70f) the engine RPM sits at a higher state than before. Good/Bad? I have no idea just something I noted. Once it finally does fully warm up I guess it settles back to normal rpm at idle.


2016 Nissan Frontier Pro4x
2017 VW GTI sport
1995 Mustang GTS
Re: MC FL 820S Issues? [Re: PumpPusher] #4491659
08/18/17 06:50 AM
08/18/17 06:50 AM
Joined: Oct 2010
Posts: 1,753
PA
123Saab Offline
123Saab  Offline
Joined: Oct 2010
Posts: 1,753
PA
I have used the 820s for years in our 03 Ranger, and never had a startup noise of any kind. 5k OCI with Formula Shell 5w-30.

As others have stated, you're running it and the oil too long.


Anything can happen
The tallest towers be overturned
Those in high places be daunted
Those overlooked regarded
- Seamus Heaney
Re: MC FL 820S Issues? [Re: PumpPusher] #4491749
08/18/17 08:30 AM
08/18/17 08:30 AM
Joined: Jul 2016
Posts: 682
il usa
merconvvv Offline
merconvvv  Offline
Joined: Jul 2016
Posts: 682
il usa
Nothing but 820 here.

No sounds filter related atleast what i can tell.

You could change to another new 820 filter to see if noise goes away since u have a stash of these filters. Add .25 quarts to .5 quarts of oil as needed. The first start might be noisy but after that
If u still have noise change the oil to see if that makes it go away.
If u still have noise try heavier oil like 10w30 or blend of 5w20 and 10w30 if heavier oil is not your cup of tea.
Is the noise present on cold start after the car has been sitting around or even on hot start ?


1988 Mazda RX7 na PP 10w30 Noack 4.7
1994 Chrysler Concorde 3.3
1999 Ford Expedition 4.6 QSUD 10W30 NOACK 5.0
Re: MC FL 820S Issues? [Re: PumpPusher] #4491783
08/18/17 08:57 AM
08/18/17 08:57 AM
Joined: Jul 2015
Posts: 3,772
MD
AirgunSavant Offline
AirgunSavant  Offline
Joined: Jul 2015
Posts: 3,772
MD
I think the 820's get a bad rap. They make excellent door stops.

Re: MC FL 820S Issues? [Re: PumpPusher] #4491798
08/18/17 09:11 AM
08/18/17 09:11 AM
Joined: Nov 2003
Posts: 3,806
Cape Cod, MA
RF Overlord Offline
RF Overlord  Offline
Joined: Nov 2003
Posts: 3,806
Cape Cod, MA
I've used the FL820S on all of my (and relatives) cars for the past 14 years. 2 Grand Marquis', 2 Marauders, and a Mustang. Never heard a start-up rattle other than the one immediately after an oil change.


Supercharged '03 Mercury Marauder - Trilogy Motorsports #61
PP 5W-30 / MC FL820S

'04 Grand Marquis LS Limited Edition - daily driver

'00 Grand Marquis GS - bad frame/future to be determined
Re: MC FL 820S Issues? [Re: HemiHawk] #4491854
08/18/17 10:35 AM
08/18/17 10:35 AM
Joined: Jul 2010
Posts: 19,263
PNW
ZeeOSix Offline
ZeeOSix  Offline
Joined: Jul 2010
Posts: 19,263
PNW
Originally Posted By: HemiHawk
I just switched to a Fram Ultra XG2 after all the praises they receive on this site. Did my usual Mobil 1 5w20, and this filter. The thing I noticed is that on a "cold" start (over 70f) the engine RPM sits at a higher state than before. Good/Bad? I have no idea just something I noted. Once it finally does fully warm up I guess it settles back to normal rpm at idle.


Idle speed not dependant on what oil or filter is used. Mostly dependant on engine/coolant and ambient temperatures.

Re: MC FL 820S Issues? [Re: PumpPusher] #4491941
08/18/17 12:27 PM
08/18/17 12:27 PM
Joined: Mar 2010
Posts: 505
Chicago Suburbs
Nitronoise Offline
Nitronoise  Offline
Joined: Mar 2010
Posts: 505
Chicago Suburbs
I just serviced my wifes freestyle and 3 weeks later i was out when she left for work and heard a rattle so I am changing out her fl820
other wise I will go to a bosch


07 Ford Freestyle 135K
04 Hyundai Sonata 280K
03 Hyundai Santa Fe 165K
02 Ford Tarus 98K
00 Buick Regal SC 135K
95 Goldwing 28K

Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™