Recent Topics
Heavy Snow Predicted for Northeast Sat/Sun
by Donald. 01/17/19 08:34 PM
Pennzoil Ultra Plat 5w30 1.4L T Chevy Cruze 10k
by SubieBlue. 01/17/19 08:03 PM
Coated rotors
by supton. 01/17/19 07:51 PM
Good samaritan
by JLTD. 01/17/19 07:15 PM
Doing suspension work. Need alignment?
by HawkeyeScott. 01/17/19 05:45 PM
100mg CBD Cannabis Gel
by Al. 01/17/19 05:36 PM
Electric Car "Green Test"
by redbone3. 01/17/19 05:06 PM
Want to try a uoa
by Dylan1303. 01/17/19 04:56 PM
Happy Birthday, Betty White!
by eljefino. 01/17/19 04:20 PM
Fram Ultra for Ecoboost 2.7
by Purpfox. 01/17/19 04:10 PM
Idle Speed / 1998 Olds 88
by Mark72. 01/17/19 03:28 PM
Heat blanket for your oil filter!
by MrWideTires. 01/17/19 03:24 PM
Proper oil viscosities.
by Bullwinkle007. 01/17/19 03:20 PM
44$ for 5 gals of home heating oil treatment!
by Audios. 01/17/19 03:05 PM
Good job Hyundai!!!
by Andy636. 01/17/19 02:43 PM
PP 0W-20 vs PP HM 0W-20 - Difference in VI
by The Critic. 01/17/19 02:34 PM
Newest Members
Dickerson888, Frisky, polarisman340, jfradella, Bigyetti83
66964 Registered Users
Who's Online Now
129 registered members (4WD, 69Torino, AdditiveOCD, 2015_PSD, 2K2AcuraTL, 11 invisible), 1,707 guests, and 48 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics296,749
Posts4,958,204
Members66,964
Most Online2,577
Jan 14th, 2019
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
03 Neon motor mount failure #4487838
08/13/17 07:45 PM
08/13/17 07:45 PM
Joined: Jun 2015
Posts: 726
Canada
Run Offline OP
Run  Offline OP
Joined: Jun 2015
Posts: 726
Canada
I have been noticing more and more vibrations in my car. Driving or stopped it would rattle. I inspected the motor mounts and determined it was time for replacement. I ordered a set from Rockauto and a couple of days after it arrived the lower mount failed completely. It felt awful as if the transmission was smashing through gears. Installed the new ones and what a difference.

Lower mount:



Upper mount:



03 Neon 2.0 - VSP 5W-30 Pentius XL
Re: 03 Neon motor mount failure [Re: Run] #4487856
08/13/17 08:02 PM
08/13/17 08:02 PM
Joined: Jun 2003
Posts: 33,776
ME
eljefino Online content
eljefino  Online Content
Joined: Jun 2003
Posts: 33,776
ME
What brand did you get, Anchor?

Re: 03 Neon motor mount failure [Re: eljefino] #4487876
08/13/17 08:17 PM
08/13/17 08:17 PM
Joined: Jun 2015
Posts: 726
Canada
Run Offline OP
Run  Offline OP
Joined: Jun 2015
Posts: 726
Canada
Originally Posted By: eljefino
What brand did you get, Anchor?

Westar, made in India. Looking forward to see how well they hold up. If I recall correctly they were the cheapest on RA.


03 Neon 2.0 - VSP 5W-30 Pentius XL
Re: 03 Neon motor mount failure [Re: Run] #4487886
08/13/17 08:27 PM
08/13/17 08:27 PM
Joined: Nov 2011
Posts: 4,050
Lima, Ohio, USA
earlyre Online sleepy
earlyre  Online Sleepy
Joined: Nov 2011
Posts: 4,050
Lima, Ohio, USA
well. good luck.
as i former neon owner, i can confirm and attest, that they are Well known "rattlers"

and none of the aftermarket mounts are made like the OE ones.

OE are supposed to be Fluid-filled,while none of the aftermarket are.(at least according to the neon forum i used to frequent..)

and accordingly, none of the aftermarket units are as smooth as the OE units. some have even complained of cabin rattles getting worse after replacing mounts.


Last edited by earlyre; 08/13/17 08:29 PM.

Mine:
09 Mercury Sable : 6qts AutoQuest(Meijer/Warren) 0w20, WIX 51516
Mine to Maintain:
03 Pontiac Vibe : 4.5qts VWB 5w30,WIX 51394
Re: 03 Neon motor mount failure [Re: Run] #4487904
08/13/17 08:40 PM
08/13/17 08:40 PM
Joined: Mar 2004
Posts: 1,533
Flaherty, KY
92saturnsl2 Offline
92saturnsl2  Offline
Joined: Mar 2004
Posts: 1,533
Flaherty, KY
Not a Neon owner, but I've replaced a lot of failed motor mounts, on a lot of vehicles. Nine times out of ten, if you don't use an OEM part, you'll be replacing the same motor mount in short order. I have no idea why, the replacements seem okay, work fine for a bit, but they just don't hold up. I was in a pinch and bought a Westar upper mount for my Honda Odyssey, and it needs replaced in the worst way less than a year later. I had a similar experience with a Saturn I owned, that was an Anchor replacement, after a month replaced it with an OEM mount, and it lasted the remaining life of the car. You really do get what you pay for with these things.

On a side note, I once used hockey pucks with a hole drilled in the middle, as a replacement for the rubber front mount on a 2000 Bonneville (3.8L supercharged engine) at the suggestion of a bunch of forum members, and that was the longest lasting, best performing mount I've ever had. Go figure.


1985 F-250HD 7.5L 4x4 135k- Castrol GTX 15w-40 HDEO
04 Odyssey EX 184k Valv. Durablend 5w-30
96 Maxima GLE 255k Castrol Edge EP 5w-20
07 Chrysler Pacifica Limited 4.0L 134k Chevron Supreme 5w-20
Re: 03 Neon motor mount failure [Re: 92saturnsl2] #4488232
08/14/17 08:55 AM
08/14/17 08:55 AM
Joined: Jun 2003
Posts: 10,574
Illinois
javacontour Offline
javacontour  Offline
Joined: Jun 2003
Posts: 10,574
Illinois
Originally Posted By: 92saturnsl2
Not a Neon owner, but I've replaced a lot of failed motor mounts, on a lot of vehicles. Nine times out of ten, if you don't use an OEM part, you'll be replacing the same motor mount in short order. I have no idea why, the replacements seem okay, work fine for a bit, but they just don't hold up. I was in a pinch and bought a Westar upper mount for my Honda Odyssey, and it needs replaced in the worst way less than a year later. I had a similar experience with a Saturn I owned, that was an Anchor replacement, after a month replaced it with an OEM mount, and it lasted the remaining life of the car. You really do get what you pay for with these things.

On a side note, I once used hockey pucks with a hole drilled in the middle, as a replacement for the rubber front mount on a 2000 Bonneville (3.8L supercharged engine) at the suggestion of a bunch of forum members, and that was the longest lasting, best performing mount I've ever had. Go figure.


I have used 3m Window Weld to fix the upper mount on my Mazda Protege5.

I took the mount off, covered one side with cardboard to prevent the urethane from leaking out and filled it from the other side. I let it set over a 3 day weekend while I was out of town.

More vibration conveyed to the passenger compartment. But for $20 vs over $100 for a new mount, I'm ok with that.


network down, IP packets delivered via UPS -BOFH
Re: 03 Neon motor mount failure [Re: Run] #4488241
08/14/17 09:06 AM
08/14/17 09:06 AM
Joined: Sep 2008
Posts: 9,236
Ontario, Canada
IndyIan Offline
IndyIan  Offline
Joined: Sep 2008
Posts: 9,236
Ontario, Canada
I don't think that style mount is ever fluid filled. That one just handles twisting of the drivetrain, the fluid filled ones usually handle holding up the drivetrain.
If that one fails, you probably can get a solid poly torque mount which increases vibes at idle and WO but usually settles in to nearly OE quietness for cruising. It was a good mod for even my auto 95 Neon for autocross, and I also have one in my Focus, but I have nearly 0 stop lights in my normal driving, let alone stop and go traffic.


07 Focus ZXW, 5spd manual, 218km M1 5W30
18 Outback 2.5 CVT 15km 0W20

BOB IS THE OIL GUY® Powered by UBB.threads™