Recent Topics
Toyota's Insistence on using ATF in power steering
by alcyon
04/27/18 01:04 AM
200 Mobil Gas Stations coming to Canada
by Snagglefoot
04/26/18 10:13 PM
Brake Pads 2003 Jetta 1.8
by maxdustington
04/26/18 09:56 PM
Any low cal high mag high zinc 5w40's out there?
by Roland1
04/26/18 09:17 PM
straight-weight 20 oil
by OilUzer
04/26/18 08:38 PM
supertech 15W40 5.3 Chevy
by mobilaltima
04/26/18 08:38 PM
Tokyo Roki 15208AA130 - 4708km
by VolkswagenFox21
04/26/18 08:37 PM
Shell Helix Ultra 0W40, 3070Km, Fiat Barchetta
by Popsy
04/26/18 07:39 PM
Marijuana on the left coast
by Snagglefoot
04/26/18 07:24 PM
Ubuntu 18.04 LTS and derivatives are out!
by uc50ic4more
04/26/18 07:21 PM
Cooper CS5'
by gabriel9766
04/26/18 07:07 PM
Zero Turn Front Tires
by AirgunSavant
04/26/18 06:50 PM
$1,000 in rewards/cash back from Chase Bank
by 04SE
04/26/18 06:15 PM
My Life with a Nurse:
by MolaKule
04/26/18 04:32 PM
No start string trimmer
by Whimsey
04/26/18 04:08 PM
HOME REMEDIES Zinc Oxide Folk Remedy- funny
by CourierDriver
04/26/18 01:39 PM
Additive Chemistry Components III
by MolaKule
04/26/18 12:33 PM
Explosion at refinery in Superior, WI.
by john_pifer
04/26/18 12:08 PM
F1 - 2018 Azerbaijan Grand Prix
by gofast182
04/26/18 11:56 AM
Best LL-01 Oil Right Now?
by RIPGermanCastrol
04/26/18 11:43 AM
Newest Members
Rafaelon, kylek162, Budd33, Jekyll, Superfede
64860 Registered Users
Who's Online
22 registered (edyvw, ctechbob, alcyon, E365, GMguy84, Hemispheres, 2 invisible), 939 Guests and 66 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
64860 Members
68 Forums
282415 Topics
4715132 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4487838 - 08/13/17 08:45 PM 03 Neon motor mount failure
Run Offline


Registered: 06/07/15
Posts: 706
Loc: Canada
I have been noticing more and more vibrations in my car. Driving or stopped it would rattle. I inspected the motor mounts and determined it was time for replacement. I ordered a set from Rockauto and a couple of days after it arrived the lower mount failed completely. It felt awful as if the transmission was smashing through gears. Installed the new ones and what a difference.

Lower mount:



Upper mount:

_________________________
03 Neon 2.0 - VSP 5W-30 Pentius XL

Top
#4487856 - 08/13/17 09:02 PM Re: 03 Neon motor mount failure [Re: Run]
eljefino Offline


Registered: 06/15/03
Posts: 32391
Loc: ME
What brand did you get, Anchor?

Top
#4487876 - 08/13/17 09:17 PM Re: 03 Neon motor mount failure [Re: eljefino]
Run Offline


Registered: 06/07/15
Posts: 706
Loc: Canada
Originally Posted By: eljefino
What brand did you get, Anchor?

Westar, made in India. Looking forward to see how well they hold up. If I recall correctly they were the cheapest on RA.
_________________________
03 Neon 2.0 - VSP 5W-30 Pentius XL

Top
#4487886 - 08/13/17 09:27 PM Re: 03 Neon motor mount failure [Re: Run]
earlyre Offline


Registered: 11/22/11
Posts: 3811
Loc: Lima, Ohio, USA
well. good luck.
as i former neon owner, i can confirm and attest, that they are Well known "rattlers"

and none of the aftermarket mounts are made like the OE ones.

OE are supposed to be Fluid-filled,while none of the aftermarket are.(at least according to the neon forum i used to frequent..)

and accordingly, none of the aftermarket units are as smooth as the OE units. some have even complained of cabin rattles getting worse after replacing mounts.



Edited by earlyre (08/13/17 09:29 PM)
_________________________
Mine:
09 Mercury Sable : 6qts AutoQuest(Meijer/Warren) 0w20, WIX 51516
Mine to Maintain:
03 Pontiac Vibe : 4.5qts VWB 5w30,WIX 51394

Top
#4487904 - 08/13/17 09:40 PM Re: 03 Neon motor mount failure [Re: Run]
92saturnsl2 Offline


Registered: 03/02/04
Posts: 1221
Loc: Flaherty, KY
Not a Neon owner, but I've replaced a lot of failed motor mounts, on a lot of vehicles. Nine times out of ten, if you don't use an OEM part, you'll be replacing the same motor mount in short order. I have no idea why, the replacements seem okay, work fine for a bit, but they just don't hold up. I was in a pinch and bought a Westar upper mount for my Honda Odyssey, and it needs replaced in the worst way less than a year later. I had a similar experience with a Saturn I owned, that was an Anchor replacement, after a month replaced it with an OEM mount, and it lasted the remaining life of the car. You really do get what you pay for with these things.

On a side note, I once used hockey pucks with a hole drilled in the middle, as a replacement for the rubber front mount on a 2000 Bonneville (3.8L supercharged engine) at the suggestion of a bunch of forum members, and that was the longest lasting, best performing mount I've ever had. Go figure.
_________________________
1985 F-250HD 7.5L 4x4 135k- Maxlife 15w-40 HDEO
04 Odyssey EX 175k PUP 5w-40
96 Maxima GLE 235k PUP 0w-40
02 Mazda Tribute 185k - Citgo 5w-30 conv.

Top
#4488232 - 08/14/17 09:55 AM Re: 03 Neon motor mount failure [Re: 92saturnsl2]
javacontour Offline


Registered: 06/26/03
Posts: 10249
Loc: Illinois
Originally Posted By: 92saturnsl2
Not a Neon owner, but I've replaced a lot of failed motor mounts, on a lot of vehicles. Nine times out of ten, if you don't use an OEM part, you'll be replacing the same motor mount in short order. I have no idea why, the replacements seem okay, work fine for a bit, but they just don't hold up. I was in a pinch and bought a Westar upper mount for my Honda Odyssey, and it needs replaced in the worst way less than a year later. I had a similar experience with a Saturn I owned, that was an Anchor replacement, after a month replaced it with an OEM mount, and it lasted the remaining life of the car. You really do get what you pay for with these things.

On a side note, I once used hockey pucks with a hole drilled in the middle, as a replacement for the rubber front mount on a 2000 Bonneville (3.8L supercharged engine) at the suggestion of a bunch of forum members, and that was the longest lasting, best performing mount I've ever had. Go figure.


I have used 3m Window Weld to fix the upper mount on my Mazda Protege5.

I took the mount off, covered one side with cardboard to prevent the urethane from leaking out and filled it from the other side. I let it set over a 3 day weekend while I was out of town.

More vibration conveyed to the passenger compartment. But for $20 vs over $100 for a new mount, I'm ok with that.
_________________________
network down, IP packets delivered via UPS -BOFH

Top
#4488241 - 08/14/17 10:06 AM Re: 03 Neon motor mount failure [Re: Run]
IndyIan Offline


Registered: 09/23/08
Posts: 8924
Loc: Ontario, Canada
I don't think that style mount is ever fluid filled. That one just handles twisting of the drivetrain, the fluid filled ones usually handle holding up the drivetrain.
If that one fails, you probably can get a solid poly torque mount which increases vibes at idle and WO but usually settles in to nearly OE quietness for cruising. It was a good mod for even my auto 95 Neon for autocross, and I also have one in my Focus, but I have nearly 0 stop lights in my normal driving, let alone stop and go traffic.
_________________________
07 Focus ZXW, 5spd manual, 201km M1 5W30
18 Outback 2.5 CVT 2km FF

Top