Recent Topics
"New" Beater
by SilverGt. 09/22/18 07:22 PM
Eschewing computer controls
by buck91. 09/22/18 06:41 PM
Leak/drip left front 13 Ram 4x4?
by irv. 09/22/18 06:22 PM
5w20 oil choices
by 53' Stude. 09/22/18 06:05 PM
site security
by RF Overlord. 09/22/18 06:02 PM
Richmond Raceway
by Warstud. 09/22/18 06:01 PM
Redline D6 ATF substituting for Toyota WS
by Patrick0525. 09/22/18 05:29 PM
XG3614 Cut Open 13,400kms (8,375mi)
by mcwilly. 09/22/18 05:25 PM
Torn Purolators: they DO TEAR!
by 53' Stude. 09/22/18 05:07 PM
transmission fluid and filter exchange
by Dennisistheman. 09/22/18 04:53 PM
Why people should change oil+filter!
by 53' Stude. 09/22/18 04:50 PM
Household lubricants (general purpose) differences
by 92saturnsl2. 09/22/18 04:35 PM
debris in my engine oil--what to do?
by Jasper8146. 09/22/18 03:50 PM
Is this seal bad?
by parshisa. 09/22/18 03:44 PM
Leather Masters Protection Cream review....
by gregk24. 09/22/18 03:13 PM
Aisin WS
by RodneyM. 09/22/18 03:11 PM
Husqvarna trimmer questions
by BrianF. 09/22/18 02:51 PM
Uber Self-Driv Death: Disabled Pedest Avoidance!!!!
by oil_film_movies. 09/22/18 02:29 PM
Question on Backlight setting on LED tv's
by LoneRanger. 09/22/18 02:16 PM
Newest Members
Sarrge, Big_R, gordond, mrgreggn, JRMFt11
66040 Registered Users
Who's Online Now
81 registered members (Al, 53' Stude, 55hambone, 87sammy, 928, 9 invisible), 1,593 guests, and 42 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,845
Posts4,851,365
Members66,040
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
1999 s10 4.3 miss/lack of power on highway #4475249
07/31/17 07:05 AM
07/31/17 07:05 AM
Joined: Nov 2009
Posts: 1,057
Warner Robins, GA
nwjones18 Offline OP
nwjones18  Offline OP
Joined: Nov 2009
Posts: 1,057
Warner Robins, GA
I just got a 1999 s10 4.3 automatic that only has 51k miles on it. When I got it the intake manifold gaskets were leaking and I'm just now getting it back on the road. The truck seems to run perfect, idles smooth and has plenty of power if you get on it, but when you are cruising in OD at 55-65 mph and come to a slight hill it just feels like it has no power and seems hesitant to downshift unless you floor it. No codes set. I honestly can't tell if its some sort of misfire, or maybe a torque converter shuddering I just know there is a lack of power and some very light vibration. Truck doesn't have a tac so its sort of hard to tell what its doing. Plugs/wires appear to be original and I assume the atf is as well, although it looks very good on the dipstick. Any thoughts?


1988 F-150. 4.9 I6 247k. 10w-40 Castrol Syn-blend ACDelco UPF2.
2005 Cadillac STS N* 108k. 5w-30 Castrol Magnatec ACDelco Classic PF61
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475254
07/31/17 07:14 AM
07/31/17 07:14 AM
Joined: Aug 2010
Posts: 5,675
WatUpDoc
ltslimjim Offline
ltslimjim  Offline
Joined: Aug 2010
Posts: 5,675
WatUpDoc
Plugged fuel filter or degraded components since 1999('98 year technically?)?

I'd start with age related/seldom driven type of problem areas for this engine and see if someone can comment on other known performance problems for this app. I believe this one has a MAF in the intake.

It could also use a good Italian tuneup at the very least after verifying fuel filter isn't the original but if say the plugs/wires are original then I doubt it has been replaced... (AC Delco has a professional series filter made in USA sold on Amazon or RockAuto)

drive

Do seldom driven cars develop combustion chamber/piston head related issues that can cause these performance symptoms? Might it be worth running a bottle of Red Line then a bottle of Berryman's B12 for the newer 1,2 punch approach before swapping fuel filters as relatively cheap additions through the gas tank? Has there since been a superseding ATF from what the factory fill would have been for the transmission side of things?

Not driven enough...but hopefully enough oil changes before now.

Last edited by ltslimjim; 07/31/17 07:20 AM.

92 Civic Hatch (stolen frown RIP)
07 Honda Fit Sport (A/T) WELCOME thumbsup
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475265
07/31/17 07:37 AM
07/31/17 07:37 AM
Joined: Jan 2011
Posts: 2,718
N.Ohio
Lubener Offline
Lubener  Offline
Joined: Jan 2011
Posts: 2,718
N.Ohio
Fuel filter if it hasn't been changed recently. Plugs could have been affected by coolant and the leaking intake gaskets.


The "thinking" man's friend.
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475271
07/31/17 07:45 AM
07/31/17 07:45 AM
Joined: Jun 2003
Posts: 17,355
Deplorable in apple valley, ca
Chris142 Offline
Chris142  Offline
Joined: Jun 2003
Posts: 17,355
Deplorable in apple valley, ca
Definatly change the plugs, wires cap and rotor...have fun with the front plug on the driver side smile


02 Wrangler durablend 10w40
87 F250 traveler 15w40
04 Tahoe super-s 10w30
Z400 castrol T 10w40
Can am maveric edge 5w40
57 case tractor 15w40
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475276
07/31/17 07:52 AM
07/31/17 07:52 AM
Joined: Nov 2006
Posts: 19,920
MA, Mittelfranken.de
Trav Offline
Trav  Offline
Joined: Nov 2006
Posts: 19,920
MA, Mittelfranken.de
After plugs, wires, cap, rotor, filters, etc check for a clogged cat.


ASE L1, Master. Deutsch Meisterbrief.
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475286
07/31/17 08:06 AM
07/31/17 08:06 AM
Joined: Nov 2009
Posts: 1,057
Warner Robins, GA
nwjones18 Offline OP
nwjones18  Offline OP
Joined: Nov 2009
Posts: 1,057
Warner Robins, GA
Thanks everyone I'll start with the fuel filter and then work down the list. I did change the cap/rotor while I had the distributor out for the intake. The truck did have a code set for the cat P0420, and I just put one of those 02 sensor spacers on there and it hasn't come back. But I guess it could be clogged. hard to believe with only 50k on it though. Will report back after fuel filter replacement.


1988 F-150. 4.9 I6 247k. 10w-40 Castrol Syn-blend ACDelco UPF2.
2005 Cadillac STS N* 108k. 5w-30 Castrol Magnatec ACDelco Classic PF61
Re: 1999 s10 4.3 miss/lack of power on highway [Re: Chris142] #4475348
07/31/17 09:09 AM
07/31/17 09:09 AM
Joined: Mar 2012
Posts: 804
BerksCounty/Pa.
thorromig Offline
thorromig  Offline
Joined: Mar 2012
Posts: 804
BerksCounty/Pa.
Easiest way to address that front plug on the drivers side -- just take the front tire off and access it from the bottom. Had a 96 Blazer 4.3L and learned the hard way!!! Like mentioned earlier -- new plugs/wires/cap & rotor. Would not hurt to run acouple back to back runs of Techron Fuel System cleaner or some other "quality" fuel system cleaner also.


00 Dodge Ram 5.2L 4x4 Edge 10W30 FU (91K)
08 Acura TL Type S 3.5L PUPP 5W20 FU (101K)
17 Jetta TSI SE 1.4L Turbo - Edge 0W40 FU (Hers) (4K)
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475351
07/31/17 09:10 AM
07/31/17 09:10 AM
Joined: Mar 2012
Posts: 804
BerksCounty/Pa.
thorromig Offline
thorromig  Offline
Joined: Mar 2012
Posts: 804
BerksCounty/Pa.
After market 02 sensors are junk. My opinion -- OEM 02 sensors are the only way to go.


00 Dodge Ram 5.2L 4x4 Edge 10W30 FU (91K)
08 Acura TL Type S 3.5L PUPP 5W20 FU (101K)
17 Jetta TSI SE 1.4L Turbo - Edge 0W40 FU (Hers) (4K)
Re: 1999 s10 4.3 miss/lack of power on highway [Re: Trav] #4475386
07/31/17 09:46 AM
07/31/17 09:46 AM
Joined: Jan 2003
Posts: 1,016
Elizabeth. Colorado
c502cid Offline
c502cid  Offline
Joined: Jan 2003
Posts: 1,016
Elizabeth. Colorado
Originally Posted By: Trav
After plugs, wires, cap, rotor, filters, etc check for a clogged cat.


^^^this^^^


17 SuperDuty 6.2 4x4
15 Chev Trax AWD
02 GMC 3500 8.1/Allison 4x4
00 Blazer 4x4
97/98 Civic's
84 Chev K30 454EFI 4x4
71 GMC Jimmy 502 RamJet
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475412
07/31/17 10:11 AM
07/31/17 10:11 AM
Joined: Dec 2013
Posts: 2,088
socal
barkingspider Offline
barkingspider  Offline
Joined: Dec 2013
Posts: 2,088
socal
New plugs, wires, dis cap, fuel filter, motor oil/filter, trans fluid/filter, PS fluid, diff fluid, brake fluid, air & cabin filter, coolant / stat, valve cover gaskets, serp & acc drive belts, grease all zerks, clean throttle body and MAF if applicable, should be good to go. Oh, check tires and brakes. The truck should take you to 200k


06 Cadillac Escalade Ext
17 Cadillac ATS (wife)
05 Toyota Camry (daughter)
11 GMC Canyon off-road (daily)
Re: 1999 s10 4.3 miss/lack of power on highway [Re: c502cid] #4475416
07/31/17 10:13 AM
07/31/17 10:13 AM
Joined: Apr 2012
Posts: 3,159
Boston, MA
Bgallagher Offline
Bgallagher  Offline
Joined: Apr 2012
Posts: 3,159
Boston, MA
Originally Posted By: c502cid
Originally Posted By: Trav
After plugs, wires, cap, rotor, filters, etc check for a clogged cat.


^^^this^^^


+1


2017 Chevy Traverse - 28k - Delco Dexos 1 and PF63
2014 Chevy Equinox - 22k - Delco Dexos 1 and PF457G
2015 GMC Terrain - 22k- Delco Dexos 1 and PF457G
Re: 1999 s10 4.3 miss/lack of power on highway [Re: Bgallagher] #4475426
07/31/17 10:19 AM
07/31/17 10:19 AM
Joined: Sep 2009
Posts: 557
near Chicago
Carbon Offline
Carbon  Offline
Joined: Sep 2009
Posts: 557
near Chicago
On many vehicles, the air filter is easier to change than the fuel filter. The fuel filter in the gas tank is the hardest.

On the highway, if the problem is the fuel filter, downshifting would usually make the problem worse. When the downshift does occur under those conditions, does that make you accelerate more or lug down more?

Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475447
07/31/17 11:01 AM
07/31/17 11:01 AM
Joined: Jan 2016
Posts: 802
NC
Vladiator Offline
Vladiator  Offline
Joined: Jan 2016
Posts: 802
NC
1) Add a bottle of fuel system cleaner (Redline is my favorite), run that tank of gas with the cleaner. Then change the fuel filter and run another bottle of fuel system cleaner.
2) Ignition components as listed above by other posters.
3) Tranny flush. Usually $120ish at the stealership.

If symptoms are still there - I'd consider replacing a fuel pump. Shop I used to work at had an Astro Van with the 4.3L. Over 130k miles the fuel pump had to be replaced 5 times... I met a few more guys with frequent fuel pump failures on those 4.3 GMs. But definitely get a second opinion first from a reputable mechanic before yous start throwing parts at it.


2000 Lexus GS300-361k
1999 Lexus GS400-213k
2006 Toyota Camry-187k
2006 Toyota Highlander Hybrid-125k
2009 Scion xB-120k
2013 VW Tiguan-120k
2009 Toyota Tacoma-60k
Re: 1999 s10 4.3 miss/lack of power on highway [Re: Trav] #4475511
07/31/17 12:08 PM
07/31/17 12:08 PM
Joined: Feb 2013
Posts: 10,703
Phoenix, AZ
Nick1994 Offline
Nick1994  Offline
Joined: Feb 2013
Posts: 10,703
Phoenix, AZ
Originally Posted By: Trav
After plugs, wires, cap, rotor, filters, etc check for a clogged cat.
Yup, clogged or broken cat.


2015 Hyundai Sonata 2.4L 84k Mobil 1 AFE 0w30 & OEM
2000 Toyota Camry 2.2L 230k Valvoline 5w30 & Fram Ultra
1996 Jeep Cherokee 4.0L 147k Mobil 1 HM 10w40 & Fram Ultra
Re: 1999 s10 4.3 miss/lack of power on highway [Re: nwjones18] #4475667
07/31/17 02:31 PM
07/31/17 02:31 PM
Joined: Aug 2009
Posts: 3,900
Pittsburgh,PA U.S.A.
JimPghPA Offline
JimPghPA  Offline
Joined: Aug 2009
Posts: 3,900
Pittsburgh,PA U.S.A.
Along with all of the things already mentioned which it very well could be, it also could be an ignition coil going bad.


Boy will I be happy when ALL vehicles on public roads are autonomous.


JimPghPa

Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™