Recent Topics
Is there a new (2018) list of GM Dexron VI licensees?
by garageman402. 09/26/18 01:20 AM
Thoughts on new AMAZON branded oil...?
by PantherFan88. 09/25/18 10:47 PM
Clutch kit?
by andrewp1998. 09/25/18 10:34 PM
Galaxy S8+ weird app when clearing storage
by KrisZ. 09/25/18 10:18 PM
Brake bleeder - cfm ?
by hallstevenson. 09/25/18 09:43 PM
18' Corolla vs 18' Elantra
by wolf_06. 09/25/18 09:41 PM
Using Tc-w3 bad for my car?
by Floydian. 09/25/18 09:25 PM
I'm going to start using type F in my gm autos
by turtlevette. 09/25/18 09:17 PM
Cleaning deceased MIL condo and found $15K cash
by Mr Nice. 09/25/18 09:12 PM
Gluten
by StevieC. 09/25/18 07:55 PM
Amazon Prime delivering inside your house
by StevieC. 09/25/18 07:49 PM
2018 MB C300 M1 0W-40 3,475 Miles
by 2015_PSD. 09/25/18 06:44 PM
02-05 Silverado frame rot
by Oildudeny. 09/25/18 06:38 PM
Aftermarket Back Up Camera
by lancerplayer. 09/25/18 06:20 PM
Service champ filter CUT OPEN
by 53' Stude. 09/25/18 05:05 PM
Pressure washer pump life just 23 hours?
by HawkeyeScott. 09/25/18 05:01 PM
STP S 10590 CUT OPEN
by 53' Stude. 09/25/18 05:00 PM
2003 BMW M5-Unknown oil 2500 mi
by Audios. 09/25/18 04:54 PM
Newest Members
Pat_Roberts, Peppz, Jfa02, ibsfusion, Fearcat707
66070 Registered Users
Who's Online Now
34 registered members (ArrestMeRedZ, bbhero, CharlieBauer, 2015Corolla, carlprop, 5 invisible), 559 guests, and 37 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics291,026
Posts4,854,658
Members66,070
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Acid filter fail #4443145
06/27/17 08:14 PM
06/27/17 08:14 PM
Joined: Dec 2004
Posts: 115
Beaverton, OR USA
T-Bone Offline OP
T-Bone  Offline OP
Joined: Dec 2004
Posts: 115
Beaverton, OR USA
I had some pleated acid filters fail over the weekend.




This is what happens when you put a polypropylene filter in a chemical (hydrochloric acid at 60 C) that should have had a PTFE filter. The polypropylene was crumbling, the filter o-rings and end cap blew off entirely. The pleated media was totally destroyed. Fun!

Re: Acid filter fail [Re: T-Bone] #4443231
06/27/17 09:46 PM
06/27/17 09:46 PM
Joined: Oct 2014
Posts: 11,864
Idaho
CT8 Offline
CT8  Offline
Joined: Oct 2014
Posts: 11,864
Idaho
What were the filters used for? Lab? MFG ?


2015 Ford F150 2.7
2018 Ford F350 6.2
Re: Acid filter fail [Re: T-Bone] #4443361
06/28/17 01:05 AM
06/28/17 01:05 AM
Joined: Dec 2004
Posts: 115
Beaverton, OR USA
T-Bone Offline OP
T-Bone  Offline OP
Joined: Dec 2004
Posts: 115
Beaverton, OR USA
These are from an acid cleaning manufacturing machine where I work.

Re: Acid filter fail [Re: T-Bone] #4443498
06/28/17 07:45 AM
06/28/17 07:45 AM
Joined: Aug 2010
Posts: 5,693
Champlain/Hudson Valley
Kira Offline
Kira  Offline
Joined: Aug 2010
Posts: 5,693
Champlain/Hudson Valley
Was there a spill? Don't worry, I won't tell.

Re: Acid filter fail [Re: T-Bone] #4443506
06/28/17 07:54 AM
06/28/17 07:54 AM
Joined: Jan 2004
Posts: 5,927
northern Alabama
benjamming Offline
benjamming  Offline
Joined: Jan 2004
Posts: 5,927
northern Alabama
What % HCl?

Re: Acid filter fail [Re: benjamming] #4443536
06/28/17 08:26 AM
06/28/17 08:26 AM
Joined: Oct 2010
Posts: 4,922
Midwest
volk06 Offline
volk06  Offline
Joined: Oct 2010
Posts: 4,922
Midwest
Originally Posted By: benjamming
What % HCl?


I would venture a guess of 35-37%.


2011 F-150 Ecoboost
2012 Focus S
2001 Taurus
Re: Acid filter fail [Re: T-Bone] #4444320
06/28/17 09:03 PM
06/28/17 09:03 PM
Joined: Dec 2004
Posts: 115
Beaverton, OR USA
T-Bone Offline OP
T-Bone  Offline OP
Joined: Dec 2004
Posts: 115
Beaverton, OR USA
Yep, hydrochloric acid of about 8% concentration at 60 C recirculating through that filter. Normally an all-PTFE filter is used, but a polypropylene one was mistakenly installed.


BOB IS THE OIL GUY® Powered by UBB.threads™