Recent Topics
Who runs a 20wt here?
by StevieC. 09/21/18 07:31 PM
Need help on edit profile
by jetmech1. 09/21/18 06:34 PM
Oil thickness on the dipstick
by Idlewild294. 09/21/18 05:40 PM
Chinese WIX Trans filter bad, let me down..
by jetmech1. 09/21/18 04:47 PM
Gen 8 Accord rear brakes-What tool?
by fdcg27. 09/21/18 04:30 PM
Ammeters?
by buck91. 09/21/18 03:55 PM
Need Help with Double D Knockers
by user52165. 09/21/18 03:41 PM
Opinion needed....
by Duffyjr. 09/21/18 02:56 PM
2017 nissan sentra
by jahwarrior1423. 09/21/18 02:47 PM
I Need A Safe Space- lol
by Zee09. 09/21/18 02:29 PM
Liqui Moly
by dawgn86. 09/21/18 02:10 PM
Valve issues
by kawie_guy. 09/21/18 01:54 PM
2018 Elantra SE
by wolf_06. 09/21/18 01:36 PM
Nasty looking oil filter
by atikovi. 09/21/18 12:43 PM
Laughing hard.
by StevieC. 09/21/18 12:26 PM
Apologies
by Drew99GT. 09/21/18 12:15 PM
Would Like the Manual Transmission to Make a Comeback?
by Speak2Mountain. 09/21/18 11:39 AM
Newest Members
JRMFt11, Navyretired, aikwae, ScottRousell, Direct_Rejection
66036 Registered Users
Who's Online Now
102 registered members (4WD, A310, 10WSmuckers, 2004tdigls, 08z06, 14 invisible), 1,613 guests, and 44 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,790
Posts4,850,407
Members66,036
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Honda 15400-PLM-A01 5k miles C&P #4441469
06/25/17 08:54 PM
06/25/17 08:54 PM
Joined: Nov 2011
Posts: 85
Luling, LA
asleepz Offline OP
asleepz  Offline OP
Joined: Nov 2011
Posts: 85
Luling, LA
Filter has right at 5k miles, came off our 09 Pilot, 75% City - 25% Hwy. Right at 6 months of use time.

This is the previous generation filter by Filtech however I never seem to have an issue buying them on Amazon.

This is my first filter cut, I murdered the filter media trying to open it the glue held it in its shape very well one fiber end cap came off with a decent amount of force with no tools. The other end cap had to be ripped off with pliers.











Last edited by asleepz; 06/25/17 09:07 PM.

14F350 6.7L 86K MC15w-40/Donaldson
09Pilot 3.5L 83K PP5w-30/OEM
07Elite 80 2675mi HGMO10w-40/ScreenDoor
92Accord 2.2L 132K PP5w-30/OEM
Re: Honda 15400-PLM-A01 5k miles C&P [Re: asleepz] #4441526
06/25/17 09:39 PM
06/25/17 09:39 PM
Joined: Feb 2007
Posts: 8,177
Grand Rapids, MI
ThirdeYe Offline
ThirdeYe  Offline
Joined: Feb 2007
Posts: 8,177
Grand Rapids, MI
Looks good. I've used and cut open a number of these filters on my old Integra. They've always worked and looked just fine. I'd happily use them again if I had to. I stopped using them because of the low efficiency numbers and I prefer to use mostly Fram or Wix now.


07 Honda Accord - 606k - Havoline High Mileage 5W-20/Purolator Synthetic PSL14610
98 Camaro Z28 - 120k - QS Defy 5w30/AC Delco PF46
Re: Honda 15400-PLM-A01 5k miles C&P [Re: asleepz] #4441537
06/25/17 09:55 PM
06/25/17 09:55 PM
Joined: Aug 2004
Posts: 4,636
Katy, Republic of Texas
blupupher Offline
blupupher  Offline
Joined: Aug 2004
Posts: 4,636
Katy, Republic of Texas
Still looks weird seeing a filter with the ends of the filter media being bare. I know it works right, but just looks odd.


1994 Honda VT1100: Peak 15w-40/PSL/2500 mile OCI
2002 Ford F150: GTX HM 5w-20/EcoGard Syn/1yr OCI
2012 Scion xB: QSUD 0w-20/CQ Blue/5k OCI

Re: Honda 15400-PLM-A01 5k miles C&P [Re: asleepz] #4441547
06/25/17 10:10 PM
06/25/17 10:10 PM
Joined: Mar 2012
Posts: 1,277
San Antonio, TX
E150GT Offline
E150GT  Offline
Joined: Mar 2012
Posts: 1,277
San Antonio, TX
looks just like the denso filter I cut today from my wife's Yaris.


1984 Mercedes-Benz 300SD - 100k
1995 F150 XL 4.9 reg cab 5MT - 251k 5w30
2016 Mazda6 Touring 6MT - 57k 10w30
2006 Buick Lucerne CXL 3.8 31k 5w30

BOB IS THE OIL GUY® Powered by UBB.threads™