Recent Topics
Amateur Paint Questions
by The Critic - 11/18/19 04:15 AM
What the..
by Mad_Hatter - 11/18/19 03:53 AM
Neighborhood Etiquette
by The Critic - 11/18/19 03:41 AM
AME 37330 Hub Cleaner for Impact Wrench
by The Critic - 11/18/19 01:54 AM
Plastic bag vs Car
by The Critic - 11/18/19 01:50 AM
Fram XG7317 20k miles cut open
by dbeau - 11/17/19 09:46 PM
2021 Ford Mach-E Electric SUV
by KeithS_NW_Ohio - 11/17/19 09:05 PM
Walker mower Oil
by Joey737 - 11/17/19 09:03 PM
Rough service tough light bulb 1ยข at Home Depot
by JLawrence08648 - 11/17/19 08:40 PM
2015 F150 5.0; 10w-30/5w-40 mix 8.6k miles
by Buzzinhalfdozen - 11/17/19 08:36 PM
MOPAR MO-285 FACTORY OIL FILTER CUT OPEN
by 53' Stude - 11/17/19 07:43 PM
Best Garage Door Seals
by Gebo - 11/17/19 07:18 PM
Bar oil as fogging oil
by WA1DH - 11/17/19 06:47 PM
Fram PH2 ExtraGuard Cut Open
by A310 - 11/17/19 06:38 PM
C&P Pentius UFXL PH16-equiv.
by 92saturnsl2 - 11/17/19 06:18 PM
Fleetguard WF2074 Coolant Filter Cut Open
by Pyrotechnic - 11/17/19 05:24 PM
Cuts on tire sidewall
by mclasser - 11/17/19 03:19 PM
Hyundai Theta II Engine in Newer Years
by smc733 - 11/17/19 02:41 PM
Walmart deals
by Deere John - 11/17/19 02:33 PM
Newest Members
JimBobSeeker, Joey737, bdavis218, XTR74, 2009Caraman
69899 Registered Users
Who's Online Now
41 registered members (Amkeer, 65convertible, AurionX2, bbhero, AZjeff, A_A_G, 7 invisible), 794 guests, and 17 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics297,573
Posts5,118,276
Members69,899
Most Online3,589
Nov 2nd, 2019
Donate to BITOG
Print Thread
Hop To
DTC code: U0101 - "lost communication with TCM" #4238525 10/31/16 09:04 PM
Joined: May 2016
Posts: 725
I
i_hate_autofraud Offline OP
OP Offline
I
Joined: May 2016
Posts: 725
Hi all,

I got a GM 4T65E transmission in a '09 Impala with a 3.5L V6.

Just did a OBDII scan for tranny codes since 4T65Es have an awful history.

It comes up U0101 "lost communication with TCM " this means I can't see what's happening in the tranny.

This could mean wiring / connector problems between modules stashed in the intake air plenum.

However, just yanking cables out without a "heads up" could make it worse.

Anyone worked on this problem before?

Thanks!!

Re: DTC code: U0101 - "lost communication with TCM" [Re: i_hate_autofraud] #4238532 10/31/16 09:24 PM
Joined: Nov 2015
Posts: 1,462
K
KingCake Offline
Offline
K
Joined: Nov 2015
Posts: 1,462
Sounds like a can bus problem, it being an 09 and all. First rule of no comm, check all power and grounds. You must load them with a test light. DVM not good enough. Then check resistance of can bus terminators. Also worth checking fuses with test light, too.

Last edited by KingCake; 10/31/16 09:25 PM.
Re: DTC code: U0101 - "lost communication with TCM" [Re: i_hate_autofraud] #4238535 10/31/16 09:35 PM
Joined: Nov 2004
Posts: 7,999
G
GMBoy Offline
Offline
G
Joined: Nov 2004
Posts: 7,999
9 times out of 10 this code will be a history code (not current) and will not come back. Module traffic on the bus may have been too high for a given moment and the TCM just happened to be the module that could not communicate at that time. It happens on our new vehicles at the plant at times, we check all connections and clear codes. If is is a current code then you do need to look deeper and looking in the air box ECM/TCM connections is a good 1st place to look.

Last edited by GMBoy; 10/31/16 09:36 PM.
Re: DTC code: U0101 - "lost communication with TCM" [Re: GMBoy] #4238596 10/31/16 11:16 PM
Joined: Nov 2015
Posts: 1,462
K
KingCake Offline
Offline
K
Joined: Nov 2015
Posts: 1,462
Originally Posted By: GMBoy
9 times out of 10 this code will be a history code (not current) and will not come back. Module traffic on the bus may have been too high for a given moment and the TCM just happened to be the module that could not communicate at that time. It happens on our new vehicles at the plant at times, we check all connections and clear codes. If is is a current code then you do need to look deeper and looking in the air box ECM/TCM connections is a good 1st place to look.


GM usually puts out new calibrations for cars that are prone to the false codes. Easy to update if you have a SAEJ2534 passthru device like a cardaq2 or something.

Re: DTC code: U0101 - "lost communication with TCM" [Re: KingCake] #4238629 11/01/16 02:00 AM
Joined: Nov 2004
Posts: 7,999
G
GMBoy Offline
Offline
G
Joined: Nov 2004
Posts: 7,999
Originally Posted By: KingCake
Originally Posted By: GMBoy
9 times out of 10 this code will be a history code (not current) and will not come back. Module traffic on the bus may have been too high for a given moment and the TCM just happened to be the module that could not communicate at that time. It happens on our new vehicles at the plant at times, we check all connections and clear codes. If is is a current code then you do need to look deeper and looking in the air box ECM/TCM connections is a good 1st place to look.


GM usually puts out new calibrations for cars that are prone to the false codes. Easy to update if you have a SAEJ2534 passthru device like a cardaq2 or something.


That' true so I checked for 2009 Impala but there are no software/cal updates for this issue.

Re: DTC code: U0101 - "lost communication with TCM" [Re: GMBoy] #4238731 11/01/16 06:41 AM
Joined: Nov 2015
Posts: 1,462
K
KingCake Offline
Offline
K
Joined: Nov 2015
Posts: 1,462
Originally Posted By: GMBoy
Originally Posted By: KingCake
Originally Posted By: GMBoy
9 times out of 10 this code will be a history code (not current) and will not come back. Module traffic on the bus may have been too high for a given moment and the TCM just happened to be the module that could not communicate at that time. It happens on our new vehicles at the plant at times, we check all connections and clear codes. If is is a current code then you do need to look deeper and looking in the air box ECM/TCM connections is a good 1st place to look.


GM usually puts out new calibrations for cars that are prone to the false codes. Easy to update if you have a SAEJ2534 passthru device like a cardaq2 or something.


That' true so I checked for 2009 Impala but there are no software/cal updates for this issue.


Bummer. Was worth a shot.

Re: DTC code: U0101 - "lost communication with TCM" [Re: i_hate_autofraud] #4238739 11/01/16 06:54 AM
Joined: Jan 2015
Posts: 1,411
R
ragtoplvr Offline
Offline
R
Joined: Jan 2015
Posts: 1,411
how many miles?
light on
Does it drive ok

Rod

Re: DTC code: U0101 - "lost communication with TCM" [Re: i_hate_autofraud] #4240883 11/03/16 02:46 PM
Joined: May 2016
Posts: 725
I
i_hate_autofraud Offline OP
OP Offline
I
Joined: May 2016
Posts: 725
Hi all,

The lost communication U0101 was found when I scanned the Traction control module, ie it's not getting data from the TCM, so it posted a code. Seems to be current.

When I scanned the TCM directly, no codes.

> 131,000 miles

> no trouble light

> drives OK

If I'm to check grounds and +12 V, what pins on the connectors do I ID for that? Any Pics for that or diagrams?

Thanks

Re: DTC code: U0101 - "lost communication with TCM" [Re: i_hate_autofraud] #4240972 11/03/16 04:43 PM
Joined: Mar 2008
Posts: 9,004
S
slacktide_bitog Offline
Offline
S
Joined: Mar 2008
Posts: 9,004
I had a U-code when my alternator died on me (everything lost power, including the OBD system, hence the no communication)

Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™