Recent Topics
PP 0w20 5QT under $10 after rebate
by dmiko
Today at 01:41 PM
OLM Accuracy
by Youthanasia
Today at 01:34 PM
Supercharged Coyote Engine Oil
by oesman
Today at 01:18 PM
The old and not so old of us.
by CourierDriver
Today at 12:43 PM
Castrol Edge EP 5W30, 3000mi 2004 Ford Expy 5.4L
by jh0
Today at 12:43 PM
H4 100/80 Watt EiKO bulbs
by oldhp
Today at 12:34 PM
Shell 15W40 HTHS
by doolah02
Today at 12:19 PM
What is the benefit of using Lube Gard Red?
by 2012AccentSE
Today at 11:40 AM
RLI 5w30 6080 miles Mazdaspeed 3 2.3
by jc1112
Today at 11:38 AM
Toyota Red in SBC 350??
by Pike51
Today at 11:31 AM
A crooked trail
by Oldmoparguy1
Today at 11:25 AM
IOS 11 for Ipads and Iphones.
by MolaKule
Today at 11:17 AM
The Wheel Reinvented?
by SubLGT
Today at 11:17 AM
Why no love for Castrol GTX Diesel 15w-40???
by CastroPenzoHavoMobil1
Today at 11:09 AM
VPN ?
by pkunk
Today at 10:50 AM
Hellcat OCI
by jkasch
Today at 10:42 AM
Replacing Shimano BB-5500 bottom bracket.
by mrsilv04
Today at 09:13 AM
Mobil1 0w/40 Euro "FS" = Film Strength?
by exShuttlemech
Today at 07:06 AM
Maori Potato
by Silk
Today at 05:01 AM
New 2017 F-150 4x4 10 speed auto
by Ammofirst
Today at 01:15 AM
Newest Members
oesman, TechPleb, brice379, chezchen, CornerSpeed73
62869 Registered Users
Who's Online
82 registered (28oz, 64bawagon, 4WD, Alfred_B, 2010Civic, 5 invisible), 2253 Guests and 14 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
62869 Members
66 Forums
271084 Topics
4495392 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#3313333 - 03/16/14 06:57 AM KN 2002 missing something?
EchoMirage Offline


Registered: 03/15/14
Posts: 1
Loc: nj
i have a KN 2002, marked made in USA (whether thats true or not who knows). it seems to be missing the drainback valve? i have a TG30 which crosses to the KN 2002, and it has a red diaphragm, but the KN has nothing. is this normal for a 2002, or is it a defect?

this is the KN

Top
#3313350 - 03/16/14 07:33 AM Re: KN 2002 missing something? [Re: EchoMirage]
Sayjac Offline


Registered: 10/13/08
Posts: 11417
Loc: The Old North State
Originally Posted By: EchoMirage
i have a KN 2002, marked made in USA (whether thats true or not who knows). it seems to be missing the drainback valve? i have a TG30 which crosses to the KN 2002, and it has a red diaphragm,.....

According the Fram look up, the TG30/PH30 spec no adbv. Based on that, I'd say this is not a defect. As for made in US, likely one of the older Champ made K&N's.

http://www.framcatalog.com/PartDetail.aspx?b=F&pn=TG30

http://www.framcatalog.com/PartDetail.aspx?b=F&pn=PH30

welcome

Top