Recent Topics
White Marking Pen
by artbuc
11/21/17 04:03 AM
Thoughts on portable air tank 5 gallon for tires
by 901Memphis
11/21/17 03:16 AM
NEW AMAZON HD 10 FIRE TABLET BLACK FRIDAY SALE
by bmwjohn
11/21/17 12:57 AM
First oil change on '16 Camry.
by andyd
11/20/17 11:42 PM
It's that time of year...
by gregk24
11/20/17 10:04 PM
Cut open: Mobil 1 M212-A used 14,237 miles
by gonefishing
11/20/17 09:59 PM
greasing leaf springs to prevent rust?
by motor_oil_madman
11/20/17 09:17 PM
Red Line 15W50, 6k mi OCI, 75k mi, Cadillac CTS-V
by Emperors6
11/20/17 09:06 PM
Discount Tire Direct started Thanksgiving sales.
by dan_erickson
11/20/17 09:00 PM
Cleaning my 50's drill press
by JHZR2
11/20/17 08:46 PM
2011 Fusion 2.5, 17.1k mi UOA, PUP 0W20, Napa Plat
by SubieRubyRoo
11/20/17 08:30 PM
ATF-HP, can not fnd local
by Davej98092
11/20/17 08:29 PM
Control arm bushing washers
by PhuongFU
11/20/17 08:27 PM
Wrong oil in engine
by WmJ
11/20/17 08:18 PM
Anyone using RLI Bio Syn oil?
by Pajero
11/20/17 07:49 PM
Delo and Klondike CK-4 15W40 VOA
by PiperOne
11/20/17 07:19 PM
Digital Torque wrenches
by Ndx
11/20/17 07:07 PM
400,000 miles of Duramax Oil samples
by PiperOne
11/20/17 07:00 PM
Replacing my tires on my one day old new car
by Finklejag
11/20/17 06:54 PM
Motul X-clean 5w/30 FE - 2017 STI - 3,900 miles
by Tiir
11/20/17 06:27 PM
Newest Members
WmJ, MJ90, Davej98092, pabloabarth, shore48
63462 Registered Users
Who's Online
19 registered (Chewie, BlakeB, 901Memphis, chrismo, Black_Thunder, 3 invisible), 883 Guests and 16 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
63462 Members
66 Forums
274102 Topics
4555735 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#3295650 - 02/26/14 10:04 PM The one time I did not have a phone pic....
daves87rs Offline


Registered: 02/23/09
Posts: 16588
Loc: Michigan
I wish I really would have had my phone to catch a pic of what I saw: The media of my AC Delco RIPPED while getting an oil change....

I've used Delco cartridges since I've owned ecotec engines...since 2003. Never an issue. Ever. So you can picture my surprise while watching my oil change (yes, too cold for me to do it) and they pulled the filter out...boy, was a mess! With all the strange things going on with this car, this could explain a bunch...I mean, this thing was nearly in two pieces!


Not sure what to think about this either. While I've used other filters, I've never had this happen....

Car now has a fresh fill of QSUD and a fram Ultra filter...and is happy as a clam!

I kinda wanted to take it home to take a picture of it (true Bitoger there), but I had nothing to put it in...they had already trashed the fram box...so sadly, no pictures.


Not sure what have caused it either.....
_________________________
Whatever you are, be a good one.

Top
#3295846 - 02/27/14 07:05 AM Re: The one time I did not have a phone pic.... [Re: daves87rs]
Danno Offline


Registered: 10/07/12
Posts: 1717
Loc: Northern Ontario, Canada
Miles on filter, oil in car at the time of failure and car/engine description would be useful.

Top
#3295869 - 02/27/14 07:24 AM Re: The one time I did not have a phone pic.... [Re: Danno]
Kira Offline


Registered: 08/19/10
Posts: 4037
Loc: Champlain/Hudson Valley
That filter elements occasionally tear is an argument for frequent, on-time fluid changes. By extension, occasional tears would be an argument for not going to the absolute longest OCI. Kira

Top
#3296047 - 02/27/14 09:57 AM Re: The one time I did not have a phone pic.... [Re: Danno]
daves87rs Offline


Registered: 02/23/09
Posts: 16588
Loc: Michigan
Originally Posted By: Danno
Miles on filter, oil in car at the time of failure and car/engine description would be useful.



Well, it did mention Ecotec up there....though it belongs in a cavalier. Oil was QSUD 5w30, which had a tad over 5200 miles when changed.


Nothing crazy on this change...good mix o city highway this time. It did have some extra idle time due to the extreme cold the last few months. Old fill was dropped in very late october/early november if I remember right....
_________________________
Whatever you are, be a good one.

Top
#3296773 - 02/27/14 09:04 PM Re: The one time I did not have a phone pic.... [Re: daves87rs]
Danno Offline


Registered: 10/07/12
Posts: 1717
Loc: Northern Ontario, Canada
I would say that is dissappointing performance out of that filter.

Top
#3296882 - 02/27/14 10:48 PM Re: The one time I did not have a phone pic.... [Re: daves87rs]
daves87rs Offline


Registered: 02/23/09
Posts: 16588
Loc: Michigan
Makes wonder if it was just a bad filter...it does happen...
_________________________
Whatever you are, be a good one.

Top