Recent Topics
Easy Roller Dolly Car Jacks
by AirgunSavant
02/27/17 09:25 AM
Motorcraft semi syn wording
by double vanos
02/27/17 08:51 AM
Pentosin ATF 1 LV $2.50/liter + shipping
by Sam_Julier
02/27/17 08:41 AM
Best Battery Maintainer
by Smoky14
02/27/17 08:25 AM
92 Toyota Pickup 2wd brake bushings/pin boots
by BigD1
02/27/17 08:05 AM
NOACK volatility ratings
by Rat407
02/27/17 07:29 AM
Engine shots - 07 Accord @ 100k miles
by AccordK24
02/27/17 06:39 AM
Fender bender city
by CourierDriver
02/27/17 06:07 AM
Schaeffer's representatives
by FowVay
02/27/17 04:02 AM
TRADE: Valvoline 5w20 SM dino (Orange County, CA)
by zorobabel
02/27/17 12:43 AM
How do I identlfy an Exide battery?
by Chris142
02/26/17 11:48 PM
Has anyone replaced iPhone battery?
by maverickfhs
02/26/17 09:40 PM
Replace belt tensioner or just the pulley?
by rationull
02/26/17 09:11 PM
Renewing Black trim
by Eddie
02/26/17 09:08 PM
Anyone still use Durablend?
by car51
02/26/17 08:58 PM
Schaeffer's 9000 5w40 - '03 TDI top end pic
by Alex_V
02/26/17 08:22 PM
What's up with all the storms forming at night?
by motor_oil_madman
02/26/17 08:21 PM
Costco battery warranty
by Kool1
02/26/17 08:05 PM
Just did first oil change with microgreen filter
by FlyingTexan
02/26/17 07:41 PM
Differential oil Infiniti G37x
by chartkor
02/26/17 07:20 PM
Newest Members
jteck75, jviss, xsboredom, Taylorm, banjobilly
60661 Registered Users
Who's Online
96 registered (AlaskaMike, barkingspider, Al, Bandito440, adamrc, 10 invisible), 2027 Guests and 11 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
60661 Members
66 Forums
261628 Topics
4316564 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#2491533 - 01/12/12 05:04 PM Subaru Legacy, Running rich, idle problems
SubaruGuru Offline


Registered: 01/10/12
Posts: 1
Loc: Auburn, WA USA
I have a 91 Subaru Legacy Sedan L 5-Speed EJ22 Engine 140k.. Full synthetic oil every 3k, always!

When I start my Legacy, It idles fine.. 1,300 rmp's. then drops down to 700 rpm's when it reaches operating temp. Which is normal. The check engine light blinks a few times when I first accelerate but never seems to blink after first acceleration. When I push in my clutch, coming to a stop, the engine idles at 300 rpm's and jumps right back up to 700 after a few seconds of engine shaking. Its never died on me the few hundred miles I've driven it like this.. When stopped, sometimes it will drop back to 300 but jump right back to 700. Sometimes.. for a few minutes, the engine runs perfect, doesn't drop rmp's while stopping or stopped.. but will sure enough start right up again.
I cleaned the mass air flow, and sprayed carb cleaner multiple times down the iac valve intake tube.. not much of a difference.
Also been getting bad gas mileage, and fuel smells very rich

The CEL codes I got were:
16- Faulty #3 Injector
35- Faulty Purge valve
42- Abnormal idle switch voltage
49- Incorrect Mass air flow sensor

-These are all weird since I just replaced, the purge valve with a new part over 300 miles ago..
-All my injectors are in the right resistance range 11-12k ohms
-The idle switch did test faulty, but my car has been runnin fine for thousands of miles since I first tested it faulty. It could be the problem, but I'm doubting it. Its slightly low on resistance.
-And the MAF is deff the correct hitachi MAF sensor for the manual transmission. Its not throwing a faulty MAF code

I once put an automatic MAF on, only for a minute.. and the purge valve is new and shows the correct resistance, it seems as if they are old codes still in the ecu... but I've unpluged the battery many times for nights at a time.

Here's a list of the parts I have replaced, trying to fix this prob.

Ignition Wires
Ignition coil
Spark plugs
Fuel pump/strainer (because last time it was failing, sorta did the same thing but way worse.
Fuel Filter
oil change

Top
#2491560 - 01/12/12 05:32 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
Warstud Offline


Registered: 09/02/05
Posts: 4253
Loc: MIchigan
Try cleaning the throttle body and plate. If that doesn't work clean the IAC.

Top
#2491582 - 01/12/12 06:03 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
bk111 Offline


Registered: 06/21/10
Posts: 58
Loc: WA
What about your IACV? Bad VSS also causes some weird issues with these cars

Top
#2491591 - 01/12/12 06:11 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
NHGUY Offline


Registered: 10/09/11
Posts: 4744
Loc: USA
TPS? Vehicle Speed Sensor?

Top
#2491756 - 01/12/12 08:12 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
The_Eric Offline


Registered: 03/31/10
Posts: 5017
Loc: Iowa
Some codes will persist. A while back, I was swapping engines in the wife's 1995 Grand Am, so naturally I had the battery unhooked. After getting it running I was still able to retrieve all the ABS codes stored from a persistent problem.

11-12k ohms? As in 1000's??? That seems high to me. All the injectors I've ever checked have read in the high 7 to low 13 ohm range. Get a mechanic's stethoscope and listen to each of the injectors as the problem is happening. This may take a few attempts. Mentally log the sound of each, listening for "the odd man out" which by the sounds of it, is number 3. Good, properly functioning injectors will sound crisp and metallic through the mech stethoscope. Bad ones will usually either have no sound or a muted, muffled sound.

Also, if you have a scan tool that will give you live data, please post it up as this will aid in the diagnosis.


Edited by The_Eric (01/12/12 08:14 PM)
Edit Reason: added content
_________________________
2005 Lincoln Aviator 4.6 DOHC
2000 Honda Accord 2.3
2001 Hyundai Elantra 2.0
1979 Ford F-150 351M

Top
#2491758 - 01/12/12 08:16 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
Audios Offline


Registered: 11/19/11
Posts: 400
Loc: Lyndhurst NJ
Mass air meter codes can also be triggered by a vacuum leak somewhere in the manifold or intake system. Listen for loud whistling or sucking noises. The car is leaning out due to the extra air getting in past the MAF and trying to correct.
_________________________
2004 Audi A4 Avant-Fuchs GT1 5/40
2002 VW Golf TDI-Mobil 1 5/40 TDT
2005 BMW X3 3.0i Fuchs GT1 5/40
2005 BMW M3 Liqui Moly 10/60

Top
#2491766 - 01/12/12 08:26 PM Re: Subaru Legacy, Running rich, idle problems [Re: Audios]
The_Eric Offline


Registered: 03/31/10
Posts: 5017
Loc: Iowa
Originally Posted By: Audios
Mass air meter codes can also be triggered by a vacuum leak somewhere in the manifold or intake system. Listen for loud whistling or sucking noises. The car is leaning out due to the extra air getting in past the MAF and trying to correct.


A MAF code can also be triggered by an engine running near stall speed.

This is one reason why I suggested the o/p posting up some freeze frame data... Otherwise we could be chasing our tails.
_________________________
2005 Lincoln Aviator 4.6 DOHC
2000 Honda Accord 2.3
2001 Hyundai Elantra 2.0
1979 Ford F-150 351M

Top
#2492306 - 01/13/12 12:53 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
Vikas Online   content


Registered: 07/22/05
Posts: 10876
Loc: NorthEast
Blinking CEL is never good; it indicates severe misfire. Usually it would be because of ignition system problems.

91 Legacy is too old for OBD-II and freeze frame data :-(


Edited by Vikas (01/13/12 12:53 PM)

Top