XG7317, 2 ocis, ~11.5k mi. cut open

Messages
14,449
Location
The Old North State
Thread starter
Topic filter run 2 years, 2.4L Accord. First oci 1 year, with QSUD 0w20, 6400 mi. 40%MM. Second with PP 0w20, 50%MM. Replaced with another XG and M1 0w20 AFE, ~$10/jug after rebate. As expected, nothing unexpected with results here. Likely could have run it another OCI, but two years 11.5k mi, I'm satisfied with my return on this Ultra purchase. Dents in can from Lisle cap wrench with removal. [Linked Image] [Linked Image] [Linked Image]
 
Messages
6,662
Location
Katy, Republic of Texas
Looks good for sure, and agree it could have gone another oil change, but also understand taking it off. I can't make myself leave a filter on for more than one oil change, much less 2 or 3.
 
Messages
24,425
Location
Central Florida
Looks good as usual with any Fram Ultra. I have the same filter on a Mazda that I plan on doing 25K miles..... but with drain / refill every 5K miles.
 
Messages
1,234
Location
USA
Looks like you have hit the correct use of oil and filter on your car. This is the way to do it. To me, it's black enough to change, just right.
 
Messages
4,430
Location
Los Gatos, CA
This is a perfect post for me as I use this filter on several Hondas (1998 thru 2019), Acuras (2006 and 2007) and Nissans (2015). I started running 2 OCIs; now I feel OK doing so. Thank you Sayjac; I will continuing doing so with confidence.
 
Messages
106
Location
Northern Michigan
Originally Posted by JeffKeryk
This is a perfect post for me as I use this filter on several Hondas (1998 thru 2019), Acuras (2006 and 2007) and Nissans (2015). I started running 2 OCIs; now I feel OK doing so. Thank you Sayjac; I will continuing doing so with confidence.
+1, thanks for sharing this...perfect post for me as well.. I have a Honda 2.4l and change oil at 7000-7500mi when the MM% is at 40, all rural driving, 20K miles per year. I Use what ever 0W20 is on sale and have been debating changing the filter ever other change... even though the owners manual and MM system recommend to do so. Was never comfortable doing it with the OEM or similar filter, but using a filter such as this Fram Ultra I am sure I would be fine...It's rated for 20K miles so may as well utilize it.
 
Messages
14,449
Location
The Old North State
Thread starter
Everyone welcome for the c&p. Not running the filter another time less about not having peace of mind, more about after two years just ready to change it for a new one. After that time period over 2 ocis, as noted satisfied I got money's worth out of the topic filter. Based on anecdotes and personal experience with the spin on type, there's no doubt the Ultra up to the task of multiple ocis to 20k miles if one so desires.
 
Messages
12,879
Location
ROCHESTER, NY
I've been using the XG7317 on both, the Altima & Civic in my signature. I've been running ours 1 year/2 full OCIs, starting for each winters OCI(Nov). When I've cut'em open, they look like what you've posted I'm happy to say.
 
Messages
25
Location
Toronto, ON, CA
Thanks for the C&P! I've been using this filter on my 2.4L Accord for the past few years, and have only recently started to do 2 6000mi OCI's on them. I know it's a good filter, but it's still nice to see posts like this that back that up!
 
Last edited:
Messages
13,322
Location
1/2 hr N.E. of Detroit
Looks as-if my wife stopped by and wiped down all the filter parts, just prior to your picture-taking......lol This Ultra pic overwhelm our eyes with quality galore. I'm hoping my two Korean models take a liking to the Ultra. My old Colorado did not. I am a fan of the Champ Mobil-1 filters also. So I have a backup plan for our Kia and Hyundai. I will run either brand for two OCIs (8k) Thanks for sharing.....
 
Last edited:
Messages
4,430
Location
Los Gatos, CA
Originally Posted by LeakySeals
Just wondering was it any more difficult to get off being on longer?
Probably. I started using the Fram Ultra Guard 7317. I have had trouble removing it on the 3 Acura TSXs I service; never had an issue with the M1 and Wix filters. The K24 has the filter mid way up in the back. Stupid. Honda hates me.
 
Top