Recent Topics
Clicked over 300,000 miles today
by asand1
04/16/14 01:28 PM
2015 Hyundai Sonata
by opus1
04/16/14 01:07 PM
Gmail question
by Hokiefyd
04/16/14 12:32 PM
Asus Nexus7 Tablet Users?
by sleddriver
04/16/14 12:03 PM
WTH is this? Yahoo mail question
by 97tbird
04/16/14 11:39 AM
Install real-time lubrication oil quality sensor
by juliansb
04/16/14 11:37 AM
Identifying what motor an oil filter is used on
by graydog
04/16/14 11:24 AM
German Castrol in Accord calling for 5w20?
by kenpoed
04/16/14 11:07 AM
Pennzoil Platinum Low Viscosity Multi-Vehicle ATF
by Cooper
04/16/14 11:05 AM
Pennzoil Platinum CVT-2
by Cooper
04/16/14 11:02 AM
Industrial dual oil filter head
by OAS
04/16/14 10:53 AM
hyundai did a bg44 intake cleaning on my veloster
by waltywalt
04/16/14 10:51 AM
Newest Members
dwreefs, turbomond, buster26, WesleyG, MNLittle
49595 Registered Users
Who's Online
81 registered (97tbird, anonobomber, 97f150, 77GrandPrix, Alex38, 3 invisible), 1978 Guests and 208 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
49595 Members
64 Forums
211954 Topics
3321776 Posts

Max Online: 2551 @ 04/05/14 01:28 PM
Donate to BITOG

Page 1 of 2 1 2 >
Topic Options
#2419262 - 10/28/11 10:12 PM Replaced EGR valve and engine light still comes on
Mark72 Offline


Registered: 09/10/09
Posts: 896
Loc: Illinois
95 chev Lumina w/170k. Took it to my mechanic and he put it on the computer and it indicated the EGR valve is bad. My check engine light would come on like once every few weeks and stay on for a couple minutes. So, I purchased the 160.00 EGR valvge and installed it, but my check engine light is still acting the same. Engine is running smooth and quiet. Idle is smooth as well. Any other ideas what it could be? Could it still be exhaust related but something else? O2 sensor? I will have it diagnosed, but wondered if any of you experienced this same issue. Thank you all. Really value any insight here.

Top
#2419270 - 10/28/11 10:19 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
tomcat27 Offline


Registered: 06/25/09
Posts: 2395
Loc: Midwest
I cant be sure than a GM is the same, but on my 96 Sebring and 07 Caravan I had to actually reset the error code with the scan tool before the light would go off. the instructions with the valve also confirmed that. normally you swap the part and everything is cool..... It's also possible that on an OBD I system it will evenutally clear itself.

Top
#2419276 - 10/28/11 10:31 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
johnsmellsalot Offline


Registered: 07/02/11
Posts: 526
Loc: Texas
I had a check engine light on my '99 Buick Century. It said low flow on EGR valve. I decided to just leave it alone until I had to take my car in for state inspections. When I was replacing my head gaskets, I discovered that the EGR passage way was clogged. My advice to you is to remove the EGR valve and spray some carburetor cleaner in the holes. Get some good carburetor cleaner too. That SuperTech stuff sucks.
_________________________
1999 Buick Century 180,000 miles (first car)
2008 Chrysler PT Cruiser 70,000 miles

Top
#2419278 - 10/28/11 10:32 PM Re: Replaced EGR valve and engine light still comes on [Re: tomcat27]
ComfyShorts Offline


Registered: 04/26/10
Posts: 178
Loc: California
You overpaid for the EGR valve. And just because the code your mechanic pulled out says "Exhaust Gas Recirculation Flow Malfunction" or something of that sort does not = bad egr valve. Read up and educate yourself http://www.obd-codes.com/faq/egr-explained.php Click on the 401/402/403 links as well to see what triggers those codes to be set in the computer.

Top
#2419298 - 10/28/11 11:00 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
beast3300 Online   sleepy


Registered: 12/24/09
Posts: 2919
Loc: Ohio
Clean Ports
_________________________
'03 Regal GS L67: PU 5w30, P1 24011

'98 Regal GS: body scrapped.

'99 Grand Prix L36: Pennzoil Dexos blend 5w30/PF52E

Top
#2419305 - 10/28/11 11:07 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Mark72 Offline


Registered: 09/10/09
Posts: 896
Loc: Illinois
Ok, so when I remove the EGR valve I see the port which is what it sits on top of correct? I should just spray the cleaner right inside those ports? Its not like I can stick a brush in there to clean it. Sorry if I sound ignorant. I've never gotten into this sort of thing with my car before, or any car for that matter.

Top
#2419314 - 10/28/11 11:20 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Stu_Rock Offline


Registered: 09/23/09
Posts: 981
Loc: SF Bay Area (formerly WI)
I have faced this problem before. About 10 years ago, I had a 1994 Oldsmobile 3.1 that had a persistent EGR code. Be warned that you may need to buy a new gasket each time you R&R the valve.

1. Clean the EGR passageway. Use a stiff wire and rod out the plenum passageway and the supply tube.

2. Check that the new EGR valve works correctly. I bought two AC Delco units that were both defective. I finally went with a NAPA unit.

3. Check your exhaust backpressure upstream of the catalytic converter. If the cat is partially clogged, the EGR system fails its tests in these cars. I think what happens is that more exhaust than desired gets diverted back to the engine, and the PCM observes a larger-than-expected decrease in engine speed.

In my case, I needed to replace both the valve and the catalytic converter. Diagnosis is a real challenge when two factors contribute to the fault.

Top
#2419317 - 10/28/11 11:23 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
johnsmellsalot Offline


Registered: 07/02/11
Posts: 526
Loc: Texas
Just spray some cleaner in the port. If the cleaner doesn't drain, its pretty clogged and you might have to remove the intake manifold to thoroughly clean it out. I'll attach a photo to show you what I'm talking about. I used a clothes hanger to poke that gunk out.

I even found a video about EGR valves. http://youtu.be/XgfT3kuY8lc

My manifold was off because I'm replacing the head gaskets.



Uploaded with ImageShack.us



Uploaded with ImageShack.us



Uploaded with ImageShack.us



Uploaded with ImageShack.us
_________________________
1999 Buick Century 180,000 miles (first car)
2008 Chrysler PT Cruiser 70,000 miles

Top
#2419421 - 10/29/11 06:57 AM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Mark72 Offline


Registered: 09/10/09
Posts: 896
Loc: Illinois
Ok, I'm going remove the EGR valve again and spray some cleaner in there...Is it ok to reinstall the EGR valve and run the motor if the port is stll damp from the cleaner? Just wanted to be sure the EGR valve wont suck up any of that moisture and damage it. SIDE NOTE:: I installed the the valve when the engine was not completely cooled down, so this morning I torked the bolts down just a little bit tighter...I could barely turn them as I had it pretty tight to begin with, but could it not being on tight enough cause it to throw an error code as well?

And thank you all, I'm learning a lot here.


Edited by Mark72 (10/29/11 06:58 AM)

Top
#2419501 - 10/29/11 09:38 AM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Rhymingmechanic Offline


Registered: 08/13/04
Posts: 736
Loc: VA
If the port is clogged, just spraying cleaner in there and putting the valve back on probably won't make a difference. As others have mentioned, use something like a piece of coat hanger or heavy wire to make sure your passage is actually clean. I went through this with a Saturn, and had to remove the new valve to clean the intake passage again. I let it soak overnight with a couple ounces of LC20, which doesn't evaporate like throttle body spray.

To verify that your intake passage is plugged, try starting the car with the valve removed. If there is no blockage, it probably won't run because the open port acts like a huge vacuum leak. That will also blow any loose carbon out of the exhaust side. It will be loud.

Top
#2419566 - 10/29/11 10:50 AM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Mark72 Offline


Registered: 09/10/09
Posts: 896
Loc: Illinois
I'll give that a shot..I have a wire coat hanger..that should do it. After I scrape it out, should I take my shop vack to suck on any loose stuff?

Top
#2420038 - 10/29/11 08:32 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Rhymingmechanic Offline


Registered: 08/13/04
Posts: 736
Loc: VA
It's a good idea to use a shop vac if you have one. I used the house vacuum, and it has smelled bad ever since.

I don't know how your intake is set up, but on my Saturn the port was 10 or 12 inches long had a bend between the valve and the opening in the plenum. I didn't realize that at first, so it didn't get cleaned out right.

Top
#2421628 - 10/31/11 05:20 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Mark72 Offline


Registered: 09/10/09
Posts: 896
Loc: Illinois
Man...I am scratching my head. So my mechanic looked at my car..hooked up the computer and got the error code that the 3rd bank of the EGR valve is bad. This is with the new EGR on there. So he cleared the computer and told me to come get it, get it out on the road and see if the engine light comes on again. It's only been coming on when I'm giong 60-70mph on the open road so it's not like the engine light goes on and stays on. Do you think that by clearing the computer after I've already installed the new EGR that the light will not come on again once I get up to cruising speed? He said if it does, then it could be a bad circuit and not necesarily the EGR valve. Also, if so, where would the circuit be? can I replace that msyelf?


Edited by Mark72 (10/31/11 05:24 PM)

Top
#2421684 - 10/31/11 06:40 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
onion Offline


Registered: 02/04/07
Posts: 2097
Loc: kansastan
He's yanking your chain. Clearing the code accomplishes nothing.

He's right that it COULD be a wiring problem. But more likely it's a clogged passage or maybe a cracked tube.
_________________________
The invisible and the imaginary look exactly the same.

Top
#2421778 - 10/31/11 08:08 PM Re: Replaced EGR valve and engine light still comes on [Re: Mark72]
Mark72 Offline


Registered: 09/10/09
Posts: 896
Loc: Illinois
WhatEVER!!! I've know this guy for 20 years, and he is also my friend. He would not lie to me and has no reason to. I trust him. He told me what code popped up after I replaced the valve and he told me to take it out tonight and bring it back in the morning if it is still doing it.

Top
Page 1 of 2 1 2 >