Recent Topics
True Confessions
by leeharvey418
7 minutes 1 second ago
Nun in a Taxi
by Kestas
8 minutes 14 seconds ago
Cruise Ctrl on Rushmore Road Kings
by LoneRanger
11 minutes 30 seconds ago
Happy Halloween BITOGers
by wavinwayne
23 minutes 10 seconds ago
Durango 4.7 a dog in cold weather
by FLORIDA
Today at 02:02 PM
New AC Delco PF48E & PF48 Cut
by DirtyMoe21
Today at 01:50 PM
Shocks for a 1992 XJ?
by Finn
Today at 01:46 PM
01 taurus wont starter after new battery
by volk06
Today at 01:40 PM
Grese for dissimilar metals, rust/water/long time
by Henrik
Today at 01:28 PM
Royal Purple 75/w140 Synthetic:
by Doktor_Bert
Today at 12:33 PM
Diy LED Flood lights
by stockrex
Today at 12:12 PM
garden led lights and battery
by stockrex
Today at 12:11 PM
Newest Members
Thourun, Zach72, SandCastle, ymc226, redwoods73
51758 Registered Users
Who's Online
75 registered (95MarkVIII, aquariuscsm, 943kgt, 440Magnum, AandPDan, 94astro, 3 invisible), 1648 Guests and 171 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
51758 Members
64 Forums
221468 Topics
3502303 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG

Topic Options
#1944185 - 07/06/10 11:25 AM Cruise control not engaging
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
I had my brake light switch replaced recently, and now my CC doesn't seem to work. It goes on and lights up when I press the button on the wheel, but when i'm moving it won't engage it. Can this be related to the brake light switch? Thanks.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944194 - 07/06/10 11:35 AM Re: Cruise control not engaging [Re: EricZoom]
CourierDriver Offline


Registered: 12/27/09
Posts: 3145
Loc: Tennessee
disconnect the neg cable on ur battery and see if it resets thru the computer, I really dont know the answer, but when my dodge stuff acts up , I do that first, sometimes it works.n Leave the cable off for 10 minutes too.
_________________________
2005Buick,LeSabre,L3800engine, 25mpgcity, 31Hwy. 90,000miles
Someday soon, the things we thought were important,may not be so important after all.

Top
#1944197 - 07/06/10 11:39 AM Re: Cruise control not engaging [Re: CourierDriver]
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
Thanks, maybe I'll try that.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944213 - 07/06/10 11:55 AM Re: Cruise control not engaging [Re: EricZoom]
Jim 5 Offline


Registered: 05/25/05
Posts: 4009
Loc: Calgary Canada
Brake switch is the most common issue for cruise control problems given that no electrical switch in the car likely gets as many cycles as this switch.

There are usually two circuits on a brake switch and both of them need to be functioning properly for the cruise to work. Just because your brake lights are functioning, doesn't mean the switch is working properly. I had this same issue on my Chev K1500 a few years ago.

I strongly suspect your brake switch especially since it was recently changed. I'd start by checking if all the wires are connected. There should be at least 4 wires attached.
_________________________
Jim A
07.5 GMC Sierra 2500HD LMM Rotella 15w-40
09 Odyssey EX-L CT 5w-20
66 Bronco QS 10w-30
08 BMW K1200S Rt 15w-40
08 Pitster Pro X4 Rt 15w-40

Top
#1944217 - 07/06/10 12:02 PM Re: Cruise control not engaging [Re: Jim 5]
SLCraig Offline


Registered: 12/21/08
Posts: 5300
Loc: London, ON, Canada
Definitely connected.
When you touch your brakes with cruise on, it will disengage. There is something going on there.

Also, I had the problem on my old Altima where the clutch pedal switch was causing engagement problems of the cruise.
_________________________
2010 Civic SI sedan 6MT
F1 Syn 5w30 | PureONE | Pennzoil MTF

Top
#1944218 - 07/06/10 12:03 PM Re: Cruise control not engaging [Re: SLCraig]
Jim 5 Offline


Registered: 05/25/05
Posts: 4009
Loc: Calgary Canada
Good point about the clutch pedal switch. If you have one, this would be just as important and likely to wear.
_________________________
Jim A
07.5 GMC Sierra 2500HD LMM Rotella 15w-40
09 Odyssey EX-L CT 5w-20
66 Bronco QS 10w-30
08 BMW K1200S Rt 15w-40
08 Pitster Pro X4 Rt 15w-40

Top
#1944227 - 07/06/10 12:08 PM Re: Cruise control not engaging [Re: SLCraig]
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
My car is an ATX, so no clutch. The only thing is the on/off button comes on. It's when i'm moving, it won't engage.
I went back to where I had it installed, and the guy said since it comes on, it must be something else, not the switch.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944247 - 07/06/10 12:30 PM Re: Cruise control not engaging [Re: EricZoom]
Anies Offline


Registered: 01/29/09
Posts: 2735
Loc: NJ
I am assuming this is the Cadillac? If it's the Caddy, your BCM will be the culprit. The BCM is bain on most 2000+ GM vehicles. I had lost Cruise Control at some point in my Impala amongst other things and finally replaced the BCM and blam that and everything else that stopped working is now working.

If its the Mazda, I'll leave it to the others.
_________________________
2013 Toyota Venza LE AWD (mine)
2014 Ford Fusion SE w/Tech (wifey)
+Dealer Serviced

Top
#1944256 - 07/06/10 12:37 PM Re: Cruise control not engaging [Re: EricZoom]
KrisZ Offline


Registered: 12/23/06
Posts: 4267
Loc: Toronto, Canada
If you're talking about your Mazda 6, then the On/Off button is just for arming/disarming the cruise control, and is not dependant on the brake, so your mechanic is wrong and this may be related to the brake light switch.

My Mazda 3 has two light indicators for cruise control, your 6 should be the same, one is called "Cruise Main" and is activated by the On/Off switch, it will remain on, no matter if the cruise is actually engaged or not, pressing the brake pedal will not turn this light off either. Then there is the "Cruise" light that comes on only if the cruise is actually engaged and will shut off if the cancel button or brake pedal is pressed.

If “Cruise” light never comes on when trying to engage cruise, then the brake switch is likely the cause, especially if cruise was functioning properly prior to switch replacement. Also I think your mechanic is just being lazy, because the first rule of troubleshooting is to check the last thing you changed that might be related to the problem, and the brake light switch is directly linked to cruise control operation, instead of dismissing it out right.


Edited by KrisZ (07/06/10 12:45 PM)
_________________________
2006 Mazda3 2.0 - 190,000 Km
2003 Ford Focus ZX5 2.0 Zetec - 160,000Km
Both on good old dino juice smile

Top
#1944272 - 07/06/10 12:55 PM Re: Cruise control not engaging [Re: KrisZ]
dwendt44 Offline


Registered: 05/17/06
Posts: 3571
Loc: Central Wisconsin
Had a Chevy truck once that did this.
The brake switch needed adjustment. Problem fixed.

As the brakes wear, the pedal hung a bit lower, just enough to trip the switch.
Try adjusting the switch for better contact.
_________________________
There's no such thing as:
Too big of a battery,
Too large of a gas tank,
or too loud of a horn,
or too bright headlights.

Top
#1944301 - 07/06/10 01:25 PM Re: Cruise control not engaging [Re: dwendt44]
mechtech2 Offline


Registered: 09/05/06
Posts: 19479
Loc: Chicago Area
The brake has a switch/disconnect for the cruise control.
This is almost assuredly your present problem.

Top
#1944379 - 07/06/10 02:24 PM Re: Cruise control not engaging [Re: mechtech2]
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
Thanks for all the responses. This problem is obviously happening on my Mazda. If it was the Caddy, I would of been covered under warranty.
I do have the same setup as KrisZ's Mazda3 where there's 2 buttons for the CC, and the main one just turns in on. I'm going back to the [censored] shop tomorrow to have him look at it. Hopefully this Putz will not try to talk his way out of it. It seems to be pointing to a problem with the replaced switch being defective, or
not installed correctly.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944673 - 07/06/10 08:14 PM Re: Cruise control not engaging [Re: EricZoom]
Jim 5 Offline


Registered: 05/25/05
Posts: 4009
Loc: Calgary Canada
I'd just let him know that you can take it to him where he can fix it for free, or you can take it elsewhere and if it is diagnosed as a brake switch installation problem then you'll be presenting him with the bill.
_________________________
Jim A
07.5 GMC Sierra 2500HD LMM Rotella 15w-40
09 Odyssey EX-L CT 5w-20
66 Bronco QS 10w-30
08 BMW K1200S Rt 15w-40
08 Pitster Pro X4 Rt 15w-40

Top