Recent Topics
Time to reorder some Fluid Film, got a question
by supton
05/26/15 07:59 AM
Running on water.
by Silk
05/26/15 04:00 AM
Oil at Walmart
by merdog
05/26/15 12:06 AM
MicroGard MGL57021 on 2007 Volvo XC70
by howie2092
05/25/15 11:07 PM
topping off with non-HDEO
by meborder
05/25/15 10:31 PM
Microgard MGL9018 unknown miles - yikes
by MoreCowbellAz
05/25/15 10:29 PM
Have any of you gone to see Fury Road?
by BRZED
05/25/15 09:58 PM
Finally Found Pennzoil Ultra at Walmart
by mike718
05/25/15 09:52 PM
Mopar or Other
by DarthDuty
05/25/15 09:35 PM
Another overfilling ATF question
by mclasser
05/25/15 09:05 PM
ATF for 1997 4l60E
by cdm1993
05/25/15 08:47 PM
Champ Oil Filters, Should I Buy This?
by s1mp13m4n
05/25/15 08:15 PM
Newest Members
Coyote5_0, Nilesh_Dharia, Hoopvillian, Jim232118, Duc
54107 Registered Users
Who's Online
67 registered (ARCOgraphite, Astro14, Bandito440, BearZDefect, 87sammy, A_Harman, 4 invisible), 1553 Guests and 128 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
54107 Members
66 Forums
231871 Topics
3716727 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Topic Options
#1426520 - 04/06/09 12:38 PM Old B&S roto-tiller engine not starting.
nthach Offline


Registered: 01/02/04
Posts: 1702
Loc: California
Me and the neighbor are having a bear of a time to get a old B&S 5HP engine on a rototiller to start, I've tried multiple shots of starting fluid with no avail. We changed the original Champion RCJ8 with a NGK CS1(J19LM equivalent), no go. I pull the starter off and I noticed the flywheel was rusty and so was the coil. Should we replace the coil and clean the flywheel with a flap wheel?

The carb's working fine, the plug smelled like fuel.

Top
#1426546 - 04/06/09 01:03 PM Re: Old B&S roto-tiller engine not starting. [Re: nthach]
tom slick Offline


Registered: 05/26/03
Posts: 8771
Loc: Central Coast, Calif.
Is it getting spark?
_________________________
You get what you pay for...
So keep in mind how much you paid for this advice.

Top
#1426592 - 04/06/09 01:46 PM Re: Old B&S roto-tiller engine not starting. [Re: tom slick]
Quest Offline


Registered: 12/19/04
Posts: 6959
Loc: beaver land EH?
spark, carb, contact point,etc. all needs attention.

Q.
_________________________
"Internet discussion boards act as echo chambers for conspiracy dittoheads" A.Allen

Top
#1426617 - 04/06/09 02:08 PM Re: Old B&S roto-tiller engine not starting. [Re: Quest]
SuperDave456 Offline


Registered: 10/29/08
Posts: 2315
Loc: Dallas, Texas
Ive "fixed" neighbors abused equipment with a new sparkplug.

Sometimes it really is that simple.

Top
#1427037 - 04/06/09 09:15 PM Re: Old B&S roto-tiller engine not starting. [Re: SuperDave456]
nthach Offline


Registered: 01/02/04
Posts: 1702
Loc: California
No spark. I've gotten the motor stripped down to the flywheel, but I lost 1 BB for the recoil. I need to find my 2-jaw puller to yank the flywheel off.

Top
#1427391 - 04/07/09 08:55 AM Re: Old B&S roto-tiller engine not starting. [Re: nthach]
eoghan Offline


Registered: 02/23/06
Posts: 163
Loc: Nebraska
"flywheel was rusty and so was the coil. Should we replace the coil and clean the flywheel with a flap wheel?"

1st thing is to clean up the flywheel use some fine grit sand paper and clean up the magnets on the flywheel and do the same for the legs on the coil (I would try cleaning before replacing the coil) then change the points as well, that along with the new spark plug should do the trick for the spark. If cleaning the coil does not work then yes replace it.

Once you have spark make sure that you have fuel flow check the carb and lines and filter you may have to address those as well. Especially if it has been neglected and had old fuel left in it.

these small engines are pretty simple if they have spark and fuel then it should start.
_________________________
Audaciter beer
Powered by Amsoil & Amsoil accessories!

Top
#1430604 - 04/10/09 01:50 AM Re: Old B&S roto-tiller engine not starting. [Re: eoghan]
nthach Offline


Registered: 01/02/04
Posts: 1702
Loc: California
Polished the flywheel with medium emery cloth and WD-40 for lubrication.

I'm throwing in a new coil and electronic ignition in this thing.

Top
#1432913 - 04/12/09 10:01 PM Re: Old B&S roto-tiller engine not starting. [Re: nthach]
motorcity Offline


Registered: 04/11/08
Posts: 146
Loc: Michigan
If it has the gas tank attached to the bottom of the carb. These carbs are natorious for clogging up, and may need a re-build.

Top
#1432989 - 04/13/09 12:03 AM Re: Old B&S roto-tiller engine not starting. [Re: motorcity]
nthach Offline


Registered: 01/02/04
Posts: 1702
Loc: California
^ it does.

I dropped in a new electronic coil assembly and it did run great but it started to bog down and stall. Do I need any more parts to rebuild the carb?

I'll try a fresh fill of Chevron tomorrow first.


Edited by nthach (04/13/09 12:07 AM)

Top