Recent Topics
Cummins: Standpipe in fuel filter needed or not?
by Extreme-Duty
07/01/16 03:36 PM
Napa Canada, Magnatec, Delvac, Napa 15W-40
by Farmer
07/01/16 02:33 PM
Meijer 4 day sale (4th of july weekend)
by Kwuality
07/01/16 02:14 PM
Brakes for 2012 Subaru Legacy
by Picky1
07/01/16 01:56 PM
Microgreen Oil Filter 50% Off Discount Code
by kohnen
07/01/16 01:51 PM
Don't believe the hype of "never change the oil"
by Fsharp
07/01/16 01:30 PM
tzlk to me about aeroflot
by Jetronic
07/01/16 12:21 PM
My extended drain OCI did not go as intended...
by firemachine69
07/01/16 11:10 AM
Honesty
by stockrex
07/01/16 11:04 AM
Valvoline's New "Cobalt" Grease availability
by EdandSherry
07/01/16 10:47 AM
Mobil Delvac 1 5w40: where to buy?
by car51
07/01/16 10:38 AM
Honda EM7000is stored too long with fuel
by henni
07/01/16 10:04 AM
Newest Members
Jennyp, dcdodge, igolfat8, makomike, Alexas
58338 Registered Users
Who's Online
90 registered (Bgallagher, Alex_V, 2015_PSD, andyd, Bebop367, 11 invisible), 1942 Guests and 10 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
58338 Members
66 Forums
251106 Topics
4116106 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Page 2 of 2 < 1 2
Topic Options
#3431008 - 07/21/14 10:38 AM Re: Motorcraft OE Batteries [Re: Nick R]
badtlc Offline


Registered: 06/08/06
Posts: 4950
Loc: KC
I guess I should throw my $0.02 in on these.

I have had 2. One came in the escape and one came in my 2006 Mazda 6i. It was odd how they both died.

Escape:
Purchased Escape new in April of 2007. Battery died August of 2012.

Mazda6i:
Purchased new in April of 2006. Battery died August of 2011.

It was almost the exact same number of weeks that the two lasted.
_________________________
2007 Ford Escape XLS 2.3L ATX, Trop Artic 5W30, Fram OCOD, 140k+
2015 Chrysler T&C, 45k+

Top
#3431026 - 07/21/14 11:06 AM Re: Motorcraft OE Batteries [Re: Nick R]
OVERKILL Offline


Registered: 04/28/08
Posts: 31808
Loc: Ontario, Canada
We've had many Motorcraft batteries with absolutely fantastic life spans. The OE from the Expedition lasted from new (build date is late '01 IIRC) until December 2009. 8 years. The Exide that we replaced it with bought the farm this past winter at only 4 years old so it was replaced with a Motorcraft.

The OE one in my '89 Town Car lasted something like 10 years. My dad's '03 Town Car still has its original battery crzy

The one in their Expedition (a '00) lasted 8 years......

Just great batteries.
_________________________
02 Expedition
06 Charger R/T
14 Charger SRT-8

Top
Page 2 of 2 < 1 2