Recent Topics
Came to my door wanting candy
by CourierDriver
11/01/14 07:03 AM
79 ford ltd rear main
by sasha
11/01/14 05:48 AM
Mobil 1 HM or Maxlife full synthetic?
by oilmaven
11/01/14 04:56 AM
Mobil 5000 5w30 Or Super Tech 5w30
by crazyoildude
11/01/14 01:59 AM
5/32 enough for Winter?
by SumpChump
10/31/14 11:52 PM
Noise from front wheel area
by weebl
10/31/14 11:31 PM
Need advice.
by joyridin83
10/31/14 11:06 PM
Amsoil SVG or Valvoline synpower 75w90
by donnyj08
10/31/14 10:54 PM
Kia oil control valve
by Propflux01
10/31/14 10:16 PM
Avalanche power steering cooler
by spasm3
10/31/14 09:58 PM
Sharp 42" LED 1080p/120Hz - $299
by mrsilv04
10/31/14 09:50 PM
brake squeak left turn.
by wrcsixeight
10/31/14 09:40 PM
Newest Members
joyridin83, NH73, Blkflg, steam_soldier, Ben_SC
51763 Registered Users
Who's Online
71 registered (BowNisPar, 2009Edge, 65convertible, andyd, brslds, Alamogunr, 10 invisible), 1222 Guests and 179 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
51763 Members
64 Forums
221502 Topics
3502864 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG

Page 3 of 3 < 1 2 3
Topic Options
#3455720 - 08/14/14 07:07 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
Jarlaxle Offline


Registered: 02/02/12
Posts: 4154
Loc: New England
Again, my Caddy has over 100K on its catalysts...passed its last emission test (also IM-240) last year, about 10% the allowable emissions. High-flow cats I think are Magnaflow.
_________________________
1979 Coupe de Ville, 542 stroker, Super Tech 15W40, AC Delco
1995 Dakota, 5.2, VWB 5W-30, NAPA
2012 Suzuki AN400A, M1 10W-40, Caltric

Top
#3465620 - 08/26/14 06:03 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
InvalidUserID Offline


Registered: 08/23/04
Posts: 630
Loc: Bay Area, CA
UPDATE: Replaced EGR, numbers improved quite a bit at 15 mph but not enough at 25 mph. The car was run about 20 minutes prior, 10 minutes on the highway or so (more on temps later). Here are the numbers on this rescan.



The smog shop suggested I come back in the morning when it's a bit cooler (it was 76f at the time). The smog technician said it looked it was going to pass and then the computer kicked him out and then he had to test again, the second time it didn't look good.

Took it to my mechanic right after and he suggested the same. He was surprised when I told him the shop didn't have the big shop fan on the car during the test, said they are supposed to do so. He asked how long the car was being tested and I said it was on the dyno machine for about 15-20 minutes and idling in between runs. He said the EGR passages were good when he replaced the EGR valve.

Would going in the morning be enough and if not, do I need to look at the cooling system or simply replace the 20k mile cat?


Edited by InvalidUserID (08/26/14 06:04 PM)
_________________________
My Cars aka 'ol reliables:
- '96 Camaro 3800 II
- '97 4.0 Grand Cherokee
- '99 Civic EX

Others I service:
- '01 Mustang, '04 Accord V6, and '93 Saturn SL2

Top
#3466388 - 08/27/14 01:42 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
InvalidUserID Offline


Registered: 08/23/04
Posts: 630
Loc: Bay Area, CA
Co-worker of mine asked how the smog went. When I told him about the lack of fan during the smog runs, he thinks that might have had an adverse effect on the numbers as well.

Cooler morning and making sure shop points the fan at the car, numbers improve?
_________________________
My Cars aka 'ol reliables:
- '96 Camaro 3800 II
- '97 4.0 Grand Cherokee
- '99 Civic EX

Others I service:
- '01 Mustang, '04 Accord V6, and '93 Saturn SL2

Top
#3466407 - 08/27/14 01:57 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
Skid Offline


Registered: 06/10/11
Posts: 199
Loc: USA - Southern California
My guess is that your catalyst is fine because the CO and HC levels are OK. I think the head is running hot.

Did you check your cooling system? I'd suggest changing the thermostat and doing some pressure testing (and changing the radiator cap too). Also check the concentration of coolant - too much coolant, too little water will make the head run hotter. Might help to have the heater running during the test as well, but won't hurt at least.

Also, you wrote earlier that "Cooling system just drained/refilled." Perhaps it wasn't fully burped initially and the higher earlier NOx readings were due to that.

Top
#3466427 - 08/27/14 02:35 PM Re: Failed CA emission - high NO [Re: Skid]
Bladecutter Offline


Registered: 02/21/11
Posts: 881
Loc: Arvada, CO
Here's all of the OP's smog tests in one shot:





First one from this thread:



And now this one after replacing the EGR:



I find it off that his NOx emissions are so much higher at lower rpms.
The car must be shifting into a lower gear, and then the tester is taking the reading under load to get the NOX scores to increase, yet all the other emissions get reduced under the same conditions.

I still think it's the convertor, since the readings for NOx are all higher after the years, but OP, try dumping a bottle of Techron Fuel system cleaner into your tank, and run through the whole thing as quickly as you can, to remove any combustion chamber deposits that are increasing NOx readings while under load.

Also, when was the last time plugs and wires were changed?
I know with my old '92 Park Avenue, if I didn't change the wires every year, one wire would start shorting to ground under load, and cause a slight miss. That doesn't seem to be the case with your HC readings, but something is causing the NOx to raise up.

BC.
_________________________
2014 Mazda CX-5 Touring (Soul Red)
2007 Ducati 848
1988 Honda Hawk GT

Top
#3466467 - 08/27/14 03:24 PM Re: Failed CA emission - high NO [Re: Bladecutter]
Skid Offline


Registered: 06/10/11
Posts: 199
Loc: USA - Southern California
Checking the cooling system is much cheaper than changing a catalyst. But it's not my money.

Top
#3466480 - 08/27/14 03:40 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
InvalidUserID Offline


Registered: 08/23/04
Posts: 630
Loc: Bay Area, CA
Thanks for sharing your opinions guys.

Plug wires are relatively new, about 20k on them. Not sure I have enough time to add a cleaner and burn the tank as the sticker expires this weekend. I paid but due to smog fail, it's an incomplete registration. Not sure if I can still get a ticket, don't want to find out.

Re-checked on the coolant: It was flushed and replaced 20k ago but that was about four years ago. Not sure how I overlooked the date in my paperwork. Given how it's four years old, DexCool and that I have/had a very slight timing cover leak, I will get it flushed out and refilled tomorrow at a radiator shop that's fortunately for me, right near a client I'll be at for a few hours.

I have noticed coolant temp gauge taking longer to drop after idling. Not sure if that's related to the NOx and if it is, hopefully a flush and fresh fluid/thermostat takes care of it.


Edited by InvalidUserID (08/27/14 03:42 PM)
_________________________
My Cars aka 'ol reliables:
- '96 Camaro 3800 II
- '97 4.0 Grand Cherokee
- '99 Civic EX

Others I service:
- '01 Mustang, '04 Accord V6, and '93 Saturn SL2

Top
#3466498 - 08/27/14 03:52 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
Skid Offline


Registered: 06/10/11
Posts: 199
Loc: USA - Southern California
Originally Posted By: InvalidUserID

I have/had a very slight timing cover leak...


That would be enough, hence the earlier pressure testing recommendations. My guess - your system is low on pressure because of this leak, and the coolant is boiling at some points in the head (it's like not having a radiator cap). Fix the leak and you'll probably pass.

Top
#3466708 - 08/27/14 06:59 PM Re: Failed CA emission - high NO [Re: Skid]
InvalidUserID Offline


Registered: 08/23/04
Posts: 630
Loc: Bay Area, CA
Originally Posted By: Skid
Originally Posted By: InvalidUserID

I have/had a very slight timing cover leak...


That would be enough, hence the earlier pressure testing recommendations. My guess - your system is low on pressure because of this leak, and the coolant is boiling at some points in the head (it's like not having a radiator cap). Fix the leak and you'll probably pass.


Didn't think a small leak would have such impact. I noticed a small amount of coolant on my garage floor and took it to my mechanic. He pressure tested it, said timing cover had a small leak. Tried some stop-leak to see if it would work. Not that he didn't want to do the repair or take my money (he didn't charge anything) but wanted to see if the easy fix would work for such a small leak.

Any idea how big of a task that timing cover would be? Want to see if the shop can take care of it and a flush in one shot.
_________________________
My Cars aka 'ol reliables:
- '96 Camaro 3800 II
- '97 4.0 Grand Cherokee
- '99 Civic EX

Others I service:
- '01 Mustang, '04 Accord V6, and '93 Saturn SL2

Top
#3468067 - 08/29/14 03:14 AM Re: Failed CA emission - high NO [Re: InvalidUserID]
mehullica Offline


Registered: 08/19/09
Posts: 57
Loc: Modesto,CA
You have a higher than normal level of O2 on your readings. A vacuum leak or lean mixture will raise the O2 levels. Your HC & CO are decent which means you're not having a catalytic converter issue. I think your engine has a small vacuum leak causing a run too hot & fail for NOx. Can you check your O2 readings with a scantool or the obd port with a voltmeter?

Top
#3468264 - 08/29/14 10:20 AM Re: Failed CA emission - high NO [Re: mehullica]
InvalidUserID Offline


Registered: 08/23/04
Posts: 630
Loc: Bay Area, CA
Originally Posted By: mehullica
You have a higher than normal level of O2 on your readings. A vacuum leak or lean mixture will raise the O2 levels. Your HC & CO are decent which means you're not having a catalytic converter issue. I think your engine has a small vacuum leak causing a run too hot & fail for NOx. Can you check your O2 readings with a scantool or the obd port with a voltmeter?


Yes, I have an OBD II scanner. What data should I look at?
_________________________
My Cars aka 'ol reliables:
- '96 Camaro 3800 II
- '97 4.0 Grand Cherokee
- '99 Civic EX

Others I service:
- '01 Mustang, '04 Accord V6, and '93 Saturn SL2

Top
#3468673 - 08/29/14 05:46 PM Re: Failed CA emission - high NO [Re: mehullica]
paulo57509 Offline


Registered: 07/13/03
Posts: 1827
Loc: Tracy, CA
Originally Posted By: mehullica
You have a higher than normal level of O2 on your readings. A vacuum leak or lean mixture will raise the O2 levels. Your HC & CO are decent which means you're not having a catalytic converter issue. I think your engine has a small vacuum leak causing a run too hot & fail for NOx. Can you check your O2 readings with a scantool or the obd port with a voltmeter?


I think '96 Camaros have an air pump (electric) that introduces additional air into the catalytic converter. If an air pump is present, there will always be excess O2 present.
_________________________
1987 Chevrolet Camaro IROC-Z 5.0L
1987 Acura Legend L Coupe 2.7L (5-Speed)
1992 Lumina Euro Coupe 3.1L
1998 Lexus LS400
2003 GMC Safari

Top
#3470048 - 08/31/14 12:23 PM Re: Failed CA emission - high NO [Re: InvalidUserID]
mehullica Offline


Registered: 08/19/09
Posts: 57
Loc: Modesto,CA
Look at your o2 voltages at 2500 rpm on a hot engine. Look at the voltage changes to see if they are switching above & below .5 volts at least a few times a minute. Then let it idle & watch the voltages. Should be above .6-.75 volts at idle with little or no switching under .5 volts.

Top
Page 3 of 3 < 1 2 3