Recent Topics
2014 WSBK Laguna Seca Photo Show...
by BusyLittleShop
07/22/14 01:50 AM
What Cologne Do You Wear?
by Cooper
07/22/14 01:38 AM
Wix filter manufacturing changes ?
by CELICA_XX
07/22/14 01:07 AM
Valvoline Conv. 5 qts 10W30 $14.39 Amazon
by Warstud
07/22/14 12:06 AM
1997 Audi A4 Quatro engine oil recomendations
by Nevets91
07/21/14 11:44 PM
Men's Body Spray
by MolaKule
07/21/14 11:07 PM
Real mechanics don't use Walmart oil filters
by SilverC6
07/21/14 10:12 PM
Canceled my Chase card (fraud alert)
by gathermewool
07/21/14 09:58 PM
Cause of Purolator Media Tears
by slalom44
07/21/14 09:49 PM
Denso Filters
by Clubber_Lang
07/21/14 09:44 PM
Coolant color has changed to light brown
by DarylZero
07/21/14 09:32 PM
Dumping Used Oil Question......
by qwerty1234
07/21/14 09:16 PM
Newest Members
Moral, momay, MatBo911, platypus20, rcube
50704 Registered Users
Who's Online
19 registered (George7941, Clubber_Lang, exxr, chrisri, coach477, 97prizm, 2 invisible), 689 Guests and 216 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
50704 Members
64 Forums
216617 Topics
3408635 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG

Topic Options
#3392436 - 06/08/14 07:07 PM wont start
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
Hello , yesterday i added a bottle of techron injector cleaner and got gas at a different station than usual and today my 09 silverado wont fire ,just turns over ,
im thinking its fuel pump or pressure regulator (checked fuses)
does this seem odd without acting up at all prior to today ,its been running fine
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top
#3392450 - 06/08/14 07:15 PM Re: wont start [Re: BuckShirley]
Eddie Offline


Registered: 12/07/03
Posts: 6584
Loc: Florida, Cape Coral
Did it run fine when you shut it down? If so, I doubt it was the fuel. Something else is most probably the problem. Can you hear the fuel pump running? There is also a fuel pump relay. You may be able to switch relays to see if it is the pump or the rely. Ed
_________________________
CX5 Touring 2.5L :-)

Top
#3392462 - 06/08/14 07:22 PM Re: wont start [Re: BuckShirley]
yonyon Offline


Registered: 03/06/12
Posts: 3492
Loc: NJ, USA
Unfortunately, things do break.

When it's the fuel pump going bad sometimes it makes the driver feel a need to fill up the gas tank. The pump knows it got to you so then when you go to start the truck it won't start. Sometimes they'll be nice and work one more time so you can get home.

When the key is first switched from off to on the pump should run for two seconds and make a humming noise that you can hear while listening closely at the gas tank. Get someone else to turn the key for you because you won't be able to get from the driver's seat to the gas tank in 2 seconds. If you hear the pump run, then you have other things to check.

If you don't hear a hum the pump isn't spinning. Try banging the gas tank at bottom center with a large hammer while someone else tries to start it. The noise will sometimes scare the pump and it will start to work. If it does that, you've caught it! Time for a new pump! If the pump holds its composure and remains silent then you need to check the electricals before condemning the pump.

Top
#3392469 - 06/08/14 07:30 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
It ran fine before and after i got the gas , it acted up today when i went to start it ,no prior symptoms ,
I have to check again about the pump turning on
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top
#3392479 - 06/08/14 07:41 PM Re: wont start [Re: BuckShirley]
Trav Offline


Registered: 11/20/06
Posts: 9085
Loc: MA, Mittelfranken.de
Check for water in the fuel, it wouldn't be the first time.
With ethanol in the fuel its not as cut and dry as it was with regular gas where the water went instantly to the bottom and killed the engine.


Edited by Trav (06/08/14 07:45 PM)
_________________________
ASE L1, Master. Deutsch Meisterbrief.

Top
#3392491 - 06/08/14 07:55 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
Im not hearing fuel pump charge up , its looking expensive already
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top
#3392513 - 06/08/14 08:28 PM Re: wont start [Re: BuckShirley]
Warstud Offline


Registered: 09/02/05
Posts: 2636
Loc: MIchigan
Try spraying some starting fluid into the throttle body and cranking it over.

Top
#3392515 - 06/08/14 08:33 PM Re: wont start [Re: Warstud]
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
I will get some tomorrow !
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top
#3392524 - 06/08/14 08:42 PM Re: wont start [Re: BuckShirley]
Eddie Offline


Registered: 12/07/03
Posts: 6584
Loc: Florida, Cape Coral
As I said before, check the pump relay before going crazy blaming the pump.
_________________________
CX5 Touring 2.5L :-)

Top
#3392544 - 06/08/14 09:03 PM Re: wont start [Re: Eddie]
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
it doesnt have one, It has a fuel pump control module
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top
#3392547 - 06/08/14 09:07 PM Re: wont start [Re: BuckShirley]
toneydoc Offline


Registered: 12/16/11
Posts: 911
Loc: War Eagle
Could be a clogged up fuel filter has happened to me before
_________________________
1994 Jeep 135k Nextgen 5w30HM
2007 Camry 60k QSUD 10w30
2010 Sebring 29k NextGen5w30
2008 HD Ultra 62k Valv20w50
2012 Toyota Rav4 12k Toyo 5w20

Top
#3392596 - 06/08/14 10:02 PM Re: wont start [Re: BuckShirley]
Chris142 Offline


Registered: 06/05/03
Posts: 11043
Loc: apple valley, ca
bang on the tank with a rubber hammer
_________________________
02 Jeep Wrangler super-s 10/30
87 F250 Diesel Delo 15w40
04 Tahoe STHM 10w30
Z400 napa 15w50
KLR250 Maxima 10w40
Polaris Trailblazer delo 5w40

Top
#3394101 - 06/10/14 03:35 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
It was the FPCM , got it back today 1
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top
#3394207 - 06/10/14 06:28 PM Re: wont start [Re: BuckShirley]
yonyon Offline


Registered: 03/06/12
Posts: 3492
Loc: NJ, USA
Good news. How much did it run you?

Top
#3394990 - 06/11/14 05:15 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 8
Loc: Brockport N.Y
Luckily it was covered under the certified warranty!
_________________________
"Back in 82, I could throw a pigskin a quarter mile"

Top