Recent Topics
Personal Locator Beacon
by DeepFriar
08/28/15 06:57 PM
What's your honest opinion? PYB vs PUP longetivity
by jdavis
08/28/15 06:56 PM
You can have this filter if ya want.
by Mrsandman
08/28/15 06:42 PM
Just replaced my
by Lightninrod
08/28/15 06:41 PM
07 Sienna, 3.5l AMSOIL OE5w-30, 6,979 miles
by Rat407
08/28/15 05:54 PM
Power transfer engine in-line w/ shaft drive
by LoneRanger
08/28/15 05:18 PM
5w30 Napa oil and Mann cartridge
by Mrsandman
08/28/15 05:02 PM
Multiple specifications in gear oil question
by Planb
08/28/15 04:45 PM
2001 Grand Cherokee 4.7l Oil Recommendation
by Deltantor
08/28/15 04:28 PM
Picked up some OEM takeoffs, replace now or later?
by Coprolite
08/28/15 04:15 PM
CNN can go fudge themselv
by Andy636
08/28/15 03:54 PM
Plane missing since 1992 found near Kapuskasing
by OVERKILL
08/28/15 03:49 PM
Newest Members
alexautoinc, fastcar22, photohause, beavis87, Coenen93
55178 Registered Users
Who's Online
94 registered (2010_FX4, afree, 268i, Bandito440, BigD1, 8 invisible), 1579 Guests and 163 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
55178 Members
66 Forums
236626 Topics
3812510 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Topic Options
#3392436 - 06/08/14 07:07 PM wont start
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
Hello , yesterday i added a bottle of techron injector cleaner and got gas at a different station than usual and today my 09 silverado wont fire ,just turns over ,
im thinking its fuel pump or pressure regulator (checked fuses)
does this seem odd without acting up at all prior to today ,its been running fine
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top
#3392450 - 06/08/14 07:15 PM Re: wont start [Re: BuckShirley]
Eddie Offline


Registered: 12/07/03
Posts: 7434
Loc: Florida, Cape Coral
Did it run fine when you shut it down? If so, I doubt it was the fuel. Something else is most probably the problem. Can you hear the fuel pump running? There is also a fuel pump relay. You may be able to switch relays to see if it is the pump or the rely. Ed
_________________________
CX5 Touring 2.5L :-)

Top
#3392462 - 06/08/14 07:22 PM Re: wont start [Re: BuckShirley]
yonyon Offline


Registered: 03/06/12
Posts: 3492
Loc: NJ, USA
Unfortunately, things do break.

When it's the fuel pump going bad sometimes it makes the driver feel a need to fill up the gas tank. The pump knows it got to you so then when you go to start the truck it won't start. Sometimes they'll be nice and work one more time so you can get home.

When the key is first switched from off to on the pump should run for two seconds and make a humming noise that you can hear while listening closely at the gas tank. Get someone else to turn the key for you because you won't be able to get from the driver's seat to the gas tank in 2 seconds. If you hear the pump run, then you have other things to check.

If you don't hear a hum the pump isn't spinning. Try banging the gas tank at bottom center with a large hammer while someone else tries to start it. The noise will sometimes scare the pump and it will start to work. If it does that, you've caught it! Time for a new pump! If the pump holds its composure and remains silent then you need to check the electricals before condemning the pump.

Top
#3392469 - 06/08/14 07:30 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
It ran fine before and after i got the gas , it acted up today when i went to start it ,no prior symptoms ,
I have to check again about the pump turning on
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top
#3392479 - 06/08/14 07:41 PM Re: wont start [Re: BuckShirley]
Trav Offline


Registered: 11/20/06
Posts: 12242
Loc: MA, Mittelfranken.de
Check for water in the fuel, it wouldn't be the first time.
With ethanol in the fuel its not as cut and dry as it was with regular gas where the water went instantly to the bottom and killed the engine.


Edited by Trav (06/08/14 07:45 PM)
_________________________
ASE L1, Master. Deutsch Meisterbrief.

Top
#3392491 - 06/08/14 07:55 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
Im not hearing fuel pump charge up , its looking expensive already
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top
#3392513 - 06/08/14 08:28 PM Re: wont start [Re: BuckShirley]
Warstud Offline


Registered: 09/02/05
Posts: 3485
Loc: MIchigan
Try spraying some starting fluid into the throttle body and cranking it over.

Top
#3392515 - 06/08/14 08:33 PM Re: wont start [Re: Warstud]
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
I will get some tomorrow !
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top
#3392524 - 06/08/14 08:42 PM Re: wont start [Re: BuckShirley]
Eddie Offline


Registered: 12/07/03
Posts: 7434
Loc: Florida, Cape Coral
As I said before, check the pump relay before going crazy blaming the pump.
_________________________
CX5 Touring 2.5L :-)

Top
#3392544 - 06/08/14 09:03 PM Re: wont start [Re: Eddie]
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
it doesnt have one, It has a fuel pump control module
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top
#3392547 - 06/08/14 09:07 PM Re: wont start [Re: BuckShirley]
toneydoc Offline


Registered: 12/16/11
Posts: 1292
Loc: War Eagle
Could be a clogged up fuel filter has happened to me before
_________________________
1994 Jeep 142k AZ 10w30 syn
2014 Camry 6k Mobil 1 5w30
2010 Sebring 37k Penn Plat 5w20
2014 HD Ultra 9k HD20w50
2012 Toyota Rav4 18k Mobil 1 0w20AFE

Top
#3392596 - 06/08/14 10:02 PM Re: wont start [Re: BuckShirley]
Chris142 Offline


Registered: 06/05/03
Posts: 12835
Loc: apple valley, ca
bang on the tank with a rubber hammer
_________________________
02 Wrangler durablend 10w40
87 F250 Diesel Mystic 15w50
04 Tahoe super-s 5w30
Z400 Lucas 10w30
KLR250 Maxima 10w40
Polaris Trailblazer delo 5w40

Top
#3394101 - 06/10/14 03:35 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
It was the FPCM , got it back today 1
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top
#3394207 - 06/10/14 06:28 PM Re: wont start [Re: BuckShirley]
yonyon Offline


Registered: 03/06/12
Posts: 3492
Loc: NJ, USA
Good news. How much did it run you?

Top
#3394990 - 06/11/14 05:15 PM Re: wont start [Re: BuckShirley]
BuckShirley Offline


Registered: 04/05/14
Posts: 11
Loc: N.Y
Luckily it was covered under the certified warranty!
_________________________
"Back in 82, I could throw a pigskin a quarter mile"
-Uncle Rico-

Top