Pennzoil Q&A

Click here to participate in the Pennzoil Q&A

Recent Topics
Going to Detroit this weekend
by donnyj08
08/31/15 08:47 PM
Twin Cities/MSP Twin Beech activity?
by Lapham3
08/31/15 08:09 PM
Havoline ProDS Synthetic - 5qts $19.99 @ Advance
by Bud_One
08/31/15 07:32 PM
Where do I purchase Kendall 0w20?
by Joe1
08/31/15 07:15 PM
Purolator PSL-12222, 10.5k CUT OPEN
by car51
08/31/15 07:05 PM
KC-135 turns 59
by tom slick
08/31/15 06:59 PM
O'Reilly Mobil Super and Peak Oil - $2.19 & $2.59
by Greg L
08/31/15 06:58 PM
FS: Motul Multi DCTF, Prospeed RS683 brake fluid
by dparm
08/31/15 06:35 PM
Bad Torque Converter
by outoforder
08/31/15 05:39 PM
New SN Defy Specs?
by 3311
08/31/15 05:24 PM
Fuel in oil; fuel pressure regulator?
by fdcg27
08/31/15 04:33 PM
new to turbos...2016 Kia Sorento 2.0T
by java
08/31/15 04:09 PM
Newest Members
Ampersand001, NStuff, sshazam, KC10SteveQ, V10magnum
55204 Registered Users
Who's Online
108 registered (AnotherDodgeGuy, 01rangerxl, 74DartSport, 901Memphis, aquariuscsm, Atlantis, 17 invisible), 1627 Guests and 148 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
55204 Members
66 Forums
236744 Topics
3814990 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Topic Options
#3333475 - 04/04/14 04:54 PM 2000 cavalier MAP low P0107
eljefino Offline


Registered: 06/15/03
Posts: 26915
Loc: ME
BIL's car. I just swapped the engine/ computer/ harness. 2200 OHV. Worked great for me. Started idling poorly in traffic after driving and warming up. Sometimes.

Checked for vacuum leaks; one teeny tiny one of no consequence plugged-- was for HVAC or something.

Watched live data, 10 inches with or without that hose plugged. Seems low, so I checked out my saturn s series that also uses MAP; it reported 9.5. "They" say I should get 21 at idle. I could get 21 on the "comedown" blipping the throttle.

FWIW, KOEO shows 29.5 inches on the cavalier, 29.7 on the saturn, and 30.2 on my home weather station. LOL

New sensors are $50+, I don't want to just throw one at the car.

Thoughts?

Top
#3333494 - 04/04/14 05:24 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
Merkava_4 Offline


Registered: 01/30/07
Posts: 11943
Loc: Clovis, CA
Standard sea level atmospheric pressure is 29.92 inches of mercury.

The FSM will tell you what the data parameters are supposed to be.

In the meantime, you could check for the presence of reference voltage, signal voltage, and ground at the MAP sensor. Signal voltage has to checked with the MAP sensor still plugged in to the engine harness. The way you check it is by back probing the MAP connector KOEO.

Top
#3333583 - 04/04/14 07:48 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
yonyon Offline


Registered: 03/06/12
Posts: 3492
Loc: NJ, USA
You've been doing car stuff more than long enough to know that 10 inches of mercury at idle is a pretty darned reasonable MAP on most gasoline engines, eljefino. I'd bet a shiny nickel that if you were to look at the freeze frame you'd be seeing something different.

Top
#3333589 - 04/04/14 07:58 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
eljefino Offline


Registered: 06/15/03
Posts: 26915
Loc: ME
Yeah it's a puzzler for sure!

I went out there and disconnected the PCM harnesses and checked them out. Crystal clean. They had been disconnected and flopping around during the motor transplant. Also the action of replugging that sort of thing in sometimes clears oxidation.

Took it for a drive; no issues. Darn intermittent faults.

Worse, the motor I sent to the junkyard had nothing in common with this OHV except the parts-bin MAP. LOL

I think maybe I'm inverted, MAP isn't vacuum, it's what's left. I got it up to near 30 acellerating and down to 2-3 in manual 2nd gear decellerating. So 30 minus 9.5 or 10 is my golden 21 number.

Top
#3333665 - 04/04/14 09:25 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
The_Eric Offline


Registered: 03/31/10
Posts: 4040
Loc: Iowa
Map isn't vacuum. It's absolute pressure. Look it up- it'll explain it better than I can.
_________________________
2001 Hyundai Elantra 2.0
1998 Chevy Malibu 2.4
1995 Pontiac Grand Am 3.1
1979 Ford F-150 351M

Top
#3333696 - 04/04/14 10:02 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
Merkava_4 Offline


Registered: 01/30/07
Posts: 11943
Loc: Clovis, CA
Originally Posted By: eljefino
Took it for a drive; no issues. Darn intermittent faults.


When my Buick needed a MAP sensor, it would fall flat when trying to accelerate. It wouldn't stall, but you could press the accelerator as far as you wanted and the car wouldn't accelerate. On the freeway, it refused to down shift when passing. The computer had no idea the engine was under load. No check engine light because the MAP sensor worked just long enough to keep the computer from setting a code. The only way the technician was able to see the fault was by looking at the seine waves on a scope that had a very fast update speed. So basically, my Buick had the opposite scenario from your Cavalier: it had all the symptoms of a bad MAP sensor, but no CEL.

Top
#3333920 - 04/05/14 08:32 AM Re: 2000 cavalier MAP low P0107 [Re: The_Eric]
Vikas Online   content


Registered: 07/22/05
Posts: 9575
Loc: NorthEast
Originally Posted By: The_Eric
Map isn't vacuum. It's absolute pressure. Look it up- it'll explain it better than I can.

Come on elje; this is something you must have known! Atmospheric pressure is about 30 inches and subtracting 20 inch of vacuum
(which is relative pressure) gives you 10 inches of manifold absolute pressure.

Top
#3334085 - 04/05/14 12:13 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
eljefino Offline


Registered: 06/15/03
Posts: 26915
Loc: ME
Yeah I figured it out like I said above. I thought the internal reference to the sensor was atmospheric, like it would be in a vacuum gauge. No, it's absolute vacuum, so the partial vacuum in the I/M is always "more". Whenever one reads texts about tuning a car up they're always referring to vacuum so I got it turned around in my head. Did I mention that sometimes my ratchets are in reverse? LOL

In order to make this level of vacuum possible, the Russians assemble these things in space orbit by the 1000s. This is why new ones are $70. LOL I got one today for $5 at the junkyard and it might like it better. FTR I was also getting a stumble at idle in neutral at 2300 RPM or so which was fixed with this new MAP. Going to return this heap to BIL later this PM, a 30 mile drive, shake it down.

Top
#3334283 - 04/05/14 05:05 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
Merkava_4 Offline


Registered: 01/30/07
Posts: 11943
Loc: Clovis, CA
Interesting. I didn't know I was on eljefino's ignore list.

Top
#3334357 - 04/05/14 06:34 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
eljefino Offline


Registered: 06/15/03
Posts: 26915
Loc: ME
Not ignoring you, Merkava. I have no FSM, but do have a scan tool to read its output. I couldn't get the old part to make shaky data for me so I wouldn't gain anything (IMO) by backprobing the sensor sitting still. Was trying to collect anecdotes about if my data was accurate.

Oddly, most computer issues I run into are EVAP leaks which are their own delightful puzzle. Fixed one with a split hose staring me right in the face. Most car issues on the beaters I service are suspension and rust related. I don't get much driveability stuff.

Shakedown cruise went great, maybe I fixed it.

Top
#3334385 - 04/05/14 07:14 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
Vikas Online   content


Registered: 07/22/05
Posts: 9575
Loc: NorthEast
so you are saying the new MAP sensor fixed the car?

Top
#3334568 - 04/05/14 10:12 PM Re: 2000 cavalier MAP low P0107 [Re: eljefino]
eljefino Offline


Registered: 06/15/03
Posts: 26915
Loc: ME
It's intermittent! Will have to wait weeks for the final verdict.

I can say that

1) This powertrain in the old car drove ~8 miles home no problem.
2) The OBDII was happy with this engine in the old car, all I/Ms happy.
3) Things were great two weeks ago when I did a shortish test drive, though it got up to temp until the fan came on etc.
4) Things were good today.
5) BIL drove it a few trips and it threw the code and started running rough on decel and leaving idle, but cleared out when he hit 20 MPH or so.
6) There was no physical damage to the sensor or wiring near it from moving the engine.

Top