Recent Topics
Happy Birthday Merkava_4
by Trav
05/03/16 04:56 PM
When should you use grease with moly?
by Jetstreamz06
05/03/16 04:54 PM
VOA Motul 4100 Power 15W50
by GermanAutohaus
05/03/16 04:31 PM
Ace Hardware Pennzoil Yellow May 4th to 9th $2.99
by BigD1
05/03/16 04:23 PM
How often to get tires balanced?
by 2010Civic
05/03/16 03:17 PM
Manual says every 10 K on oil changes
by ceast
05/03/16 02:42 PM
Brake fluid ageing?
by LucasDK
05/03/16 02:39 PM
If Anybody has 60K Lying around
by GumbyJarvis
05/03/16 02:03 PM
144$ lot of 48 Fl-400s/L20195 Eq Filters
by GumbyJarvis
05/03/16 01:29 PM
AT Whine
by DWC28
05/03/16 01:14 PM
GM AutoTrak II fluid
by nthach
05/03/16 12:49 PM
GM 2500HD 75w-90 or 75w-110
by Stewart Fan
05/03/16 12:03 PM
Newest Members
myfarmertan, coachvonyo, ionix, Amtecol, DRAX392
57779 Registered Users
Who's Online
85 registered (ag_ghost, 2015_PSD, 69GTX, 2oldtommy, 901Memphis, 12 invisible), 1807 Guests and 270 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
57779 Members
66 Forums
248418 Topics
4062342 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Page 1 of 6 1 2 3 4 5 6 >
Topic Options
#3282213 - 02/14/14 05:07 PM GM 1.4 Ecotec Failure
Ramblejam Offline


Registered: 11/05/13
Posts: 2161
Loc: Kentucky

Top
#3282218 - 02/14/14 05:13 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
dave1251 Offline


Registered: 07/15/05
Posts: 7963
Loc: Maricopa, AZ
It looks like the owner felt that engine oil was a lifetime fill.
_________________________
make the inside of your engine oil cap white.
don't use.

Top
#3282221 - 02/14/14 05:15 PM Re: GM 1.4 Ecotec Failure [Re: dave1251]
Ramblejam Offline


Registered: 11/05/13
Posts: 2161
Loc: Kentucky
Originally Posted By: dave1251
It looks like the owner felt that engine oil was a lifetime fill.


Amazingly, that was after only 13,000 miles.

Top
#3282223 - 02/14/14 05:15 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
wolf_06 Offline


Registered: 06/11/12
Posts: 453
Loc: Atlantic, Canada
wonder what the OLM was saying...
_________________________
2011 Chevy Cruze 1.8L 6AT
Castrol Edge Syntec w/ Titanium 5w30 - OEM filter

Top
#3282224 - 02/14/14 05:16 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
NHGUY Offline


Registered: 10/09/11
Posts: 4576
Loc: USA
I predict with all these EcoBoost....EcoTec...engines,there will be lots of turbo related failures coming up.You can only push an engine so hard to produce power before something gives.

Top
#3282228 - 02/14/14 05:20 PM Re: GM 1.4 Ecotec Failure [Re: NHGUY]
Voltmaster Offline


Registered: 10/08/12
Posts: 923
Loc: California
Originally Posted By: NHGUY
I predict with all these EcoBoost....EcoTec...engines,there will be lots of turbo related failures coming up.You can only push an engine so hard to produce power before something gives.


+1 naturally aspirated all the way !

Top
#3282231 - 02/14/14 05:22 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
tomcat27 Offline


Registered: 06/25/09
Posts: 2938
Loc: Midwest
what was rebuild cost? how receptive was the owner to the concept that it was their fault?
_________________________
2015 Rogue, 2014 Sentra, 2001 Camry, 2005 Starcraft, 1998 Dodge B1500
1996 Sebring Jx, 1995 Jeep ZJ, 1970 Cougar, 2010 Vstar, 1989 Radian

Top
#3282232 - 02/14/14 05:22 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
BertieBlue Offline


Registered: 02/12/14
Posts: 72
Loc: Ireland
If I saw a local mechanic post something like that he'd be my go-to mechanic for ever.

Great job!

Top
#3282235 - 02/14/14 05:23 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
tomcat27 Offline


Registered: 06/25/09
Posts: 2938
Loc: Midwest
GM should FF those with synthetic, if they don't already
_________________________
2015 Rogue, 2014 Sentra, 2001 Camry, 2005 Starcraft, 1998 Dodge B1500
1996 Sebring Jx, 1995 Jeep ZJ, 1970 Cougar, 2010 Vstar, 1989 Radian

Top
#3282249 - 02/14/14 05:34 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
GutsyGecko Offline


Registered: 08/16/12
Posts: 426
Loc: Youngstown, OH
I don't get it. I thought the olm on the cruze could push 10k on a dexos blend? How did that much happen in 13k!?

Top
#3282253 - 02/14/14 05:42 PM Re: GM 1.4 Ecotec Failure [Re: tomcat27]
Kira Offline


Registered: 08/19/10
Posts: 2265
Loc: Champlain/Hudson Valley
People close their eyes and "pretend" not to know anything all the time.

I heard a lady's engine clicking away in a parking lot upstate and offered to check her oil.

The dipstick was rusted in its tube solidly. The stick crumbled at the top and the handle broke away with no resistance at all.

Too bad. Kira

Top
#3282254 - 02/14/14 05:43 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
Quest Offline


Registered: 12/19/04
Posts: 7354
Loc: beaver land EH?
owner's ignorance with leads to 100% owner's fault.

Q.
_________________________
"Internet discussion boards act as echo chambers for conspiracy dittoheads" A.Allen

Top
#3282255 - 02/14/14 05:43 PM Re: GM 1.4 Ecotec Failure [Re: NHGUY]
artificialist Offline


Registered: 09/23/07
Posts: 8027
Loc: Florida
Originally Posted By: NHGUY
I predict with all these EcoBoost....EcoTec...engines,there will be lots of turbo related failures coming up.You can only push an engine so hard to produce power before something gives.

I have my doubts about such widespread disaster.
Look at how long Volvo has been making turbocharged gasoline engines, and succeeding at it.
A turbocharged gasoline engine is fine when properly designed and maintained.

This picture makes me think of one of my dad's friends. His friend really believed his Toyota Avalon was meant for 7,500 mile oil changes because his manual said so. The engine was destroyed by sludge and replaced under warranty. The dealer mechanic then said that the numbers listed in the manual should be completely different.

In this guy's case, the OLM should have been completely different.
_________________________
2010 Lancer Ralliart Sportback

Top
#3282257 - 02/14/14 05:44 PM Re: GM 1.4 Ecotec Failure [Re: GutsyGecko]
turtlevette Offline


Registered: 12/24/13
Posts: 2677
Loc: Massachusetts
Originally Posted By: GutsyGecko
I don't get it. I thought the olm on the cruze could push 10k on a dexos blend? How did that much happen in 13k!?


Must have been some really cheap oil.
_________________________
USA-1

Top
#3282268 - 02/14/14 05:56 PM Re: GM 1.4 Ecotec Failure [Re: Ramblejam]
aquariuscsm Online   content


Registered: 12/30/06
Posts: 13350
Loc: South Texas,USA
They should've used Mobil 1 EP,they would've had 2k more miles left *shame on you,owner of that car!!* :P
_________________________
1996 Nissan 300ZX 5-speed,Arctic Pearl(#175 of 300)
Syntec 10W40/Fram Ultra
Amsoil MTG(tranny)
Amsoil 80W90 GL5(rear diff)
Mobil 1 ATF
Redline Water Wetter

Top
Page 1 of 6 1 2 3 4 5 6 >