Recent Topics
My UOA with Frantz TP Filter
by Jonzobot
41 minutes 1 second ago
Amsoil Signature Series 5w-30
by Jonzobot
Today at 12:22 PM
A/C condensation in desert climates
by mclasser
Today at 12:21 PM
A trial run
by Ifixyawata
Today at 12:10 PM
Homeowners insurance
by mclasser
Today at 12:07 PM
1999 Toyota Tercel, Amsoil SS 5W-30, 10,000km OCI
by Jonzobot
Today at 11:39 AM
Blains Farm & Fleet 8/25-9/4 $.99 synthetic
by LotI
Today at 11:01 AM
VW 1.8tsi Total Quartz Ineo MC3 7,500 mile OCI
by VR6OOM
Today at 10:41 AM
Where to get adapter nipple from 3/4-16 to 1/16?
by ryaneirich
Today at 09:52 AM
Looking For A New Car-CUV
by metalone
Today at 09:49 AM
Scion XD
by Drew99GT
Today at 09:45 AM
Coolant question. Supposedly changed.
by Martin10
Today at 09:22 AM
Newest Members
ryaneirich, Gabe78, taters, Louis_Desbiens, Burk
58918 Registered Users
Who's Online
87 registered (09_GXP, Artem, ARCOgraphite, Al, Andy636, Andrei, 7 invisible), 1949 Guests and 7 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
58918 Members
66 Forums
253538 Topics
4161909 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Page 4 of 4 < 1 2 3 4
Topic Options
#2558433 - 03/05/12 10:17 PM Re: P0420 Code... CAT or O2 sensors? [Re: Vikas]
TFB1 Offline


Registered: 09/03/10
Posts: 3496
Loc: VA
Here's how to fix that P0420...


Top
#2558481 - 03/06/12 12:01 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1184
Loc: CA
ok.. so I found the last smog check.. done on 7/20/10 so it will most likely have to be tested again in July as CA does biannual inspections.

Here were the readings - keep in mind they put cars on the dyno.

15MPH Test: [email protected] HC PPM:37 (MAX:50) C0: 0.27 (MAX 0.64) NO PPM:444 (MAX:508) PASS
25MPH Test: [email protected] HC PPM:9 (MAX:34) C0:0.00 (MAX 0.78) NO PPM:22 (MAX:761) PASS

does it seem like the converter either wasn't fully warmed up... or does it seem to need replacement? Or can you even tell from these results?

I priced sensors today.. about $220 for both upstream and downstream Denso (OEM style sensors)
_________________________
drive
'02 Saturn SC2 95,682 Maxlife 5w30
'04 Highlander 2AZ 181,442 Mobil 1 HM 5w30
'06 Focus 5MT 2.0 110,205 Maxlife 5w30



Top
#2558586 - 03/06/12 06:41 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
Trav Offline


Registered: 11/20/06
Posts: 14201
Loc: MA, Mittelfranken.de
Its hard to tell from these reading if there is any problem.
IMHO keep this as simple as possible. O2 sensors do get slow, in fact for many years some companies recommended 30K change intervals.
Today they can go much longer but personally over 100K i change them if i suspect a problem.

Whenever you change a cat its a good idea to swap them out anyway especially if they are in the 100k range, so swapping the O2's first makes sense.
If that doesn't cure the problem then you can change the cat. +1 on the Denso O2's, they are quality units.
_________________________
ASE L1, Master. Deutsch Meisterbrief.

Top
#2559034 - 03/06/12 01:55 PM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1184
Loc: CA
Thanks Trav..

I think I will run a bottle of techron, go burn some mileage on the highway, and get the O2 sensors on order, and go from there.

James: I just replaced the spark plugs with OEM Iridiums at 100k and also cleaned the TB at that time.
_________________________
drive
'02 Saturn SC2 95,682 Maxlife 5w30
'04 Highlander 2AZ 181,442 Mobil 1 HM 5w30
'06 Focus 5MT 2.0 110,205 Maxlife 5w30



Top
#2560753 - 03/08/12 02:07 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
ltslimjim Offline


Registered: 08/06/10
Posts: 5505
Loc: WatUpDoc
^As a note, the longer a PEA containing fuel system cleaner can remain in the gas tank the better. It isn't a stripping solvent but a detergent that is best used on a full tank that you will use over a longer during of time.
_________________________
92 Civic Hatch (stolen frown RIP)
07 Honda Fit Sport (A/T) WELCOME thumbsup

Top
#2566212 - 03/13/12 11:40 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1184
Loc: CA
Update:

I took the car out for a nice drive this past weekend with lots of high RPM miles to heat things up. Then as luck would have it, got a flat tire (sidewall) and interrupted my work. Anyhow, I replaced both O2 sensors, and reset the ECU. I also cleaned the MAF and cleared the codes. We will see what happens. I *did* notice the exhaust had a different smell when letting the car idle. Before the sensor changes, the exhaust smelled in excess of fuel. Now, not so much, so hopefully things are better! If not, I suppose a cat replacement is in order!
_________________________
drive
'02 Saturn SC2 95,682 Maxlife 5w30
'04 Highlander 2AZ 181,442 Mobil 1 HM 5w30
'06 Focus 5MT 2.0 110,205 Maxlife 5w30



Top
#2566226 - 03/13/12 11:59 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1184
Loc: CA
Sidebar on the Flat: I jacked the car up and put the spare on.. and continued working on the planned o2 sensor changes on Sunday. Yesterday I took the car and tire to Americas Tire since I bought the tires (and replacement certs) from them. They ended up replacing the tire for free, so I just had to pay the CA environmental tax, and a new certificate. I also opted to purchase a second new tire to have a "matched" set of tread since the other tires are at about 4-5 32nds of tread left. I hope I'm done spending money on this car for awhile, but it is the wife's car... It is comfortable, safe and is relatively inexpensive to drive - less than a new car payment every month, and safe for her and the kids to run around in.
_________________________
drive
'02 Saturn SC2 95,682 Maxlife 5w30
'04 Highlander 2AZ 181,442 Mobil 1 HM 5w30
'06 Focus 5MT 2.0 110,205 Maxlife 5w30



Top
#3228625 - 12/26/13 07:40 PM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
mitmaks Offline


Registered: 10/09/11
Posts: 13
Loc: WA
I was wondering if replacing o2 sensors fixed your issue?

Top
Page 4 of 4 < 1 2 3 4