Recent Topics
hyndai xg350 water pump job
by Chris142
01/28/15 02:03 PM
Evans Waterless Coolant??
by WillB
01/28/15 01:50 PM
Annoying photobucket issue - file names
by Quattro Pete
01/28/15 01:48 PM
Cure for BMW N52 Engine Lifter Ticking Noise(?)
by CrawfishTails
01/28/15 12:34 PM
Hog Rings
by tezzzas
01/28/15 12:05 PM
Snow Plowing Contract: Wants More $ to Move Snow
by gathermewool
01/28/15 12:00 PM
Liqui Moly 10w-60
by goldie2222
01/28/15 11:48 AM
ACEA A5/B5-12 Meeting Oils?
by Ibrahim
01/28/15 11:31 AM
For those of you who flamed me for dissing Texas..
by DBMaster
01/28/15 11:29 AM
Short trips Toyota Corolla OCI
by Luciano
01/28/15 10:57 AM
Virus Bulletin Results
by OVERKILL
01/28/15 10:36 AM
Printer Ink cartridges?
by daman
01/28/15 10:23 AM
Newest Members
NEXT35, mac62989, Dexters, tds, Three77
52632 Registered Users
Who's Online
97 registered (4wheeldog, 01rangerxl, 147_Grain, 97f150, 01_celica_gt, 11 invisible), 1740 Guests and 142 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
52632 Members
66 Forums
225697 Topics
3591357 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Page 2 of 2 < 1 2
Topic Options
#3210224 - 12/08/13 10:23 AM Re: delo 400 for race use? [Re: ericsiewkk]
ericsiewkk Offline


Registered: 08/20/13
Posts: 8
Loc: Malaysia
after 5 days running the delo 400. i notice the hot oil pressure is not as good as liqui moly mos2 10w-40.

i used to get 65psi hot with the LM. delo 400 15w-40 im only getting 55psi hot. both measure at 3krpm.

is there any problem?


Edited by ericsiewkk (12/08/13 10:23 AM)

Top
#3211778 - 12/09/13 10:13 PM Re: delo 400 for race use? [Re: ericsiewkk]
KenO Offline


Registered: 10/29/07
Posts: 1284
Loc: Auburn, GA
At how many RPM's? Whats your hot oil pressure at idle??
_________________________
1995 Volvo 960 ShagginWagon
1995 BMW 328ti
1997 Chevy C2500 5.7l V8
1998 BMW 528i

Top
#3212245 - 12/10/13 11:30 AM Re: delo 400 for race use? [Re: ericsiewkk]
ericsiewkk Offline


Registered: 08/20/13
Posts: 8
Loc: Malaysia
hot idle is 20psi.

Top
#3212397 - 12/10/13 02:06 PM Re: delo 400 for race use? [Re: ericsiewkk]
KenO Offline


Registered: 10/29/07
Posts: 1284
Loc: Auburn, GA
That sounds like plenty of oil pressure to me.
_________________________
1995 Volvo 960 ShagginWagon
1995 BMW 328ti
1997 Chevy C2500 5.7l V8
1998 BMW 528i

Top
#3212890 - 12/10/13 09:42 PM Re: delo 400 for race use? [Re: ericsiewkk]
ericsiewkk Offline


Registered: 08/20/13
Posts: 8
Loc: Malaysia
then it is nothing to worry i guess.

Top
#3213541 - 12/11/13 02:50 PM Re: delo 400 for race use? [Re: ericsiewkk]
forcedtalon Offline


Registered: 12/24/03
Posts: 306
Loc: cary, IL
Changing to a diffrent brand of oil filter will change the pressures as well so keep that in mind.
I also see no problem with the oil pressures you have now.
Oil pressures you should be looking at are the max and the min you are seeing on the gauge.
Do you have an oil temp gauge?
_________________________
Renegade semi syn 20/50
Forged Motor, AWD Talon
Billet stock appearing turbo

95 Jeep Grand Cherokee 5.2L
Delo 15/40

Top
#3218092 - 12/16/13 05:36 AM Re: delo 400 for race use? [Re: ericsiewkk]
ericsiewkk Offline


Registered: 08/20/13
Posts: 8
Loc: Malaysia
at its lowest idle pressure is 10psi after a few 1/4mile run.

its got 50psi by 3krpm and 70psi at 4krpm.

motor is doing great on this oil.

Top
Page 2 of 2 < 1 2