Recent Topics
What does E85 smell like ?
by Merkava_4
07/25/14 03:30 AM
Thoughts on General Grabber AT2
by Camprunner
07/25/14 02:46 AM
Collinite 845 over Meguiars Cleaner Wax
by bobbob
07/25/14 12:57 AM
Micro Guard MGL 3682 (4k miles)
by stang5
07/25/14 12:40 AM
Echo Trimmer Carb rebuild, er upgrade
by Team_FAST
07/24/14 11:02 PM
Dodge Hellcat acceleration times released
by 901Memphis
07/24/14 10:42 PM
Questions about Castrol TWS / Edge Professional
by bimmerdriver
07/24/14 09:38 PM
Pennzoil HM 5w20 in new car
by wemay
07/24/14 09:27 PM
Recalls & more recalls. Cars are now too complex!
by antiqueshell
07/24/14 09:23 PM
Honda MM logic vs. BITOG logic
by Pajamarama
07/24/14 09:07 PM
Alignment done on my ranger
by Blkstanger
07/24/14 08:47 PM
MMO suggestions!
by lawman1909
07/24/14 08:38 PM
Newest Members
tjon, Jonlee89, Tripletsredxj, Brophy, Mamba
50749 Registered Users
Who's Online
48 registered (caravanmike, Andy636, d00df00d, Barbell7, chrisri, 57ChevyLS, 5 invisible), 906 Guests and 239 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
50749 Members
64 Forums
216754 Topics
3411689 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG

Page 2 of 2 < 1 2
Topic Options
#2455700 - 12/07/11 11:18 AM Re: Fixing Bad Catalytic Converters With P0420 [Re: artificialist]
HerrStig Offline


Registered: 08/24/11
Posts: 2929
Loc: Boston, MA
Our "too clever by half" smog cops thought the tailpipe test could be too easily faked, (by using another car, for example) so they rely on a direct connection to the OBDII port. By the time they get around to a tailpipe test AND the OBD II read I hope to be in Florida where a bunch of stuff not needed for actual operation may go overboard. The greenies tell us this stuff is oh so important, (and expensive) yet a number of states and their car owners are totally exempt.

Top
#2456146 - 12/07/11 06:48 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: 55Test]
dailydriver Offline


Registered: 03/14/06
Posts: 6820
Loc: Bucks County, Pa.
Actually, the OBD 2 plug in test can be more easily passed than the sniffer test.

Just ask all of those with long tube headers and NO catcons whatsoever who had their ECMs programmed/written out to show NO codes, and ALL I/Ms in ready mode! wink

Now of course, an educated, 'aware'/OCD smog inspector will break out the mirrors and see no catcons, or recognise fake catcon sheilds welded to the header collector, but if this is not done as a matter of procedure, the 'cheater' is home free. smile

Also, at this point tuners/programmers are so good that some catconless cars could actually pass a sniffer test with a precision tune.
_________________________
2000 Z28 1SC 6 speed 170K miles
Red Line 0W-40/Sustina 0W-20 (80/20 mix)
Amsoil EaO 64 filter
Millers CRX 75-140 NT/4oz. XL-3
Ravenol MTF-2

Top
#2456551 - 12/08/11 02:02 AM Re: Fixing Bad Catalytic Converters With P0420 [Re: KeithS_NW_Ohio]
chevrofreak Offline


Registered: 06/17/05
Posts: 4899
Loc: Billings, MT
Originally Posted By: KeithS_NW_Ohio


Spacers are easier, unless you buy a simple plug-in kit.
_________________________
I <3 Red Line oil

Top
#2456959 - 12/08/11 12:54 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: L_Sludger]
JTK Offline


Registered: 08/14/03
Posts: 7157
Loc: Buffalo, NY
Originally Posted By: L_Sludger
A good fix for P0420 is a couple of spark plug anti-foulers screwed into the post-cat O2 sensor bung, with the O2 sensor screwed in at the end.


Now that's a sweet idea! It pushes the sensor up and out of the exhaust stream.

I know shops in my area would have no reason to even look at the O2 sensors provided there's no reason to.
_________________________
2014 Subaru XV Crosstek 2.0L, 5spd, 2013 Dodge Grand Caravan SE (Babe magnet III)

Top
#3391904 - 06/08/14 01:01 AM Re: Fixing Bad Catalytic Converters With P0420 [Re: JTK]
biron Offline


Registered: 01/15/08
Posts: 19
Loc: minnesota
I just cleaned my 15 year old factory fitted catalytic converter using the citric acid/oxalic acid heated to 150F for about 5 hours method and to my surprise, it worked!

It cleaned up the honeycomb inside the cat quite nicely. All the light grey carbon is gone leaving clean metal on the inside. I have to say I'm quite happy that this method worked so well. No more P0420 code!

Here's the story....This is the factory cat from my 1999 Dodge Grand Caravan 3.8 that had about 475,000 miles on it when the P0420 code kept coming on back in October of 2012. I took the factory cat off, put it behind the shed and replaced it with a new Magnaflow aftermarket cat from O'Reilly's.

While the Magnaflow fit very well and appeared well made, it didn't last long, only about 65K miles before it repeatedly set off the P0420 code.

This Magnaflow cat was in my opinion, inferior to the factory cat because it was shorter, made of thinner metal, the flex joint creaked over bumps and for some reason, it set up weird resonances through the van at certain rpm's.

When the factory cat and the Maganaflow were placed side by side the factory cat measured about 9.25 inches long on the catalyst section and the Maganflow measured about 6.25 inches long. The width of the factory cat was 6.25 vs about 5.75 for the Magnflow and the thickness of the factory cat was a good 3/8th's thicker as well. I felt the added length, width and thickness and what felt to me to be thicker and heavier metal made the factory cat much quieter.

I noticed the added noise when I first installed the Magnaflow but at that time, I didn't know how to revive my original cat, so I just lived with the added noise and vibration.

This spring I started getting the P0420 code on my Magnaflow so I decided to research cleaning the cat and after seeing Scotty Kilmer's video on Youtube I thought, "Hmmm, maybe it's that easy, I'll try this on my old cat to see if it works"

So I took my old cat and instead using of dish soap, I used Simple Green. I soaked it in a tall skinny wastebasket for a couple of days and in the meantime researched other methods of cleaning the cat.

I found some guys using vinegar so I tried that for a couple of days after the Simple Green soak. Thinking it would be all clean, I rinsed it and dried it and put it on the van. In just 27 miles, the check engine soon light came on. Not good.

One thing I did notice now that the old cat was back on the van was how much quieter and smoother the engine felt. This confirmed my thinking that the Magnaflow was in fact creating the weird vibrations and a slightly louder exhaust note.

Because the Simple Green and vinegar experiment didn't work and I wanted that check engine light off, I looked for my receipt for the Magnaflow and discovered that it had a 5 year warranty on it so I went to O'Reilly and they promptly replaced my 18 month old Magnaflow with a new unit.

I installed the new replacement Magnaflow and it had the same louder exhaust note and vibration that the previous Magnaflow had. I wasn't pleased about that but the good news was that the check engine light stayed off.

I now felt I needed to try something else to revive my old cat if I wanted both the smoother and quieter function of the factory cat without resorting to the spark plug de-fouler trick or living with the check engine light on.

I had read about the citric acid/oxalic acid method on the Tundra Forum (and other places) and although it seemed a bit complex I decided to track down the products needed. Turns out it was easy to find both the citric acid and the oxalic acid. The citric acid, $2.99, was purchased at Walmart (in the canning section) and the oxalic acid (it's also called Wood Bleach) was purchased at my local Ace Hardware for about $8.00. Cheap.

The formula I used was 2.5 ounces of citric acid and 24 grams of oxalic acid, both at the same time, per gallon. Always wear gloves and safety glasses when mixing or handling this stuff. Do not get any on your skin!

To use the minimum amount of this mixture, I made a 4"X4" plexiglass plate that had four holes in it to match the pattern on the cat flange and put a large o-ring between the flange and the plexi plate to seal the end of the cat and bolted it together.

Standing it on end, cat end down, I then filled it with the citric acid/oxalic acid mix until it came out the oxy sensor hole just above the cat. It took about 3/4 of a gallon to fill to the oxy hole.

The cleaning process called for the cat to be heated to about 150F and because it had about five feet of tube after the cat, I hung it from the ceiling in the garage with the cat end down by using a wire. I then placed two 500W shop lights on it, one on each side spaced about 6 inches away from the cat and they heated it up nicely to between 130 and 160. I used my infrared thermometer to check the temps.

After about five or six hours of heating it, I poured the acid solution into a bucket and it was dirty, sort of a muddy grey sludge collected at the bottom of the bucket after it settled out for a few minutes. Good so far. At least something came out.

I rinsed it with the sprayer on a garden hose and then to dry it, I blew air through it for about an hour using my shop vac. After that I peered inside with my flashlight and 300+ reading glasses and I could clearly see that the areas of the honeycomb that had previously been plugged up with the light grey carbon were now clean and silver in color. Cool. Maybe, just maybe, this will work this time.

I installed the cat leaving the oxy sensor out temporarily while I let the cat warm up and dry further by idling the engine for about 10 minutes. Once warm, I shut the engine off and reinstalled the oxy sensor and took a long drive waiting for the check engine light to come on. The check engine light normally trips at 75 miles. This time it didn't! Another couple hundred miles and no light! Nice.

It's now been about 480 miles and so far so good.

I didn't take any pictures of this process but on the Tundra Forum there are pictures of what the poster there did to his cat and what it looked like when done. Mine looked similar. Clean.

I will update this post as I get a few thousand miles on the cat but so far, this method of cleaning cats seems to work quite well. And it's very inexpensive.

I'm the original owner of this van and it now has 537,000 miles on it and it still runs great.

I've posted a bit on the BITOG By-pass oil filter forum which has a bit more info on how I got so many miles on this van.

Many thanks to all at BITOG - I've learned much about keeping a vehicle running in top form the past ten years - which is part of the reason why this van is still doing so well.

Questions about the cat cleaning? Ask away.

Top
#3391952 - 06/08/14 06:22 AM Re: Fixing Bad Catalytic Converters With P0420 [Re: 55Test]
Vikas Offline


Registered: 07/22/05
Posts: 7836
Loc: NorthEast
Quote:
While the Magnaflow fit very well and appeared well made, it didn't last long, only about 65K miles before it repeatedly set off the P0420 code.
I have to be honest with you but 65K is a long time even for some of the OEM converters!

Thanks for posting this information. Did you try Scotty's paint thinner method? I don't remember if the paint thinner method is supposed to be stronger than the laundry detergent per his video.

Top
#3392084 - 06/08/14 10:30 AM Re: Fixing Bad Catalytic Converters With P0420 [Re: 55Test]
DBMaster Offline


Registered: 09/18/12
Posts: 1926
Loc: Texas
My GF has an 03 Highlander with the side-by-side cat setup (can you say expensive?). She gets that code about 2-3 times a year. Toyota has a TSB related to it and it is just due to the fact that the factory setting for the ECM on the O2 sensor readings is too "tight." I have checked the actual sensor voltages - on all four sensors - and they are working fine. I have also measured cat temps with my IR thermometer - also fine. So, I erase the code and she motors on for another 4-6 months.

Yet another example of how the CEL can sometimes be a dirty trick. Nothing wrong with the car or its level of emissions. Just programming without enough tolerance built in. Toyota will reprogram the ECM per the TSB, however, they won't do it for free.
_________________________

Mike

Top
#3392196 - 06/08/14 01:36 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: Vikas]
biron Offline


Registered: 01/15/08
Posts: 19
Loc: minnesota
I had seen the video of Scotty running a gallon of paint thinner in the tank but I didn't try it. Instead, I ran two cans of Berryman B-12 on a 1/4 tank of gas but it didn't do enough to shut off the check engine light.

Top
#3392210 - 06/08/14 01:54 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: L_Sludger]
justinf89 Offline


Registered: 07/11/10
Posts: 534
Loc: Hampton, VA
Originally Posted By: L_Sludger
A good fix for P0420 is a couple of spark plug anti-foulers screwed into the post-cat O2 sensor bung, with the O2 sensor screwed in at the end.


Didn't work for me. I even tried 2! I'm going to try the acetone route probably because my safari has 230k miles and runs like [censored]. The calalytic converter is welded and I don't feel like messing with it. VA doesn't require tests in my area. As long as the light isn't on...wink wink
_________________________
97 Explorer 4.0L SOHC - 155k - ML 5w-30/PL30001

04 Safari 4.3L - 235k - ML 5w-30/L24011

05 Silverado 6.6L DMX - 135k - Ams AME/EAO52

Top
#3392221 - 06/08/14 02:00 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: biron]
Warstud Offline


Registered: 09/02/05
Posts: 2641
Loc: MIchigan
Originally Posted By: biron
I had seen the video of Scotty running a gallon of paint thinner in the tank but I didn't try it. Instead, I ran two cans of Berryman B-12 on a 1/4 tank of gas but it didn't do enough to shut off the check engine light.


It's actually Laquer Thinner. And it's 9 gallons of gas per 1 gallon of Laquer thinner. And you need to run it at highway speed for about 150 miles. If that doesn't work remove the Cat and soak in laudry detergent overnight. No guarentees.
Scotty Kilmer.

Top
#3392230 - 06/08/14 02:09 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: Warstud]
biron Offline


Registered: 01/15/08
Posts: 19
Loc: minnesota
I meant to write lacquer thinner.

Top
#3392252 - 06/08/14 02:39 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: 55Test]
01rangerxl Offline


Registered: 04/08/06
Posts: 7106
Loc: Birmingham, AL
My truck had a fairly major cat failure, but never set a catalyst efficiency code. In fact, it never set a code at all.

It was acting like it couldn't breathe. Performance was fine below 2500 RPM, then it would kind of fall on its face, then above 3000 RPM it would flash the CEL indicating a misfire, but would not set a code. I could hear major detonation/misfiring going on at these engine speeds. Went over the ignition system and fuel system and nothing was going on there...had to be airflow related.

One day on the highway it started misfiring, I reached over and touched the floorboard...it was HOT. Like really freaking hot. The truck had four converters (LEV, default CA emissions)...I pulled the rear two and ran a serp belt tool through them. I tried to get the two up front, but that was a no-go due to the bends in the pipe. I ended up ordering a Magnaflow y-pipe. Unfortunately the Magnaflow stainless y-pipe looked good, but did not fit the truck at all. Simply impossible to install it on a automatic trans truck. I swapped it for a Walker, and the Walker dropped right in like a glove.

7 months later, no catalyst efficiency code. No CEL at all in fact. Apparently the two Walker pre-cats are doing the job. No misfires, no detonation, no catalyst efficiency code...just a smooth running, slightly louder truck. I fully expected a P0420, but it has not happened.

Not really proud of my "fix" for the rear converters, and may eventually put new ones on as the truck does drone and attracts unwanted attention, but I was quick fixing and when all performance problems went away and there was no CEL, I kind of stopped. I am myself shocked that the CEL has not gone off at all with two rear cats completely gutted. The front two seem to be doing a good job of cleaning, or this old Vulcan just doesn't pass too many nasties through the exhaust somehow. Go figure.

BTW - Tried Mr. Gasket Cataclean and it did nothing.


Edited by 01rangerxl (06/08/14 02:52 PM)
_________________________
2002 Ford Ranger XLT
3.0 V6 / 5-Speed Automatic / 2WD
154K miles

Top
#3392274 - 06/08/14 03:12 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: DBMaster]
wirelessF Offline


Registered: 10/04/07
Posts: 1218
Loc: Oahu, Hawaii
Originally Posted By: DBMaster
My GF has an 03 Highlander with the side-by-side cat setup (can you say expensive?). She gets that code about 2-3 times a year. Toyota has a TSB related to it and it is just due to the fact that the factory setting for the ECM on the O2 sensor readings is too "tight." I have checked the actual sensor voltages - on all four sensors - and they are working fine. I have also measured cat temps with my IR thermometer - also fine. So, I erase the code and she motors on for another 4-6 months.


I had Lucas fuel treatment throw a P0420 in my Toyota truck several times. Ran a full tank without that stuff, cleared the CEL and no more P0420. Even quality of gas or what you put in can throw a code.
_________________________
For racing or off-road use only!

Top
#3392410 - 06/08/14 06:34 PM Re: Fixing Bad Catalytic Converters With P0420 [Re: 55Test]
DBMaster Offline


Registered: 09/18/12
Posts: 1926
Loc: Texas
I tend to agree. I mention to her to stick with one of the stations in our area that sells top tier gas. She mostly buys Murphy from Wally World.
_________________________

Mike

Top
Page 2 of 2 < 1 2