Recent Topics
Honda mower oil question.....
by Clubber_Lang
8 minutes 18 seconds ago
Mopar 0W-20 Oil - Any info on this Oil ?
by JSRT4
15 minutes 39 seconds ago
'05 Scion xB, 10K on M1 5W30 EP, 62 K on car
by bullwinkle
29 minutes 18 seconds ago
BMW K1100LT 1993 valve train photo
by Finn
43 minutes 58 seconds ago
Happy Labor Day!
by Drew99GT
Today at 12:32 PM
2014 Toyota Tacoma Extended Drains
by flyboy8101
Today at 12:06 PM
Smoothest, quitest tire for 2013 Civic sedan?
by flinter
Today at 11:58 AM
New to GDI engines
by daemontrym
Today at 11:40 AM
How not to write a craigslist ad
by Stelth
Today at 11:32 AM
mobil 1 ep or pp 5w30 flavor.
by waltywalt
Today at 10:16 AM
I think it is sludge but not sure
by RobDlouisville
Today at 10:14 AM
Kohler and fuel flooding oil
by rjundi
Today at 10:07 AM
Newest Members
Lexusguy, atomb, snapple37, Speed_Racer, DennisWaller
51164 Registered Users
Who's Online
84 registered (-SyN-, Apollo14, 65f100, andrewlg, 10 invisible), 2093 Guests and 204 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
51164 Members
64 Forums
218629 Topics
3447369 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG

Page 4 of 4 < 1 2 3 4
Topic Options
#2558433 - 03/05/12 10:17 PM Re: P0420 Code... CAT or O2 sensors? [Re: Vikas]
TFB1 Offline


Registered: 09/03/10
Posts: 2622
Loc: VA
Here's how to fix that P0420...


Top
#2558481 - 03/06/12 12:01 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1133
Loc: CA
ok.. so I found the last smog check.. done on 7/20/10 so it will most likely have to be tested again in July as CA does biannual inspections.

Here were the readings - keep in mind they put cars on the dyno.

15MPH Test: RPM@1794 HC PPM:37 (MAX:50) C0: 0.27 (MAX 0.64) NO PPM:444 (MAX:508) PASS
25MPH Test: RPM@1765 HC PPM:9 (MAX:34) C0:0.00 (MAX 0.78) NO PPM:22 (MAX:761) PASS

does it seem like the converter either wasn't fully warmed up... or does it seem to need replacement? Or can you even tell from these results?

I priced sensors today.. about $220 for both upstream and downstream Denso (OEM style sensors)
_________________________
'06 Focus SES 2.0 93,487 QSUD 5w30
'04 Highlander 2.4 157,521 Maxlife 5w30
"God is Great, Beer is Good, and People are Crazy." USA

Top
#2558586 - 03/06/12 06:41 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
Trav Offline


Registered: 11/20/06
Posts: 9509
Loc: MA, Mittelfranken.de
Its hard to tell from these reading if there is any problem.
IMHO keep this as simple as possible. O2 sensors do get slow, in fact for many years some companies recommended 30K change intervals.
Today they can go much longer but personally over 100K i change them if i suspect a problem.

Whenever you change a cat its a good idea to swap them out anyway especially if they are in the 100k range, so swapping the O2's first makes sense.
If that doesn't cure the problem then you can change the cat. +1 on the Denso O2's, they are quality units.
_________________________
ASE L1, Master. Deutsch Meisterbrief.

Top
#2559034 - 03/06/12 01:55 PM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1133
Loc: CA
Thanks Trav..

I think I will run a bottle of techron, go burn some mileage on the highway, and get the O2 sensors on order, and go from there.

James: I just replaced the spark plugs with OEM Iridiums at 100k and also cleaned the TB at that time.
_________________________
'06 Focus SES 2.0 93,487 QSUD 5w30
'04 Highlander 2.4 157,521 Maxlife 5w30
"God is Great, Beer is Good, and People are Crazy." USA

Top
#2560753 - 03/08/12 02:07 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
ltslimjim Offline


Registered: 08/06/10
Posts: 5143
Loc: PL&F
^As a note, the longer a PEA containing fuel system cleaner can remain in the gas tank the better. It isn't a stripping solvent but a detergent that is best used on a full tank that you will use over a longer during of time.
_________________________
1992 Civic VX 275k+
HG replaced, waiting to sample

Top
#2566212 - 03/13/12 11:40 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1133
Loc: CA
Update:

I took the car out for a nice drive this past weekend with lots of high RPM miles to heat things up. Then as luck would have it, got a flat tire (sidewall) and interrupted my work. Anyhow, I replaced both O2 sensors, and reset the ECU. I also cleaned the MAF and cleared the codes. We will see what happens. I *did* notice the exhaust had a different smell when letting the car idle. Before the sensor changes, the exhaust smelled in excess of fuel. Now, not so much, so hopefully things are better! If not, I suppose a cat replacement is in order!
_________________________
'06 Focus SES 2.0 93,487 QSUD 5w30
'04 Highlander 2.4 157,521 Maxlife 5w30
"God is Great, Beer is Good, and People are Crazy." USA

Top
#2566226 - 03/13/12 11:59 AM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
MysticGold04 Offline


Registered: 01/12/05
Posts: 1133
Loc: CA
Sidebar on the Flat: I jacked the car up and put the spare on.. and continued working on the planned o2 sensor changes on Sunday. Yesterday I took the car and tire to Americas Tire since I bought the tires (and replacement certs) from them. They ended up replacing the tire for free, so I just had to pay the CA environmental tax, and a new certificate. I also opted to purchase a second new tire to have a "matched" set of tread since the other tires are at about 4-5 32nds of tread left. I hope I'm done spending money on this car for awhile, but it is the wife's car... It is comfortable, safe and is relatively inexpensive to drive - less than a new car payment every month, and safe for her and the kids to run around in.
_________________________
'06 Focus SES 2.0 93,487 QSUD 5w30
'04 Highlander 2.4 157,521 Maxlife 5w30
"God is Great, Beer is Good, and People are Crazy." USA

Top
#3228625 - 12/26/13 07:40 PM Re: P0420 Code... CAT or O2 sensors? [Re: MysticGold04]
mitmaks Offline


Registered: 10/09/11
Posts: 13
Loc: WA
I was wondering if replacing o2 sensors fixed your issue?

Top
Page 4 of 4 < 1 2 3 4